aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-02-01 11:48:28 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-02-01 12:07:22 +0000
commitd757d5292b7e413356381c09ce0abb09f402e184 (patch)
treeeda26bf73c084a6d9900b79c570df19e903f5103
parent761babb06ef31d5be02f7ac254fd11a9951e4269 (diff)
downloadports-d757d5292b7e413356381c09ce0abb09f402e184.tar.gz
ports-d757d5292b7e413356381c09ce0abb09f402e184.zip
net-mgmt/super_mediator: Ignore with mysql 8.0
- Pet portclippy PR: 269203 Reported by: exp-run Approved by: portmgr (just-fix-it)
-rw-r--r--net-mgmt/super_mediator/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/net-mgmt/super_mediator/Makefile b/net-mgmt/super_mediator/Makefile
index fcc434387562..7107c0db5615 100644
--- a/net-mgmt/super_mediator/Makefile
+++ b/net-mgmt/super_mediator/Makefile
@@ -14,28 +14,27 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfixbuf.so:net/libfixbuf \
libltdl.so:devel/libltdl
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
USES= compiler:c11 gnome libtool pathfix perl5 pkgconfig ssl
USE_GNOME= glib20
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
OPTIONS_DEFINE= SPREAD MYSQL SKIPSET
OPTIONS_DEFAULT= MYSQL SKIPSET
-SPREAD_DESC= Enable Spread libary as a pub/sub distribution capability
MYSQL_DESC= Enable SuperMediator to directly write into MySQL
SKIPSET_DESC= Enable SiLK IPSET files for filtering
+SPREAD_DESC= Enable Spread libary as a pub/sub distribution capability
-SKIPSET_LIB_DEPENDS= libsilk.so:security/silktools
-SPREAD_LIB_DEPENDS= libspread.so:net/spread4
MYSQL_LIB_DEPENDS= libmysqlclient.so:${_MYSQL_CLIENT}
-
MYSQL_USES= mysql
-
MYSQL_CONFIGURE_WITH= mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL=80
+SKIPSET_LIB_DEPENDS= libsilk.so:security/silktools
SKIPSET_CONFIGURE_WITH= skipset
+SPREAD_LIB_DEPENDS= libspread.so:net/spread4
SPREAD_CONFIGURE_WITH= spread
post-install: