aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2023-03-23 13:31:25 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2023-03-24 20:39:52 +0000
commitd7abce9e0506a1abaff98284f3fef73e90f5c9cd (patch)
tree82c9754268335749b45e58086ac8454ffa7b5415
parenteed83f2cc00bb23e233577741df23ab60b1fe5e1 (diff)
downloadports-d7abce9e0506a1abaff98284f3fef73e90f5c9cd.tar.gz
ports-d7abce9e0506a1abaff98284f3fef73e90f5c9cd.zip
x11/wmenu: New port
wmenu is an efficient dynamic menu for Sway and wlroots based Wayland compositors. It provides a Wayland-native dmenu replacement which maintains the look and feel of dmenu. https://sr.ht/~adnano/wmenu PR: 269693 Reviewed by: diizzy, jbeich Differential Revision: https://reviews.freebsd.org/D39230
-rw-r--r--x11/Makefile1
-rw-r--r--x11/wmenu/Makefile28
-rw-r--r--x11/wmenu/distinfo3
-rw-r--r--x11/wmenu/pkg-descr3
4 files changed, 35 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 97e8db4db45d..1f762aa82d52 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -430,6 +430,7 @@
SUBDIR += wmcliphist
SUBDIR += wmctrl
SUBDIR += wmdrawer
+ SUBDIR += wmenu
SUBDIR += wmfocus
SUBDIR += wmsystemtray
SUBDIR += wmutils-core
diff --git a/x11/wmenu/Makefile b/x11/wmenu/Makefile
new file mode 100644
index 000000000000..b645b52c8235
--- /dev/null
+++ b/x11/wmenu/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= wmenu
+DISTVERSION= 0.1.3
+CATEGORIES= x11 wayland
+MASTER_SITES= https://git.sr.ht/~adnano/${PORTNAME}/archive/${DISTVERSIONFULL}${EXTRACT_SUFX}?dummy=/
+
+MAINTAINER= o.hushchenkov@gmail.com
+COMMENT= Efficient dynamic menu for Wayland
+WWW= https://sr.ht/~adnano/wmenu
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= scdoc:textproc/scdoc \
+ wayland-protocols>0:graphics/wayland-protocols
+LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
+ libwayland-client.so:graphics/wayland \
+ libxkbcommon.so:x11/libxkbcommon
+
+USES= compiler:c11 gnome meson pkgconfig
+USE_GNOME= cairo pango
+
+CPPFLAGS+= `pkg-config --cflags epoll-shim`
+LDFLAGS+= `pkg-config --libs epoll-shim`
+
+PLIST_FILES= bin/wmenu \
+ man/man1/wmenu.1.gz
+
+.include <bsd.port.mk>
diff --git a/x11/wmenu/distinfo b/x11/wmenu/distinfo
new file mode 100644
index 000000000000..dc1f58bcc7e8
--- /dev/null
+++ b/x11/wmenu/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1679690334
+SHA256 (wmenu-0.1.3.tar.gz) = 4d1f25b1787d1df203236373d19aec735178d46a3d92b6e0e65a0665dea6e1cb
+SIZE (wmenu-0.1.3.tar.gz) = 17214
diff --git a/x11/wmenu/pkg-descr b/x11/wmenu/pkg-descr
new file mode 100644
index 000000000000..183bfbbfdc8a
--- /dev/null
+++ b/x11/wmenu/pkg-descr
@@ -0,0 +1,3 @@
+wmenu is an efficient dynamic menu for Sway and wlroots based Wayland
+compositors. It provides a Wayland-native dmenu replacement which
+maintains the look and feel of dmenu.