aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:01:56 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:01:56 +0000
commitd7fce4c1c7e2b5d69aa613fb975a363f41f72cdf (patch)
treecf622bc9fb8e9c88fbcb30b98b5a55759cab4c85
parent459d857af3d1d656fdc97c8732af1eca0706dbb5 (diff)
downloadports-d7fce4c1c7e2b5d69aa613fb975a363f41f72cdf.tar.gz
ports-d7fce4c1c7e2b5d69aa613fb975a363f41f72cdf.zip
graphics/py-pyganim: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--graphics/py-pyganim/Makefile6
-rw-r--r--graphics/py-pyganim/files/patch-setup.py18
2 files changed, 22 insertions, 2 deletions
diff --git a/graphics/py-pyganim/Makefile b/graphics/py-pyganim/Makefile
index 17deaa691c02..78d68be40f5a 100644
--- a/graphics/py-pyganim/Makefile
+++ b/graphics/py-pyganim/Makefile
@@ -1,6 +1,6 @@
PORTNAME= pyganim
PORTVERSION= 0.9.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,10 +13,12 @@ WWW= https://inventwithpython.com/pyganim/ \
LICENSE= BSD2CLAUSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game>=0:devel/py-game@${PY_FLAVOR}
USES= python zip
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/graphics/py-pyganim/files/patch-setup.py b/graphics/py-pyganim/files/patch-setup.py
new file mode 100644
index 000000000000..58b2e78b50aa
--- /dev/null
+++ b/graphics/py-pyganim/files/patch-setup.py
@@ -0,0 +1,18 @@
+--- setup.py.orig 2015-08-03 09:20:46 UTC
++++ setup.py
+@@ -2,7 +2,7 @@ setup(
+
+
+ setup(
+- name='Pyganim',
++ name='pyganim',
+ version='0.9.2',
+ url='http://inventwithpython.com/pyganim',
+ author='Al Sweigart',
+@@ -28,4 +28,4 @@ setup(
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ ],
+-)
+\ No newline at end of file
++)