aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-12-31 12:57:46 +0000
committerRene Ladan <rene@FreeBSD.org>2021-12-31 12:57:46 +0000
commitd85222d9669d10c9fd198334bfe7adab61ec6e1a (patch)
tree2135b6dd3ea2bad7075706982bd122e1360eb9c6
parent37475f717ed2d7cf28525fcfc2915428be30e365 (diff)
Mk: unregister expired lang/python36
While here update some examples.
-rw-r--r--Mk/Uses/python.mk22
-rw-r--r--Mk/bsd.default-versions.mk4
2 files changed, 13 insertions, 13 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index 19b5fea01b3c..6c5d11dc9d08 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -17,19 +17,19 @@
# Examples:
#
# USES=python:2.7 # Supports Python 2.7 Only
-# USES=python:3.6+ # Supports Python 3.6 or later
-# USES=python:3.6-3.9 # Supports Python 3.6 to 3.9
+# USES=python:3.7+ # Supports Python 3.7 or later
+# USES=python:3.7-3.9 # Supports Python 3.7 to 3.9
# USES=python:-3.8 # Supports Python up to 3.8
-# USES=python # Supports 3.6+
+# USES=python # Supports 3.7+
#
# NOTE: <version-spec> should be as specific as possible, matching the versions
# upstream declares support for, without being incorrect. In particular,
-# USES=python *without* a <version-spec> means 3.6+,
+# USES=python *without* a <version-spec> means 3.7+,
# including unreleased versions, which is probably incorrect.
#
# Not specifying a <version-spec> should only be used when a more specific
# <version-spec> cannot be specified due to syntax limitations, for
-# example: 2.7,3.4-3.6, but even in this case, X.Y+ (2.7+), or -X.Y (-3.6)
+# example: 2.7,3.7-3.8, but even in this case, X.Y+ (2.7+), or -X.Y (-3.7)
# is preferred and likely more correct.
#
# patch Python is needed at patch time. Adds dependency to PATCH_DEPENDS.
@@ -184,7 +184,7 @@
# interpreter, e.g. 2, 3, ...
#
# PYTHON_VER - The major-minor release version of the chosen Python
-# interpreter, e.g. 2.7, 3.6, ...
+# interpreter, e.g. 2.7, 3.7, ...
#
# PYTHON_ABIVER - Additional ABI flags set by the chosen Python
# interpreter, e.g. md
@@ -248,7 +248,7 @@ _INCLUDE_USES_PYTHON_MK= yes
# What Python version and what Python interpreters are currently supported?
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
-_PYTHON_VERSIONS= 3.8 3.9 3.7 3.6 3.10 3.11 2.7 # preferred first
+_PYTHON_VERSIONS= 3.8 3.9 3.7 3.10 3.11 2.7 # preferred first
_PYTHON_PORTBRANCH= 3.8 # ${_PYTHON_VERSIONS:[1]}
_PYTHON_BASECMD= ${LOCALBASE}/bin/python
_PYTHON_RELPORTDIR= lang/python
@@ -327,13 +327,13 @@ DEV_WARNING+= "lang/python27 reached End of Life and will be removed on 2020-12
.elif ${_PYTHON_ARGS} == 2
DEV_ERROR+= "USES=python:2 is no longer supported, use USES=python:2.7"
.elif ${_PYTHON_ARGS} == 3
-DEV_ERROR+= "USES=python:3 is no longer supported, use USES=python:3.6+ or an appropriate version range"
+DEV_ERROR+= "USES=python:3 is no longer supported, use USES=python:3.7+ or an appropriate version range"
.endif # ${_PYTHON_ARGS} == 2.7
_PYTHON_VERSION:= ${PYTHON_DEFAULT}
.if empty(_PYTHON_ARGS)
-_PYTHON_ARGS= 3.6+
+_PYTHON_ARGS= 3.7+
.endif
# Validate Python version whether it meets the version restriction.
@@ -435,7 +435,7 @@ PKGNAMESUFFIX= ${PYTHON_PKGNAMESUFFIX}
# To avoid having dependencies with @ and empty flavor:
# _PYTHON_VERSION is either set by (first that matches):
# - If using Python flavors, from the current Python flavor
-# - If using a version restriction (USES=python:3.6+), from the first
+# - If using a version restriction (USES=python:3.7+), from the first
# acceptable default Python version.
# - From PYTHON_DEFAULT
PY_FLAVOR= py${_PYTHON_VERSION:S/.//}
@@ -466,7 +466,7 @@ PYTHON_CMD?= ${_PYTHON_BASECMD}${_PYTHON_VERSION}
.if exists(${PYTHON_CMD}-config)
PYTHON_ABIVER!= ${PYTHON_CMD}-config --abiflags
.elif ${PYTHON_REL} < 30800
-# Default ABI flags for lang/python3[67] ports
+# Default ABI flags for lang/python37 port
PYTHON_ABIVER= m
.endif
.endif
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index 53519b606af4..461bc25cfcaa 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -109,11 +109,11 @@ PERL5_DEFAULT:= ${_PERL5_FROM_BIN:R}
PGSQL_DEFAULT?= 13
# Possible values: 7.3, 7.4, 8.0
PHP_DEFAULT?= 7.4
-# Possible values: 2.7, 3.6, 3.7, 3.8, 3.9, 3.10, 3.11
+# Possible values: 2.7, 3.7, 3.8, 3.9, 3.10, 3.11
PYTHON_DEFAULT?= 3.8
# Possible values: 2.7
PYTHON2_DEFAULT?= 2.7
-# Possible values: 3.6, 3.7, 3.8, 3.9, 3.10
+# Possible values: 3.7, 3.8, 3.9, 3.10
PYTHON3_DEFAULT?= 3.8
# Possible values: 2.6, 2.7, 3.0, 3.1
RUBY_DEFAULT?= 2.7