aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2023-08-01 14:56:33 +0000
committerCy Schubert <cy@FreeBSD.org>2023-08-01 18:06:52 +0000
commitd8da18a69ca0bc07e6566ee7bf92eb100ba7b08f (patch)
tree9e8ce57048a5ecb52516b7f26220edd0c15f2016
parente3870422c83310c98c03bf15312bf046a0fe17b5 (diff)
downloadports-d8da18a69ca0bc07e6566ee7bf92eb100ba7b08f.tar.gz
ports-d8da18a69ca0bc07e6566ee7bf92eb100ba7b08f.zip
sysutils/nut-devel: Remove GCC requirement.
Remove the GCC requirement by adding -lpthread and removing the nullification of CFLAGS and LDFLAGS in the M4 script that verifies we have a working libltdl.
-rw-r--r--sysutils/nut-devel/Makefile3
-rw-r--r--sysutils/nut-devel/files/patch-m4_nut__check_libltdl.m421
2 files changed, 22 insertions, 2 deletions
diff --git a/sysutils/nut-devel/Makefile b/sysutils/nut-devel/Makefile
index f119ef8d95e4..fea20af2d89a 100644
--- a/sysutils/nut-devel/Makefile
+++ b/sysutils/nut-devel/Makefile
@@ -22,7 +22,6 @@ GH_TAGNAME= 2ced48d1b
NUT_COMMIT_DATE= 2023.07.30
MAKE_JOBS_UNSAFE= yes
-USE_GCC= yes
GNU_CONFIGURE= yes
USES= autoreconf:build compiler:c11 gmake libtool pkgconfig python
USE_LDCONFIG= yes
@@ -84,7 +83,7 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/nut \
--with-dev \
--with-ltdl --with-nut-scanner
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib -lpthread
LIB_DEPENDS+= libltdl.so:devel/libltdl
# XXX Remove this when copying this port to sysutils/nut. The GA version
diff --git a/sysutils/nut-devel/files/patch-m4_nut__check_libltdl.m4 b/sysutils/nut-devel/files/patch-m4_nut__check_libltdl.m4
new file mode 100644
index 000000000000..ae4a2710adf5
--- /dev/null
+++ b/sysutils/nut-devel/files/patch-m4_nut__check_libltdl.m4
@@ -0,0 +1,21 @@
+--- m4/nut_check_libltdl.m4.orig 2023-08-01 07:33:24.593954000 -0700
++++ m4/nut_check_libltdl.m4 2023-08-01 07:35:18.506094000 -0700
+@@ -10,10 +10,7 @@
+ dnl No NUT_CHECK_PKGCONFIG here: (lib)ltdl.pc was not seen on any OS
+
+ dnl save CFLAGS and LIBS
+- CFLAGS_ORIG="${CFLAGS}"
+- LIBS_ORIG="${LIBS}"
+ LIBS=""
+- CFLAGS=""
+ dnl For fallback below:
+ myCFLAGS=""
+
+@@ -71,7 +68,5 @@
+ unset myCFLAGS
+
+ dnl restore original CFLAGS and LIBS
+- CFLAGS="${CFLAGS_ORIG}"
+- LIBS="${LIBS_ORIG}"
+ fi
+ ])