aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2022-11-25 07:56:37 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2022-12-11 15:08:54 +0000
commitd9bc838ec26c8f13d97cdd3640c98545266c0252 (patch)
treebedfa324d77a1a2f8eddb33387a2f41a5bd29214
parentac4d327f0569cf2c7a5d1e4fc3387bdd88b14468 (diff)
downloadports-d9bc838ec26c8f13d97cdd3640c98545266c0252.tar.gz
ports-d9bc838ec26c8f13d97cdd3640c98545266c0252.zip
audio/spotifyd: Add an option to compile with dns-sd
Add an option DNS-SD to compile the librespot crate with dns-sd support instead of relying on the built in mDNS functionality. This allows for compatibility with Avahi. PR: 266980 Reported by: Rafe <mondo.debater_0q@icloud.com>
-rw-r--r--audio/spotifyd/Makefile13
-rw-r--r--audio/spotifyd/distinfo4
-rw-r--r--audio/spotifyd/files/extra-patch.Cargo.toml2
3 files changed, 13 insertions, 6 deletions
diff --git a/audio/spotifyd/Makefile b/audio/spotifyd/Makefile
index 20cdf51dffca..c359b16bd095 100644
--- a/audio/spotifyd/Makefile
+++ b/audio/spotifyd/Makefile
@@ -1,7 +1,7 @@
PORTNAME= spotifyd
DISTVERSIONPREFIX= v
DISTVERSION= 0.3.3
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= audio
MAINTAINER= rodrigo@FreeBSD.org
@@ -90,6 +90,7 @@ CARGO_CRATES= addr2line-0.14.1 \
derive_builder-0.7.2 \
derive_builder_core-0.5.0 \
digest-0.9.0 \
+ dns-sd-0.1.3 \
dotenv-0.13.0 \
dtoa-0.4.4 \
either-1.5.3 \
@@ -416,16 +417,20 @@ PLIST_FILES= bin/spotifyd \
"@sample etc/spotifyd.conf.sample"
PORTDOCS= README.md
-OPTIONS_DEFINE= DBUS DOCS PORTAUDIO PULSEAUDIO ALSA
+OPTIONS_DEFINE= DBUS DOCS PORTAUDIO PULSEAUDIO ALSA DNS-SD
OPTIONS_DEFAULT= PORTAUDIO
DBUS_DESC= D-Bus MPRIS support
+DNS-SD_DESC= Avahi mDNSS support
+
+ALSA_LIB_DEPENDS= libasound_module_pcm_oss.so:audio/alsa-plugins
+ALSA_VARS= CARGO_FEATURES+=alsa_backend
DBUS_LIB_DEPENDS= libdbus-1.so:devel/dbus
DBUS_VARS= CARGO_FEATURES+=dbus_mpris
-ALSA_LIB_DEPENDS= libasound_module_pcm_oss.so:audio/alsa-plugins
-ALSA_VARS= CARGO_FEATURES+=alsa_backend
+DNS-SD_LIB_DEPENDS= libdns_sd.so:net/avahi-libdns
+DNS-SD_EXTRA_PATCHES= ${PATCHDIR}/extra-patch.Cargo.toml
PORTAUDIO_LIB_DEPENDS= libportaudio.so:audio/portaudio
PORTAUDIO_VARS= CARGO_FEATURES+=portaudio_backend
diff --git a/audio/spotifyd/distinfo b/audio/spotifyd/distinfo
index 5cbe6abbd294..f6ca717d5ded 100644
--- a/audio/spotifyd/distinfo
+++ b/audio/spotifyd/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1639912890
+TIMESTAMP = 1664577482
SHA256 (rust/crates/addr2line-0.14.1.crate) = a55f82cfe485775d02112886f4169bde0c5894d75e79ead7eafe7e40a25e45f7
SIZE (rust/crates/addr2line-0.14.1.crate) = 31201
SHA256 (rust/crates/adler-0.2.3.crate) = ee2a4ec343196209d6594e19543ae87a39f96d5534d7174822a3ad825dd6ed7e
@@ -143,6 +143,8 @@ SHA256 (rust/crates/derive_builder_core-0.5.0.crate) = 0288a23da9333c246bb18c143
SIZE (rust/crates/derive_builder_core-0.5.0.crate) = 18313
SHA256 (rust/crates/digest-0.9.0.crate) = d3dd60d1080a57a05ab032377049e0591415d2b31afd7028356dbf3cc6dcb066
SIZE (rust/crates/digest-0.9.0.crate) = 13247
+SHA256 (rust/crates/dns-sd-0.1.3.crate) = d748509dea20228f63ba519bf142ce2593396386125b01f5b0d6412dab972087
+SIZE (rust/crates/dns-sd-0.1.3.crate) = 6201
SHA256 (rust/crates/dotenv-0.13.0.crate) = c0d0a1279c96732bc6800ce6337b6a614697b0e74ae058dc03c62ebeb78b4d86
SIZE (rust/crates/dotenv-0.13.0.crate) = 8807
SHA256 (rust/crates/dtoa-0.4.4.crate) = ea57b42383d091c85abcc2706240b94ab2a8fa1fc81c10ff23c4de06e2a90b5e
diff --git a/audio/spotifyd/files/extra-patch.Cargo.toml b/audio/spotifyd/files/extra-patch.Cargo.toml
index 044fd6b99e7c..b5971b6d4152 100644
--- a/audio/spotifyd/files/extra-patch.Cargo.toml
+++ b/audio/spotifyd/files/extra-patch.Cargo.toml
@@ -8,4 +8,4 @@
+librespot-connect = { version = "0.2.0", features = ["with-dns-sd"]}
toml = "0.5.8"
color-eyre = "0.5"
-
+