aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-03-14 19:04:04 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-03-14 19:04:04 +0000
commitda1a3d2bae70f9283ecba474ca7a44fde0758414 (patch)
tree38f4093243758323ec76088db53d8a2f767c8ddb
parentfb230792bc2d4df95184d5fb29b66e76474b2593 (diff)
downloadports-da1a3d2bae70f9283ecba474ca7a44fde0758414.tar.gz
ports-da1a3d2bae70f9283ecba474ca7a44fde0758414.zip
x11-toolkits/kf5-kirigami2: fix build without libomp
CMake Error at /usr/local/share/cmake/Modules/FindOpenMP.cmake:261 (try_compile): Failed to generate test project build system. Call Stack (most recent call first): /usr/local/share/cmake/Modules/FindOpenMP.cmake:537 (_OPENMP_GET_FLAGS) CMakeLists.txt:122 (find_package)
-rw-r--r--x11-toolkits/kf5-kirigami2/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/x11-toolkits/kf5-kirigami2/Makefile b/x11-toolkits/kf5-kirigami2/Makefile
index bc0716d2638a..889d062a753a 100644
--- a/x11-toolkits/kf5-kirigami2/Makefile
+++ b/x11-toolkits/kf5-kirigami2/Makefile
@@ -5,7 +5,12 @@ CATEGORIES= x11-toolkits kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
COMMENT= QtQuick based components set
-USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz
+USES= cmake gettext kde:5 qt:5 tar:xz
+.if !exists(/usr/include/omp.h)
+USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler:c++11-lib
+.endif
USE_KDE= kdeclarative \
ecm:build
USE_QT= core concurrent dbus declarative graphicaleffects gui \