aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-26 20:32:07 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-26 20:32:07 +0000
commitdaeb071983c97ccd81a791178e1476a75d5f9581 (patch)
treecd2119384f4abf8c6264cd043c3024d2ba917368
parentb22d25bf994880256cb2db93121c64322a4d90b6 (diff)
downloadports-daeb071983c97ccd81a791178e1476a75d5f9581.tar.gz
ports-daeb071983c97ccd81a791178e1476a75d5f9581.zip
x11/py-mouseinfo: New port: application to display XY position and RGB color information
An application to display XY position and RGB color information for the pixel currently under the mouse. This is useful for GUI automation planning.
-rw-r--r--x11/Makefile1
-rw-r--r--x11/py-mouseinfo/Makefile25
-rw-r--r--x11/py-mouseinfo/distinfo3
-rw-r--r--x11/py-mouseinfo/pkg-descr2
4 files changed, 31 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 4f10bfce6b40..bdc7ab03f1fe 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -311,6 +311,7 @@
SUBDIR += py-caffeine-ng
SUBDIR += py-i3-quickterm
SUBDIR += py-i3ipc
+ SUBDIR += py-mouseinfo
SUBDIR += py-pynput
SUBDIR += py-pyscreenshot
SUBDIR += py-python-xapp
diff --git a/x11/py-mouseinfo/Makefile b/x11/py-mouseinfo/Makefile
new file mode 100644
index 000000000000..f9a9fd9710c5
--- /dev/null
+++ b/x11/py-mouseinfo/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= mouseinfo
+DISTVERSION= 0.1.3
+CATEGORIES= x11 python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= MouseInfo-${DISTVERSION}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= application to display XY position and RGB color information
+WWW= https://github.com/asweigart/mouseinfo
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-xlib>0:x11-toolkits/py-python-xlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyperclip>0:devel/py-pyperclip@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+
+USES= dos2unix python:3.6+
+USE_PYTHON= autoplist distutils
+
+DOS2UNIX_GLOB= *.py
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/x11/py-mouseinfo/distinfo b/x11/py-mouseinfo/distinfo
new file mode 100644
index 000000000000..2e5a0eb86eec
--- /dev/null
+++ b/x11/py-mouseinfo/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1682534915
+SHA256 (MouseInfo-0.1.3.tar.gz) = 2c62fb8885062b8e520a3cce0a297c657adcc08c60952eb05bc8256ef6f7f6e7
+SIZE (MouseInfo-0.1.3.tar.gz) = 10850
diff --git a/x11/py-mouseinfo/pkg-descr b/x11/py-mouseinfo/pkg-descr
new file mode 100644
index 000000000000..945de4463aba
--- /dev/null
+++ b/x11/py-mouseinfo/pkg-descr
@@ -0,0 +1,2 @@
+An application to display XY position and RGB color information for the pixel
+currently under the mouse. This is useful for GUI automation planning.