aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Chadwick <jdc@koitsu.org>2022-01-16 09:37:06 +0000
committerDries Michiels <driesm@FreeBSD.org>2022-01-25 19:35:35 +0000
commitdc765dc71a5b03bfc463329c6699f4f6e5480f45 (patch)
treedced78dc4dab43f09e6a99f1d8a8e0025ac191b1
parentd7e0acbd4d9a4bc9413811ce5a0321840298415a (diff)
downloadports-dc765dc71a5b03bfc463329c6699f4f6e5480f45.tar.gz
ports-dc765dc71a5b03bfc463329c6699f4f6e5480f45.zip
databases/influxdb: Improve syslog logging title
This changes the log entries from "daemon[PID]: logmesage" to "influxd[PID]: logmessage". While here, remove trailing spaces. Approved by: 0mp (mentor) Pull Request: https://github.com/freebsd/freebsd-ports/pull/121 Differential Revision: https://reviews.freebsd.org/D33907
-rw-r--r--databases/influxdb/Makefile1
-rw-r--r--databases/influxdb/files/influxd.in14
2 files changed, 8 insertions, 7 deletions
diff --git a/databases/influxdb/Makefile b/databases/influxdb/Makefile
index 1520087c287a..0f9492e463f8 100644
--- a/databases/influxdb/Makefile
+++ b/databases/influxdb/Makefile
@@ -1,6 +1,7 @@
PORTNAME= influxdb
DISTVERSIONPREFIX= v
DISTVERSION= 1.8.10
+PORTREVISION= 1
CATEGORIES= databases net-mgmt
MAINTAINER= driesm@FreeBSD.org
diff --git a/databases/influxdb/files/influxd.in b/databases/influxdb/files/influxd.in
index 57c3892f1cff..539daf16d49c 100644
--- a/databases/influxdb/files/influxd.in
+++ b/databases/influxdb/files/influxd.in
@@ -43,7 +43,7 @@ influxd_pidfile="%%INFLUXD_PIDDIR%%${name}.pid"
procname="%%PREFIX%%/bin/${name}"
command=/usr/sbin/daemon
start_precmd="influxd_precmd"
-start_cmd="influxd_startcmd_%%INFLUXD_LOGCMD%%"
+start_cmd="influxd_startcmd_%%INFLUXD_LOGCMD%%"
influxd_precmd()
{
@@ -52,16 +52,16 @@ influxd_precmd()
influxd_startcmd_daemon()
{
- echo "Starting ${name}."
- /usr/sbin/daemon -c -p ${influxd_pidfile} -S -s ${influxd_priority} -l ${influxd_facility} \
- -u ${influxd_user} ${procname} ${influxd_options}
+ echo "Starting ${name}."
+ /usr/sbin/daemon -c -p ${influxd_pidfile} -S -s ${influxd_priority} -l ${influxd_facility} -T ${name} \
+ -u ${influxd_user} ${procname} ${influxd_options}
}
-influxd_startcmd_logger()
+influxd_startcmd_logger()
{
- echo "Starting ${name}."
+ echo "Starting ${name}."
/usr/sbin/daemon -c -p ${influxd_pidfile} -u ${influxd_user} /bin/sh -c "${procname} ${influxd_options} 2>&1 \
| /usr/bin/logger -t ${name} -p ${influxd_facility}.${influxd_priority}"
-}
+}
run_rc_command "$1"