aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-03-18 16:37:40 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-03-18 17:11:37 +0000
commitdc826ba1280fc889e95b8c12fc1aba6279c3d67d (patch)
tree85fce3f329f09342a4014eaf9a291f5ac8c6a61e
parent7db055349957ee7f79e5c2452430c71a3e86b6eb (diff)
downloadports-dc826ba1280fc889e95b8c12fc1aba6279c3d67d.tar.gz
ports-dc826ba1280fc889e95b8c12fc1aba6279c3d67d.zip
devel/py-pytest4-{asyncio,cov}: preserve pytest4 counterparts of corresponding ports
PR: 256624
-rw-r--r--devel/Makefile2
-rw-r--r--devel/py-pytest-asyncio/Makefile2
-rw-r--r--devel/py-pytest-cov/Makefile2
-rw-r--r--devel/py-pytest4-asyncio/Makefile22
-rw-r--r--devel/py-pytest4-asyncio/distinfo3
-rw-r--r--devel/py-pytest4-asyncio/pkg-descr5
-rw-r--r--devel/py-pytest4-cov/Makefile25
-rw-r--r--devel/py-pytest4-cov/distinfo3
-rw-r--r--devel/py-pytest4-cov/pkg-descr8
9 files changed, 72 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f05e073de828..cf444dda81cd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5116,6 +5116,8 @@
SUBDIR += py-pytest-xdist
SUBDIR += py-pytest-xprocess
SUBDIR += py-pytest4
+ SUBDIR += py-pytest4-asyncio
+ SUBDIR += py-pytest4-cov
SUBDIR += py-python-Levenshtein
SUBDIR += py-python-application
SUBDIR += py-python-bugzilla
diff --git a/devel/py-pytest-asyncio/Makefile b/devel/py-pytest-asyncio/Makefile
index e71f43e80737..dd1bac84768e 100644
--- a/devel/py-pytest-asyncio/Makefile
+++ b/devel/py-pytest-asyncio/Makefile
@@ -9,6 +9,8 @@ COMMENT= Py.test plugin providing fixtures and markers for asyncio
LICENSE= APACHE20
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}pytest4-asyncio
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.0.6:devel/py-pytest@${PY_FLAVOR}
NO_ARCH= yes
diff --git a/devel/py-pytest-cov/Makefile b/devel/py-pytest-cov/Makefile
index c64605039407..7bebf037c4e5 100644
--- a/devel/py-pytest-cov/Makefile
+++ b/devel/py-pytest-cov/Makefile
@@ -10,6 +10,8 @@ COMMENT= Pytest plugin for measuring coverage
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}pytest4-cov
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=4.4:devel/py-coverage@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest>=3.6:devel/py-pytest@${PY_FLAVOR}
diff --git a/devel/py-pytest4-asyncio/Makefile b/devel/py-pytest4-asyncio/Makefile
new file mode 100644
index 000000000000..7f9f9b08e0b2
--- /dev/null
+++ b/devel/py-pytest4-asyncio/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= pytest4-asyncio
+PORTVERSION= 0.10.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:C/4//}-${PORTVERSION}
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Py.test plugin providing fixtures and markers for asyncio (legacy version for pytest 4)
+
+LICENSE= APACHE20
+
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}pytest-asyncio
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest4>=3.0.6:devel/py-pytest4@${PY_FLAVOR}
+
+NO_ARCH= yes
+USES= python:3.5+
+USE_PYTHON= autoplist distutils
+PYDISTUTILS_PKGNAME= ${PORTNAME:C/4//}
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytest4-asyncio/distinfo b/devel/py-pytest4-asyncio/distinfo
new file mode 100644
index 000000000000..1378944ef27e
--- /dev/null
+++ b/devel/py-pytest4-asyncio/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1546907123
+SHA256 (pytest-asyncio-0.10.0.tar.gz) = 9fac5100fd716cbecf6ef89233e8590a4ad61d729d1732e0a96b84182df1daaf
+SIZE (pytest-asyncio-0.10.0.tar.gz) = 11765
diff --git a/devel/py-pytest4-asyncio/pkg-descr b/devel/py-pytest4-asyncio/pkg-descr
new file mode 100644
index 000000000000..19fb8a5dc42a
--- /dev/null
+++ b/devel/py-pytest4-asyncio/pkg-descr
@@ -0,0 +1,5 @@
+asyncio code is usually written in the form of coroutines, which makes it
+slightly more difficult to test using normal testing tools. pytest-asyncio
+provides useful fixtures and markers to make testing easier.
+
+WWW: https://pypi.org/project/pytest-asyncio/
diff --git a/devel/py-pytest4-cov/Makefile b/devel/py-pytest4-cov/Makefile
new file mode 100644
index 000000000000..0091afe40e7c
--- /dev/null
+++ b/devel/py-pytest4-cov/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= pytest4-cov
+PORTVERSION= 2.9.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:C/4//}-${PORTVERSION}
+
+MAINTAINER= dbaio@FreeBSD.org
+COMMENT= Pytest plugin for measuring coverage (legacy version for pytest 4)
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}pytest-cov
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=4.4:devel/py-coverage@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest4>=3.6:devel/py-pytest4@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+PYDISTUTILS_PKGNAME= ${PORTNAME:C/4//}
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytest4-cov/distinfo b/devel/py-pytest4-cov/distinfo
new file mode 100644
index 000000000000..dfe93af0583b
--- /dev/null
+++ b/devel/py-pytest4-cov/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1590933452
+SHA256 (pytest-cov-2.9.0.tar.gz) = b6a814b8ed6247bd81ff47f038511b57fe1ce7f4cc25b9106f1a4b106f1d9322
+SIZE (pytest-cov-2.9.0.tar.gz) = 54269
diff --git a/devel/py-pytest4-cov/pkg-descr b/devel/py-pytest4-cov/pkg-descr
new file mode 100644
index 000000000000..5aac44f44c20
--- /dev/null
+++ b/devel/py-pytest4-cov/pkg-descr
@@ -0,0 +1,8 @@
+This plugin produces coverage reports. It supports centralised testing and
+distributed testing in both load and each modes. It also supports coverage of
+subprocesses.
+
+All features offered by the coverage package should be available, either through
+pytest-cov or through coverage's config file.
+
+WWW: https://github.com/pytest-dev/pytest-cov