aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-08-03 11:53:06 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-08-04 11:20:49 +0000
commitdcd24b8b8198561695a2d600e64013d04a8c438c (patch)
treee84068839278ca5064f595645c2b773575d63f06
parentf9697956d876c4a51b62e77c1c5ec5d7884483b0 (diff)
downloadports-dcd24b8b8198561695a2d600e64013d04a8c438c.tar.gz
ports-dcd24b8b8198561695a2d600e64013d04a8c438c.zip
graphics/vulkan-headers: update to 1.2.187
-rw-r--r--graphics/vulkan-extension-layer/files/patch-headers-1.2.187103
-rw-r--r--graphics/vulkan-headers/Makefile2
-rw-r--r--graphics/vulkan-headers/distinfo6
-rw-r--r--graphics/vulkan-loader/Makefile1
-rw-r--r--graphics/vulkan-loader/pkg-plist2
-rw-r--r--graphics/vulkan-validation-layers/Makefile3
-rw-r--r--graphics/vulkan-validation-layers/distinfo2
7 files changed, 114 insertions, 5 deletions
diff --git a/graphics/vulkan-extension-layer/files/patch-headers-1.2.187 b/graphics/vulkan-extension-layer/files/patch-headers-1.2.187
new file mode 100644
index 000000000000..bb5bd50911fa
--- /dev/null
+++ b/graphics/vulkan-extension-layer/files/patch-headers-1.2.187
@@ -0,0 +1,103 @@
+Part of https://github.com/KhronosGroup/Vulkan-ValidationLayers/pull/3121
+
+In file included from layers/synchronization2.cpp:33:
+utils/generated/vk_safe_struct.h:3503:5: error: unknown type name 'VkVideoCapabilitiesFlagsKHR'; did you mean 'VkVideoCapabilityFlagsKHR'?
+ VkVideoCapabilitiesFlagsKHR capabilityFlags;
+ ^~~~~~~~~~~~~~~~~~~~~~~~~~~
+ VkVideoCapabilityFlagsKHR
+/usr/local/include/vulkan/vulkan_beta.h:74:17: note: 'VkVideoCapabilityFlagsKHR' declared here
+typedef VkFlags VkVideoCapabilityFlagsKHR;
+ ^
+In file included from layers/synchronization2.cpp:33:
+utils/generated/vk_safe_struct.h:5546:5: error: unknown type name 'VkVideoEncodeH264CapabilitiesFlagsEXT'; did you mean 'VkVideoEncodeH264CapabilityFlagsEXT'?
+ VkVideoEncodeH264CapabilitiesFlagsEXT flags;
+ ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ VkVideoEncodeH264CapabilityFlagsEXT
+/usr/local/include/vulkan/vulkan_beta.h:453:17: note: 'VkVideoEncodeH264CapabilityFlagsEXT' declared here
+typedef VkFlags VkVideoEncodeH264CapabilityFlagsEXT;
+ ^
+In file included from layers/synchronization2.cpp:33:
+utils/generated/vk_safe_struct.h:5735:5: error: unknown type name 'VkVideoDecodeH264FieldLayoutFlagsEXT'; did you mean 'VkVideoDecodeH264PictureLayoutFlagsEXT'?
+ VkVideoDecodeH264FieldLayoutFlagsEXT fieldLayout;
+ ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ VkVideoDecodeH264PictureLayoutFlagsEXT
+/usr/local/include/vulkan/vulkan_beta.h:579:17: note: 'VkVideoDecodeH264PictureLayoutFlagsEXT' declared here
+typedef VkFlags VkVideoDecodeH264PictureLayoutFlagsEXT;
+ ^
+
+--- utils/generated/vk_safe_struct.cpp.orig 2021-07-21 20:54:27 UTC
++++ utils/generated/vk_safe_struct.cpp
+@@ -25624,7 +25624,7 @@ void safe_VkVideoEncodeH264ProfileEXT::initialize(cons
+ safe_VkVideoDecodeH264ProfileEXT::safe_VkVideoDecodeH264ProfileEXT(const VkVideoDecodeH264ProfileEXT* in_struct) :
+ sType(in_struct->sType),
+ stdProfileIdc(in_struct->stdProfileIdc),
+- fieldLayout(in_struct->fieldLayout)
++ pictureLayout(in_struct->pictureLayout)
+ {
+ pNext = SafePnextCopy(in_struct->pNext);
+ }
+@@ -25638,7 +25638,7 @@ safe_VkVideoDecodeH264ProfileEXT::safe_VkVideoDecodeH2
+ {
+ sType = copy_src.sType;
+ stdProfileIdc = copy_src.stdProfileIdc;
+- fieldLayout = copy_src.fieldLayout;
++ pictureLayout = copy_src.pictureLayout;
+ pNext = SafePnextCopy(copy_src.pNext);
+ }
+
+@@ -25651,7 +25651,7 @@ safe_VkVideoDecodeH264ProfileEXT& safe_VkVideoDecodeH2
+
+ sType = copy_src.sType;
+ stdProfileIdc = copy_src.stdProfileIdc;
+- fieldLayout = copy_src.fieldLayout;
++ pictureLayout = copy_src.pictureLayout;
+ pNext = SafePnextCopy(copy_src.pNext);
+
+ return *this;
+@@ -25667,7 +25667,7 @@ void safe_VkVideoDecodeH264ProfileEXT::initialize(cons
+ {
+ sType = in_struct->sType;
+ stdProfileIdc = in_struct->stdProfileIdc;
+- fieldLayout = in_struct->fieldLayout;
++ pictureLayout = in_struct->pictureLayout;
+ pNext = SafePnextCopy(in_struct->pNext);
+ }
+
+@@ -25675,7 +25675,7 @@ void safe_VkVideoDecodeH264ProfileEXT::initialize(cons
+ {
+ sType = copy_src->sType;
+ stdProfileIdc = copy_src->stdProfileIdc;
+- fieldLayout = copy_src->fieldLayout;
++ pictureLayout = copy_src->pictureLayout;
+ pNext = SafePnextCopy(copy_src->pNext);
+ }
+ #endif // VK_ENABLE_BETA_EXTENSIONS
+--- utils/generated/vk_safe_struct.h.orig 2021-07-21 20:54:27 UTC
++++ utils/generated/vk_safe_struct.h
+@@ -3500,7 +3500,7 @@ struct safe_VkVideoProfilesKHR {
+ struct safe_VkVideoCapabilitiesKHR {
+ VkStructureType sType;
+ void* pNext;
+- VkVideoCapabilitiesFlagsKHR capabilityFlags;
++ VkVideoCapabilityFlagsKHR capabilityFlags;
+ VkDeviceSize minBitstreamBufferOffsetAlignment;
+ VkDeviceSize minBitstreamBufferSizeAlignment;
+ VkExtent2D videoPictureExtentGranularity;
+@@ -5543,7 +5543,7 @@ struct safe_VkImageViewAddressPropertiesNVX {
+ struct safe_VkVideoEncodeH264CapabilitiesEXT {
+ VkStructureType sType;
+ const void* pNext;
+- VkVideoEncodeH264CapabilitiesFlagsEXT flags;
++ VkVideoEncodeH264CapabilityFlagsEXT flags;
+ VkVideoEncodeH264InputModeFlagsEXT inputModeFlags;
+ VkVideoEncodeH264OutputModeFlagsEXT outputModeFlags;
+ VkExtent2D minPictureSizeInMbs;
+@@ -5732,7 +5732,7 @@ struct safe_VkVideoDecodeH264ProfileEXT {
+ VkStructureType sType;
+ const void* pNext;
+ StdVideoH264ProfileIdc stdProfileIdc;
+- VkVideoDecodeH264FieldLayoutFlagsEXT fieldLayout;
++ VkVideoDecodeH264PictureLayoutFlagsEXT pictureLayout;
+ safe_VkVideoDecodeH264ProfileEXT(const VkVideoDecodeH264ProfileEXT* in_struct);
+ safe_VkVideoDecodeH264ProfileEXT(const safe_VkVideoDecodeH264ProfileEXT& copy_src);
+ safe_VkVideoDecodeH264ProfileEXT& operator=(const safe_VkVideoDecodeH264ProfileEXT& copy_src);
diff --git a/graphics/vulkan-headers/Makefile b/graphics/vulkan-headers/Makefile
index 9e6a7d863bf0..409000d7d0db 100644
--- a/graphics/vulkan-headers/Makefile
+++ b/graphics/vulkan-headers/Makefile
@@ -1,6 +1,6 @@
PORTNAME= vulkan-headers
DISTVERSIONPREFIX= v
-DISTVERSION= 1.2.186
+DISTVERSION= 1.2.187
CATEGORIES= graphics
MAINTAINER= jbeich@FreeBSD.org
diff --git a/graphics/vulkan-headers/distinfo b/graphics/vulkan-headers/distinfo
index db345b7fe8b8..dca0bab1b792 100644
--- a/graphics/vulkan-headers/distinfo
+++ b/graphics/vulkan-headers/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1627382608
-SHA256 (KhronosGroup-Vulkan-Headers-v1.2.186_GH0.tar.gz) = f3773ccc42d61b1b9588738dca0cb683b56fbba7283d83a962cdb80fb015071c
-SIZE (KhronosGroup-Vulkan-Headers-v1.2.186_GH0.tar.gz) = 1188880
+TIMESTAMP = 1627991586
+SHA256 (KhronosGroup-Vulkan-Headers-v1.2.187_GH0.tar.gz) = 37f399aef2dbeb0eb979139f41a0fe411b3dff77e70be85e93318a7b833557de
+SIZE (KhronosGroup-Vulkan-Headers-v1.2.187_GH0.tar.gz) = 1188907
diff --git a/graphics/vulkan-loader/Makefile b/graphics/vulkan-loader/Makefile
index 024cfbf8c646..a6ca4d537616 100644
--- a/graphics/vulkan-loader/Makefile
+++ b/graphics/vulkan-loader/Makefile
@@ -1,6 +1,7 @@
PORTNAME= vulkan-loader
DISTVERSIONPREFIX= v
DISTVERSION= 1.2.186
+PORTREVISION= 1
CATEGORIES= graphics devel
MAINTAINER= jbeich@FreeBSD.org
diff --git a/graphics/vulkan-loader/pkg-plist b/graphics/vulkan-loader/pkg-plist
index 6c140cd0f57b..d3ec73d3b951 100644
--- a/graphics/vulkan-loader/pkg-plist
+++ b/graphics/vulkan-loader/pkg-plist
@@ -1,4 +1,4 @@
lib/libvulkan.so
lib/libvulkan.so.1
-lib/libvulkan.so.1.2.186
+lib/libvulkan.so.1.2.187
libdata/pkgconfig/vulkan.pc
diff --git a/graphics/vulkan-validation-layers/Makefile b/graphics/vulkan-validation-layers/Makefile
index f3d18c86f7a7..31593f6ec61c 100644
--- a/graphics/vulkan-validation-layers/Makefile
+++ b/graphics/vulkan-validation-layers/Makefile
@@ -3,6 +3,9 @@ DISTVERSIONPREFIX= v
DISTVERSION= 1.2.186
CATEGORIES= graphics
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= 653b0bce9243.patch:-p1 # https://github.com/KhronosGroup/Vulkan-ValidationLayers/pull/3121
+
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Validation layers for the Vulkan graphics API
diff --git a/graphics/vulkan-validation-layers/distinfo b/graphics/vulkan-validation-layers/distinfo
index c40caf277fff..81b390e3e00f 100644
--- a/graphics/vulkan-validation-layers/distinfo
+++ b/graphics/vulkan-validation-layers/distinfo
@@ -5,3 +5,5 @@ SHA256 (KhronosGroup-SPIRV-Headers-1.5.4.raytracing.fixed-90-ge7b49d7_GH0.tar.gz
SIZE (KhronosGroup-SPIRV-Headers-1.5.4.raytracing.fixed-90-ge7b49d7_GH0.tar.gz) = 414402
SHA256 (martinus-robin-hood-hashing-3.10.0_GH0.tar.gz) = 15f031c3ab7c13addfb19bd495be6f12ac8843111b71b61873ef6fa981bfc4da
SIZE (martinus-robin-hood-hashing-3.10.0_GH0.tar.gz) = 169078
+SHA256 (653b0bce9243.patch) = 52d57989463903daaf3f66c76b20a847c673a1386854708c563eebb7b1f3574a
+SIZE (653b0bce9243.patch) = 105357