aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2023-07-02 10:11:36 +0000
committerRene Ladan <rene@FreeBSD.org>2023-07-02 18:19:02 +0000
commitdd152219f70da0465ee12edb1feeae5e2f802c51 (patch)
tree4a154ef0973172fb4cc8defae7c82780d3b63b48
parent339e609cc21174da50c503ce54ed9ac7d39eb7c6 (diff)
downloadports-dd152219f70da0465ee12edb1feeae5e2f802c51.tar.gz
ports-dd152219f70da0465ee12edb1feeae5e2f802c51.zip
Mk: ghostscript: modernize
- add support for GhostScript 10 - bump versions for dependency lines - 9 and agpl are synonymous, represent this in the Makefile PR: 270989 (point 3 + 5) Reported by: Chad Jacob Milios <milios@ccsys.com> (original) Continued work: Michael Osipov <michael.osipov@siemens.com> Reviewed by: diizzy MFH: 2023Q3
-rw-r--r--Mk/Uses/ghostscript.mk43
-rw-r--r--Mk/bsd.default-versions.mk2
2 files changed, 28 insertions, 17 deletions
diff --git a/Mk/Uses/ghostscript.mk b/Mk/Uses/ghostscript.mk
index af38582e8384..8e5010986ccd 100644
--- a/Mk/Uses/ghostscript.mk
+++ b/Mk/Uses/ghostscript.mk
@@ -4,8 +4,8 @@
# Usage: USES=ghostscript or USES=ghostscript:args
# Valid ARGS: <version>, build, run, test, x11
#
-# version The chooseable versions are 9 and agpl. If no version is
-# specified version agpl is selected.
+# version The chooseable versions are 9, agpl and 10. If no version is
+# specified version agpl is selected. 9 and agpl are synonymous.
#
# USES=ghostscript:9 # Use Ghostscript 9
# USES=ghostscript:run # Use the set default Ghostscript as a run dependency
@@ -30,15 +30,15 @@ _INCLUDE_USES_GHOSTSCRIPT_MK= yes
# allowed versions
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
-_GS_VERSION= 9 agpl
+_GS_VERSION= 9 agpl 10
-_GS_ARGS= ${ghostscript_ARGS}
+_GS_ARGS= ${ghostscript_ARGS}
-. if ${_GS_ARGS:N[9]:Nagpl:Nx11:Nbuild:Nrun:Ntest}
+. if ${_GS_ARGS:N9:N10:Nagpl:Nx11:Nbuild:Nrun:Ntest}
IGNORE?= Unknown ghostscript argument ${_GS_ARGS}
. endif
-. if ${GHOSTSCRIPT_DEFAULT:N[9]:Nagpl}
+. if ${GHOSTSCRIPT_DEFAULT:N9:Nagpl:N10}
IGNORE?= Invalid GHOSTSCRIPT_DEFAULT value: ${GHOSTSCRIPT_DEFAULT}, please select one of ${_GS_VERSION}
. endif
@@ -67,29 +67,40 @@ _GS_RUN_DEP= yes
.undef _GS_SELECTED
. for V in ${_GS_ARGS} ${GHOSTSCRIPT_DEFAULT}
_V=${V}
-. if ${_V:M9}
-_GS_SELECTED?= 9
+. if ${_V:M10}
+_GS_SELECTED?= 10
+. elif ${_V:M9}
+_GS_SELECTED?= 9-agpl
. elif ${_V:Magpl}
_GS_SELECTED?= 9-agpl
. endif
. endfor
+. undef _GS_FLAVORED
+. if empty(_GS_SELECTED:M9-agpl)
+_GS_FLAVORED= yes
+. endif
+
# Resolve minor version number for X11.so library.
-. if !empty(_GS_SELECTED:M9-agpl)
-_GS_VERSION_MINOR= 9.16_2
-. elif !empty(_GS_SELECTED:M9)
-_GS_VERSION_MINOR= 9.06_11
+. if !empty(_GS_SELECTED:M10)
+_GS_VERSION_MINOR= 10.01.2
+. elif !empty(_GS_SELECTED:M9-agpl)
+_GS_VERSION_MINOR= 9.56.1
. endif
# dependencies
-_GS_PORT= ghostscript${_GS_SELECTED}-base
-_GS_X11_PORT= ghostscript${_GS_SELECTED}-x11
+_GS_PKGNAME= ghostscript${_GS_SELECTED}${_GS_FLAVORED:?:-base}
+_GS_X11_PKGNAME=ghostscript${_GS_SELECTED}-x11
+_GS_PORT= print/ghostscript${_GS_SELECTED}${_GS_FLAVORED:?:-base}
+_GS_X11_PORT= print/ghostscript${_GS_SELECTED}${_GS_FLAVORED:?@:-}x11
. for type in BUILD RUN TEST
. if defined(_GS_${type}_DEP)
-${type}_DEPENDS+= ${_GS_PORT}>=${_GS_VERSION_MINOR}:print/${_GS_PORT}
+. if defined(_GS_FLAVORED) || !${_GS_ARGS:Mx11}
+${type}_DEPENDS+= ${_GS_PKGNAME}>=${_GS_VERSION_MINOR}:${_GS_PORT}
+. endif
. if ${_GS_ARGS:Mx11}
-${type}_DEPENDS+= ${_GS_X11_PORT}>=${_GS_VERSION_MINOR}:print/${_GS_X11_PORT}
+${type}_DEPENDS+= ${_GS_X11_PKGNAME}>=${_GS_VERSION_MINOR}:${_GS_X11_PORT}
. endif
. endif
. endfor
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index e3fac4c45918..3cf846195760 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -53,7 +53,7 @@ GCC_DEFAULT?= 8
. else
GCC_DEFAULT?= 12
. endif
-# Possible values: 9, agpl
+# Possible values: 9, agpl, 10
GHOSTSCRIPT_DEFAULT?= agpl
# Possible values: mesa-libs, mesa-devel
GL_DEFAULT?= mesa-libs