aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-02 21:14:24 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-02 21:18:14 +0000
commitddf0ac13873abe00960631ad7f2445689bd68645 (patch)
treef0c013a755917b1885e70771c11ae99bfb4931d9
parent9585000d0f854a691063706209e521eb48c86d59 (diff)
downloadports-ddf0ac13873abe00960631ad7f2445689bd68645.tar.gz
ports-ddf0ac13873abe00960631ad7f2445689bd68645.zip
net-mgmt/kismet: Fix build with llvm16
- Utilize USES=localbase - Utilize OPTIONSNG where possible - Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--net-mgmt/kismet/Makefile57
1 files changed, 21 insertions, 36 deletions
diff --git a/net-mgmt/kismet/Makefile b/net-mgmt/kismet/Makefile
index e0268cf626ef..e98fc6fbbb43 100644
--- a/net-mgmt/kismet/Makefile
+++ b/net-mgmt/kismet/Makefile
@@ -11,55 +11,40 @@ WWW= https://www.kismetwireless.net/
LICENSE= GPLv2
-USES= gmake tar:xz
+USES= gmake localbase:ldflags tar:xz
+USE_CXXSTD= c++14
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/a$$//}
+
+PORTDOCS= README
+PORTEXAMPLES= *
OPTIONS_DEFINE= PCRE PLUGINS SETUID DOCS EXAMPLES
OPTIONS_DEFAULT= PCRE PLUGINS SETUID
+OPTIONS_SUB= yes
+
SETUID_DESC= Use privilege separation
-WRKSRC= ${WRKDIR}/${DISTNAME:S/a$$//}
+PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
+PCRE_CONFIGURE_ENABLE= pcre
+PLUGINS_USES= ssl
+PLUGINS_ALL_TARGET= depend all all-plugins
+PLUGINS_INSTALL_TARGET= all-plugins-install
+SETUID_CONFIGURE_ON=--with-suidgroup=wheel
+SETUID_CONFIGURE_OFF=--without-suidgroup
+SETUID_INSTALL_TARGET= suidinstall
+SETUID_INSTALL_TARGET_OFF= install
+SETUID_SUB_FILES= suid_pkg-message
+SETUID_PLIST_SUB= SUID="" SUIDGROUP="${GROUPS}"
+SETUID_PLIST_SUB_OFF= SUID="@comment " SUIDGROUP=""
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCS= README
-.endif
-
-.if ${PORT_OPTIONS:MEXAMPLES}
-PORTEXAMPLES= *
-.endif
-
-.if ${PORT_OPTIONS:MPCRE}
-CONFIGURE_ARGS+=--enable-pcre
-LIB_DEPENDS+= libpcre.so:devel/pcre
-.else
-CONFIGURE_ARGS+=--disable-pcre
-.endif
-
.if ${PORT_OPTIONS:MSETUID}
GROUPS= kismet
-CONFIGURE_ARGS+=--with-suidgroup=wheel
-INSTALL_TARGET= suidinstall
-PLIST_SUB+= SUID="" SUIDGROUP="${GROUPS}"
PKGMESSAGE= ${WRKDIR}/suid_pkg-message
-SUB_FILES+= suid_pkg-message
-.else
-INSTALL_TARGET= install
-CONFIGURE_ARGS+=--without-suidgroup
-PLIST_SUB+= SUID="@comment " SUIDGROUP=""
-.endif
-
-.if ${PORT_OPTIONS:MPLUGINS}
-ALL_TARGET= depend all all-plugins
-INSTALL_TARGET+= all-plugins-install
-USES+= ssl
-PLIST_SUB+= PLUGINS=""
-.else
-PLIST_SUB+= PLUGINS="@comment "
.endif
.include <bsd.port.pre.mk>