aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2023-09-12 05:56:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2023-09-12 15:16:36 +0000
commitde051854d7be6f8d85259d32c659fd182f7ea218 (patch)
tree587f440acf5fbf527a2b71879dab8d9c2511c3d1
parent88bca0dee0644b916cc5230ec1a712f57ef75223 (diff)
downloadports-de051854d7be6f8d85259d32c659fd182f7ea218.tar.gz
ports-de051854d7be6f8d85259d32c659fd182f7ea218.zip
databases/kexi: move webkit behind default-off option
qt5-webkit will be removed by the end of the year.
-rw-r--r--databases/kexi/Makefile10
-rw-r--r--databases/kexi/pkg-plist4
2 files changed, 10 insertions, 4 deletions
diff --git a/databases/kexi/Makefile b/databases/kexi/Makefile
index 8adef6ba98da..aeec46312f8f 100644
--- a/databases/kexi/Makefile
+++ b/databases/kexi/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kexi
DISTVERSION= 3.2.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= databases kde
MASTER_SITES= KDE/stable/${PORTNAME}/src
DIST_SUBDIR= KDE/${PORTNAME}
@@ -23,7 +23,7 @@ USE_KDE= auth bookmarks codecs completion config configwidgets \
texteditor textwidgets widgetsaddons windowsystem xmlgui \
breeze-icons:build ecm:build
USE_QT= concurrent core dbus declarative gui network printsupport \
- webkit widgets xml \
+ widgets xml \
buildtools:build qmake:build testlib:build
USE_XORG= x11
@@ -33,4 +33,10 @@ CMAKE_OFF= BUILD_TESTING \
KEXI_ENABLE_QTGUI_FOR_TESTS
CMAKE_ON= KEXI_QTGUI_RUNTIME_AVAILABLE
+OPTIONS_DEFINE= WEBKIT
+OPTIONS_SUB= yes
+WEBKIT_DESC= Use obsolete qt5-webkit to build Browser Plugin
+WEBKIT_USE= QT5=webkit
+WEBKIT_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Qt5WebKit
+
.include <bsd.port.mk>
diff --git a/databases/kexi/pkg-plist b/databases/kexi/pkg-plist
index 1826e1be0f5d..5184e39e179b 100644
--- a/databases/kexi/pkg-plist
+++ b/databases/kexi/pkg-plist
@@ -36,7 +36,7 @@ lib/libkformdesigner3.2.so
lib/libkformdesigner3.2.so.3.2
lib/libkformdesigner3.2.so.3.2.0
%%QT_PLUGINDIR%%/kexi/3.2/forms/widgets/org.kexi-project.form.widgets.main.so
-%%QT_PLUGINDIR%%/kexi/3.2/forms/widgets/org.kexi-project.form.widgets.web-browser.so
+%%WEBKIT%%%%QT_PLUGINDIR%%/kexi/3.2/forms/widgets/org.kexi-project.form.widgets.web-browser.so
%%QT_PLUGINDIR%%/kexi/3.2/kexi_csvimportexportplugin.so
%%QT_PLUGINDIR%%/kexi/3.2/kexi_formplugin.so
%%QT_PLUGINDIR%%/kexi/3.2/kexi_migrationplugin.so
@@ -86,7 +86,7 @@ share/icons/hicolor/64x64/apps/kexi-3.2.png
%%DATADIR%%/3.2/examples/Simple_Database.kexi
%%DATADIR%%/3.2/icons/kexi_breeze.rcc
%%DATADIR%%/3.2/icons/org.kexi-project.form.widgets.main_breeze.rcc
-%%DATADIR%%/3.2/icons/org.kexi-project.form.widgets.web-browser_breeze.rcc
+%%WEBKIT%%%%DATADIR%%/3.2/icons/org.kexi-project.form.widgets.web-browser_breeze.rcc
%%DATADIR%%/3.2/status/contribution_details.ui
%%DATADIR%%/3.2/status/contribution_help.ui
%%DATADIR%%/3.2/status/status.rcc