aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2016-07-24 14:24:34 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2016-07-24 14:24:34 +0000
commitde17f32cc0f8d8d8e56f40b91162d665a010ff3f (patch)
treeed4bfb94cc7a7b0c1a17668703148eba267b0262
parent4af2489d718120bd199f6df1726cfee944ec5dba (diff)
downloadports-de17f32cc0f8d8d8e56f40b91162d665a010ff3f.tar.gz
ports-de17f32cc0f8d8d8e56f40b91162d665a010ff3f.zip
Update to 2.17.4.
* Check PLIST_FILES for icons [1] * Add VARS and VARS_OFF to the option helper list [2] * Add NO_ARCH [2] PR: 211175 [1] Submitted by: koobs [2]
Notes
Notes: svn path=/head/; revision=419006
-rw-r--r--ports-mgmt/portlint/Makefile3
-rw-r--r--ports-mgmt/portlint/src/portlint.pl14
2 files changed, 13 insertions, 4 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index c7fc4a9dc3e2..ae8dce262a1c 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= portlint
-PORTVERSION= 2.17.3
+PORTVERSION= 2.17.4
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
@@ -15,6 +15,7 @@ LICENSE_NAME= Itojun License
LICENSE_TEXT= All rights reserved. Freely redistributable. Absolutely no warranty.
LICENSE_PERMS= auto-accept dist-mirror dist-sell pkg-mirror pkg-sell
+NO_ARCH= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/src
USES= perl5 shebangfix
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 08201e4e2909..8e2d6331dd2b 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -15,7 +15,7 @@
# was removed.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.390 2016/07/07 17:40:43 jclarke Exp $
+# $MCom: portlint/portlint.pl,v 1.393 2016/07/24 14:20:19 jclarke Exp $
#
use strict;
@@ -50,7 +50,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 17;
-my $micro = 3;
+my $micro = 4;
# default setting - for FreeBSD
my $portsdir = '/usr/ports';
@@ -1439,11 +1439,17 @@ sub checkmakefile {
"for more details)");
}
if ($plist_file =~ m|\.core$| && $plist_file !~ /^\@/) {
- &perror("WARN", "", -1, "this port installs a file which ".
+ &perror("WARN", "", -1, "PLIST_FILES: this port installs a file which ".
"ends in \".core\". This file may be deleted if ".
"daily_clean_disks_enable=\"YES\" in /etc/periodic.conf. ".
"If possible, install this file with a different name.");
}
+ if ($plist_file =~ m|^share/icons/.*/| &&
+ $makevar{INSTALLS_ICONS} eq '') {
+ &perror("WARN", "", -1, "PLIST_FILES: installing icons, ".
+ "please define INSTALLS_ICONS as appropriate");
+ }
+
}
}
@@ -1574,6 +1580,8 @@ sub checkmakefile {
PLIST_FILES
USE
USES
+ VARS
+ VARS_OFF
);
my $m = join("|", @options_helpers);