aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-22 02:44:38 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-22 17:42:32 +0000
commitde2abd895141340360e8a2b78c62f0c93966c40c (patch)
tree159544da40fbb470bdd4358c801f58ce5591737d
parent006930d197c4c8221f04acc89db322afdcf25aca (diff)
downloadports-de2abd895141340360e8a2b78c62f0c93966c40c.tar.gz
ports-de2abd895141340360e8a2b78c62f0c93966c40c.zip
x11/py-screeninfo: New port: Fetch location and size of physical screens
-rw-r--r--x11/Makefile1
-rw-r--r--x11/py-screeninfo/Makefile22
-rw-r--r--x11/py-screeninfo/distinfo3
-rw-r--r--x11/py-screeninfo/pkg-descr2
4 files changed, 28 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index f8ef299ffea9..7e81497365b7 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -311,6 +311,7 @@
SUBDIR += py-pyscreenshot
SUBDIR += py-python-xapp
SUBDIR += py-pyvirtualdisplay
+ SUBDIR += py-screeninfo
SUBDIR += py-xcffib
SUBDIR += py-xdot
SUBDIR += qimageblitz
diff --git a/x11/py-screeninfo/Makefile b/x11/py-screeninfo/Makefile
new file mode 100644
index 000000000000..da964ca5a0b3
--- /dev/null
+++ b/x11/py-screeninfo/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= screeninfo
+DISTVERSION= 0.8.1
+CATEGORIES= x11
+MASTER_SITES= PYPI # no tests on PYPI, but GitHub tarball doesn't bui;d
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Fetch location and size of physical screens
+WWW= https://github.com/rr-/screeninfo
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+TEST_WRKSRC= ${WRKSRC}/tests
+
+.include <bsd.port.mk>
diff --git a/x11/py-screeninfo/distinfo b/x11/py-screeninfo/distinfo
new file mode 100644
index 000000000000..a3537bb5c8e7
--- /dev/null
+++ b/x11/py-screeninfo/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1674355156
+SHA256 (screeninfo-0.8.1.tar.gz) = 9983076bcc7e34402a1a9e4d7dabf3729411fd2abb3f3b4be7eba73519cd2ed1
+SIZE (screeninfo-0.8.1.tar.gz) = 10666
diff --git a/x11/py-screeninfo/pkg-descr b/x11/py-screeninfo/pkg-descr
new file mode 100644
index 000000000000..d44faab849c4
--- /dev/null
+++ b/x11/py-screeninfo/pkg-descr
@@ -0,0 +1,2 @@
+Fetch location and size of physical screens
+in Python programs.