aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2021-08-20 00:47:13 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2021-08-20 00:47:13 +0000
commitdee02c88c2ec440f0106dc09464b70a55c2df21c (patch)
treecc0c788f948bd70737c1f83e5f5bb97799091c5d
parentfb4cc7c03f295e603d7d5d585537560822b75cce (diff)
downloadports-dee02c88c2ec440f0106dc09464b70a55c2df21c.tar.gz
ports-dee02c88c2ec440f0106dc09464b70a55c2df21c.zip
math/GiNaC: Update to 1.8.1, and other small changes.
The other small changes are as follows: - USES: add ncurses and readline, sort the entries - add TEST_TARGET - remove REINPLACE_CMDs since nothing was changed PR: 257956 Reported by: bsd@philippost.de
-rw-r--r--math/GiNaC/Makefile13
-rw-r--r--math/GiNaC/distinfo6
-rw-r--r--math/GiNaC/pkg-plist13
3 files changed, 14 insertions, 18 deletions
diff --git a/math/GiNaC/Makefile b/math/GiNaC/Makefile
index 8b1efc18b6dd..85a6adb50c66 100644
--- a/math/GiNaC/Makefile
+++ b/math/GiNaC/Makefile
@@ -1,7 +1,7 @@
# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
PORTNAME= GiNaC
-PORTVERSION= 1.7.11
+PORTVERSION= 1.8.1
CATEGORIES= math
MASTER_SITES= ftp://ftpthep.physik.uni-mainz.de/pub/GiNaC/ \
http://www.ginac.de/
@@ -15,11 +15,12 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcln.so:math/cln
-USES= gmake libtool makeinfo pathfix pkgconfig python:build \
- tar:bzip2 compiler:c++11-lib
+USES= compiler:c++11-lib gmake libtool makeinfo ncurses pathfix \
+ pkgconfig python:build readline tar:bzip2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
+TEST_TARGET= check
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -34,11 +35,5 @@ post-patch:
@${REINPLACE_CMD} -e 's|unsigned|size_t|g' \
${WRKSRC}/ginac/parser/parser.cpp
.endif
- @${REINPLACE_CMD} -e 's|python3|${PYTHON_CMD}|' \
- ${WRKSRC}/scripts/yaptu.py \
- ${WRKSRC}/scripts/fixupind.py \
- ${WRKSRC}/ginac/function.py \
- ${WRKSRC}/ginsh/ginsh_fcn_help.py \
- ${WRKSRC}/ginsh/ginsh_op_help.py
.include <bsd.port.post.mk>
diff --git a/math/GiNaC/distinfo b/math/GiNaC/distinfo
index 5cceef3130f7..a44cbf0f5935 100644
--- a/math/GiNaC/distinfo
+++ b/math/GiNaC/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1596594247
-SHA256 (ginac-1.7.11.tar.bz2) = 96529ddef6ae9788aca0093f4b85fc4e34318bc6704e628e6423ab5a92dfe929
-SIZE (ginac-1.7.11.tar.bz2) = 1077491
+TIMESTAMP = 1629405569
+SHA256 (ginac-1.8.1.tar.bz2) = f1695dbd6b187061ef3fba507648c9d6dba438f733b058c16f9278cbdcf5e1ab
+SIZE (ginac-1.8.1.tar.bz2) = 1128166
diff --git a/math/GiNaC/pkg-plist b/math/GiNaC/pkg-plist
index 06aed6fb446d..cd3ce12b2460 100644
--- a/math/GiNaC/pkg-plist
+++ b/math/GiNaC/pkg-plist
@@ -1,9 +1,5 @@
bin/ginsh
bin/viewgar
-include/ginac/compiler.h
-include/ginac/factor.h
-include/ginac/parse_context.h
-include/ginac/parser.h
include/ginac/add.h
include/ginac/archive.h
include/ginac/assertion.h
@@ -11,6 +7,7 @@ include/ginac/basic.h
include/ginac/class_info.h
include/ginac/clifford.h
include/ginac/color.h
+include/ginac/compiler.h
include/ginac/constant.h
include/ginac/container.h
include/ginac/ex.h
@@ -18,6 +15,7 @@ include/ginac/excompiler.h
include/ginac/expair.h
include/ginac/expairseq.h
include/ginac/exprseq.h
+include/ginac/factor.h
include/ginac/fail.h
include/ginac/fderivative.h
include/ginac/flags.h
@@ -28,6 +26,7 @@ include/ginac/idx.h
include/ginac/indexed.h
include/ginac/inifcns.h
include/ginac/integral.h
+include/ginac/integration_kernel.h
include/ginac/lst.h
include/ginac/matrix.h
include/ginac/mul.h
@@ -35,6 +34,8 @@ include/ginac/ncmul.h
include/ginac/normal.h
include/ginac/numeric.h
include/ginac/operators.h
+include/ginac/parse_context.h
+include/ginac/parser.h
include/ginac/power.h
include/ginac/print.h
include/ginac/pseries.h
@@ -49,8 +50,8 @@ include/ginac/version.h
include/ginac/wildcard.h
lib/libginac.a
lib/libginac.so
-lib/libginac.so.6
-lib/libginac.so.6.4.5
+lib/libginac.so.11
+lib/libginac.so.11.1.0
libdata/pkgconfig/ginac.pc
libexec/ginac-excompiler
man/man1/ginsh.1.gz