aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2022-02-11 17:38:32 +0000
committerNeel Chauhan <nc@FreeBSD.org>2022-02-11 17:40:06 +0000
commitdf09a8684441709585dab23c293e3849b659993a (patch)
tree4d642319a85343cfed36d3a303b16575ba7f8d41
parent834be35d6c8056194d1db566dddcea5df2597926 (diff)
downloadports-df09a8684441709585dab23c293e3849b659993a.tar.gz
ports-df09a8684441709585dab23c293e3849b659993a.zip
archivers/xarchiver: Update to 0.5.4.17
-rw-r--r--archivers/xarchiver/Makefile3
-rw-r--r--archivers/xarchiver/distinfo6
-rw-r--r--archivers/xarchiver/files/patch-src_gzip__et__al.c38
3 files changed, 4 insertions, 43 deletions
diff --git a/archivers/xarchiver/Makefile b/archivers/xarchiver/Makefile
index b43c3daca37d..92e644bd9ef4 100644
--- a/archivers/xarchiver/Makefile
+++ b/archivers/xarchiver/Makefile
@@ -1,8 +1,7 @@
# Created by: Andreev Maxim
PORTNAME= xarchiver
-PORTVERSION= 0.5.4.16
-PORTREVISION= 1
+PORTVERSION= 0.5.4.17
CATEGORIES= archivers
MAINTAINER= ports@FreeBSD.org
diff --git a/archivers/xarchiver/distinfo b/archivers/xarchiver/distinfo
index d8882ea35616..a79cd79150e7 100644
--- a/archivers/xarchiver/distinfo
+++ b/archivers/xarchiver/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1621373055
-SHA256 (ib-xarchiver-0.5.4.16_GH0.tar.gz) = d31f301d66b77d47e0a40e13e2542d19b30649aff5e7254045baaf4b09cd38b6
-SIZE (ib-xarchiver-0.5.4.16_GH0.tar.gz) = 1071484
+TIMESTAMP = 1644600946
+SHA256 (ib-xarchiver-0.5.4.17_GH0.tar.gz) = fec755ffbd50e3575bd2497c755e9fe93265c5735f20de03328485f57d1123e2
+SIZE (ib-xarchiver-0.5.4.17_GH0.tar.gz) = 1077111
diff --git a/archivers/xarchiver/files/patch-src_gzip__et__al.c b/archivers/xarchiver/files/patch-src_gzip__et__al.c
deleted file mode 100644
index 861220efb44d..000000000000
--- a/archivers/xarchiver/files/patch-src_gzip__et__al.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/gzip_et_al.c.orig 2020-05-30 14:10:55 UTC
-+++ src/gzip_et_al.c
-@@ -109,7 +109,7 @@ gchar *xa_gzip_et_al_get_command (const gchar *program
- password_str = xa_gzip_et_al_password_str(password, type);
- workfile = xa_escape_bad_chars(workfile, "\"");
- archive = xa_quote_shell_command(archive, TRUE);
-- command = g_strconcat("sh -c \"", program, " ", workfile, password_str, type == XARCHIVETYPE_LRZIP ? " -fo " : " -c > ", archive, "\"", NULL);
-+ command = g_strconcat("sh -c \"", program, type == XARCHIVETYPE_LRZIP ? " " : " -c ", workfile, password_str, type == XARCHIVETYPE_LRZIP ? " -fo " : " > ", archive, "\"", NULL);
- g_free(archive);
- g_free(workfile);
- g_free(password_str);
-@@ -468,7 +468,7 @@ void xa_gzip_et_al_list (XArchive *archive)
- archive_path = xa_quote_shell_command(archive->path[0], TRUE);
-
- archive->child_dir = g_strdup(archive->working_dir);
-- command = g_strconcat("sh -c \"", archiver[archive->type].program[0], " -d", password_str, " ", archive_path, lrzip ? " -fo " : " -c > ", decompfile, "\"", NULL);
-+ command = g_strconcat("sh -c \"", archiver[archive->type].program[0], lrzip ? " " : " -c ", "-d", password_str, " ", archive_path, lrzip ? " -fo " : " > ", decompfile, "\"", NULL);
- xa_run_command(archive, command);
- g_free(command);
-
-@@ -702,7 +702,7 @@ gboolean xa_gzip_et_al_extract (XArchive *archive, GSL
- if (archive->do_overwrite || !g_file_test(out_file, G_FILE_TEST_EXISTS))
- {
- password_str = xa_gzip_et_al_password_str(archive->password, archive->type);
-- command = g_strconcat("sh -c \"", archiver[archive->type].program[0], " -d", password_str, " ", archive_path, lrzip ? " -fo " : " -c > ", extraction_dir, "/", files_str, "\"", NULL);
-+ command = g_strconcat("sh -c \"", archiver[archive->type].program[0], lrzip ? " " : " -c ", "-d", password_str, " ", archive_path, lrzip ? " -fo " : " > ", extraction_dir, "/", files_str, "\"", NULL);
- g_free(password_str);
- }
- else
-@@ -777,7 +777,7 @@ void xa_gzip_et_al_add (XArchive *archive, GSList *fil
- move = g_strdup("");
-
- password_str = xa_gzip_et_al_password_str(archive->password, archive->type);
-- command = g_strconcat("sh -c \"", archiver[archive->type].program[0], " -", compress ? "b " : (lrzip ? "L " : ""), compression, password_str, files_str, lrzip ? " -fo " : " -c > ", archive_path, move, "\"", NULL);
-+ command = g_strconcat("sh -c \"", archiver[archive->type].program[0], lrzip ? " -" : " -c -", compress ? "b " : (lrzip ? "L " : ""), compression, password_str, files_str, lrzip ? " -fo " : " > ", archive_path, move, "\"", NULL);
- g_free(password_str);
-
- g_free(move);