aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2024-09-25 21:43:22 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2024-09-25 21:43:22 +0000
commitdf3c96e94d4775c63b86156bece7978b4c948cfb (patch)
tree808ce0e01c82f87ddede2e0747279fc33ce7ca96
parent895106462b203e12878a42a5ff6aa1ee924068e9 (diff)
www/firefox www/firefox-esr mail/thunderbird: set wxneeded
people keep twiddling the knobs and see fallot from setting kern.elf64.allow_wx PR: 272767
-rw-r--r--Mk/bsd.gecko.mk5
-rw-r--r--mail/thunderbird/Makefile1
-rw-r--r--www/firefox-esr/Makefile1
-rw-r--r--www/firefox/Makefile1
4 files changed, 7 insertions, 1 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 08fa01ff9646..c6fb935ba593 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -60,7 +60,8 @@ MOZILLA?= ${PORTNAME}
MOZILLA_VER?= ${PORTVERSION}
MOZILLA_BIN?= ${PORTNAME}-bin
MOZILLA_EXEC_NAME?=${MOZILLA}
-USES+= compiler:c++17-lang cpe gl gmake gnome iconv llvm:min=17,noexport localbase \
+USES+= compiler:c++17-lang cpe elfctl gl gmake gnome iconv \
+ llvm:min=17,noexport localbase \
pkgconfig python:build desktop-file-utils
CPE_VENDOR?=mozilla
USE_GL= gl
@@ -71,6 +72,8 @@ CONFIGURE_OUTSOURCE= yes
LDFLAGS+= -Wl,--as-needed -Wl,--undefined-version
BINARY_ALIAS+= python3=${PYTHON_CMD}
+ELF_FEATURES+= +wxneeded:dist/bin/${MOZILLA} +wxneeded:dist/bin/${MOZILLA}-bin
+
BUNDLE_LIBS= yes
BUILD_DEPENDS+= rust-cbindgen>=0.26.0:devel/rust-cbindgen \
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 36e557cb7286..ff625d5638bd 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -1,5 +1,6 @@
PORTNAME= thunderbird
DISTVERSION= 128.2.3
+PORTREVISION= 1
CATEGORIES= mail news net-im wayland
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}esr-candidates/build1/source
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index b00a72194831..fbb6d8631939 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -1,5 +1,6 @@
PORTNAME= firefox
DISTVERSION= 128.3.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www wayland
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 522b4ad88dbd..897cc7c7b42a 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -1,5 +1,6 @@
PORTNAME= firefox
DISTVERSION= 131.0
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= www wayland
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}${DISTVERSIONSUFFIX}/source \