aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-08-28 08:43:54 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-08-28 08:57:31 +0000
commite011fe87582bcb59f7a2f51e3bd86e99f862d039 (patch)
tree0cb58c950e2d42e0941aa4c1c3855d52130a73fa
parent0cf3e3b7fec401cfc316e42809d2f5696a899839 (diff)
downloadports-e011fe87582b.tar.gz
ports-e011fe87582b.zip
x11-toolkits/gtk-layer-shell: convert TEST option into build cookie
-rw-r--r--x11-toolkits/gtk-layer-shell/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/x11-toolkits/gtk-layer-shell/Makefile b/x11-toolkits/gtk-layer-shell/Makefile
index 6a6d770f39e0..d93ce52c5d65 100644
--- a/x11-toolkits/gtk-layer-shell/Makefile
+++ b/x11-toolkits/gtk-layer-shell/Makefile
@@ -13,6 +13,7 @@ LICENSE_FILE_MIT= ${WRKSRC}/LICENSE_MIT.txt
BUILD_DEPENDS= wayland-protocols>=1.16:graphics/wayland-protocols
LIB_DEPENDS= libwayland-client.so:graphics/wayland
+TEST_DEPENDS= evdev-proto>0:devel/evdev-proto
USES= compiler:c11 gnome meson pkgconfig
USE_GNOME= gtk30 introspection:build
@@ -20,16 +21,18 @@ USE_GITHUB= yes
USE_LDCONFIG= yes
GH_ACCOUNT= wmww
-OPTIONS_DEFINE= DOCS EXAMPLES TEST
+OPTIONS_DEFINE= DOCS EXAMPLES
DOCS_BUILD_DEPENDS= gtk-doc>0:textproc/gtk-doc
DOCS_MESON_TRUE= docs
EXAMPLES_MESON_TRUE= examples
-TEST_BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto
-TEST_MESON_TRUE= tests
-
-pre-install-TEST-on: do-test
+pre-test:
+ @if [ ! -e ${WRKDIR}/.meson_build_tests ]; then \
+ ${RM} ${CONFIGURE_COOKIE} ${BUILD_COOKIE}; \
+ ${MAKE} -C${.CURDIR} build MESON_ARGS="${MESON_ARGS} --reconfigure -Dtests=true"; \
+ ${TOUCH} ${WRKDIR}/.meson_build_tests; \
+ fi
.include <bsd.port.mk>