aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2023-03-14 20:56:42 +0000
committerDon Lewis <truckman@FreeBSD.org>2023-03-14 21:19:45 +0000
commite0a892ced94cf2502b2f8401b24c358bd3f7f6a1 (patch)
tree1dc0026c17c6af8c9b255c5433ed710f67d9ff1f
parente5ac22c6a4a380d80b189ab7d09ca6cac77a6837 (diff)
downloadports-e0a892ced94cf2502b2f8401b24c358bd3f7f6a1.tar.gz
ports-e0a892ced94cf2502b2f8401b24c358bd3f7f6a1.zip
editors/openoffice-*: test for required jar file
Test for a required jar file that is optionally installed by textproc/lucene and fail at the configure step with a helpful message if we don't find it. If the jar file is missing, javac fails during the build of l10ntools module with an unhelpful error message that does not pinpoint the cause of the problem. PR: 270158 Reported by: Ken Gunderson <kgunders@teamcool.net>
-rw-r--r--editors/openoffice-4/Makefile8
-rw-r--r--editors/openoffice-devel/Makefile9
2 files changed, 17 insertions, 0 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index 6fd8b3d81a44..fa78c44e61ae 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -410,6 +410,14 @@ post-patch:
${REINPLACE_CMD} -e "s/ := -Os/ := -O2 -fno-unroll-loops/" ${WRKSRC}/solenv/gbuild/platform/freebsd.mk
.endif
+# Verify that lucene was built with the CONTRIB option instead of
+# failing mysteriously during the build
+pre-configure:
+ @if [ ! -f ${JAVALIBDIR}/lucene-analyzers-3.6.2.jar ]; then \
+ ${ECHO} "error: textproc/lucene must be built with the CONTRIB option enabled"; \
+ exit 1; \
+ fi
+
do-build:
${PRINTF} "[repositories]\nmain=active\nextras=active\n" > ${WRKSUBDIR}/source_config
cd ${WRKSRC} ; ./bootstrap
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index b58427969cde..21f3a7170163 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -54,6 +54,7 @@ BROKEN_powerpc64= fails to compile: aoo-4.2.0/main/solver/420/unxfbsdppc64.pro/i
BUILD_DEPENDS= \
p5-Archive-Zip>=0:archivers/p5-Archive-Zip \
+ ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs \
${LOCALBASE}/bin/unzip:archivers/unzip \
zip:archivers/zip \
ant:devel/apache-ant \
@@ -414,6 +415,14 @@ post-patch:
${WRKSRC}/desktop/scripts/soffice.sh
${REINPLACE_CMD} -e '/^mkdir -p/,$$d' ${CREATE_TREE}
+# Verify that lucene was built with the CONTRIB option instead of
+# failing mysteriously during the build
+pre-configure:
+ @if [ ! -f ${JAVALIBDIR}/lucene-analyzers-3.6.2.jar ]; then \
+ ${ECHO} "error: textproc/lucene must be built with the CONTRIB option enabled"; \
+ exit 1; \
+ fi
+
do-build:
${PRINTF} "[repositories]\nmain=active\nextras=active\n" > ${WRKSUBDIR}/source_config
cd ${WRKSRC} ; ./bootstrap