aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2022-09-08 16:09:09 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2022-09-08 16:21:56 +0000
commite1abc97d9ede14c8e14b120de52b350acd77f3f4 (patch)
treec3e6f810da7e859cb0030868cbabfc433419ef95
parent4d7b9fbb0dbedad2db1f74aa42291c133d3ff73b (diff)
downloadports-e1abc97d9ede14c8e14b120de52b350acd77f3f4.tar.gz
ports-e1abc97d9ede14c8e14b120de52b350acd77f3f4.zip
devel/arcanist-lib: Fix `arc patch` on PHP 8.1
-rw-r--r--devel/arcanist-lib/Makefile1
-rw-r--r--devel/arcanist-lib/files/patch-src_parser_ArcanistBundle.php20
-rw-r--r--devel/arcanist-lib/files/patch-src_toolset_workflow_ArcanistVersionWorkflow.php (renamed from devel/arcanist-lib/files/patch-src-toolset-workflow-ArcanistVersionWorkflow.php)0
3 files changed, 21 insertions, 0 deletions
diff --git a/devel/arcanist-lib/Makefile b/devel/arcanist-lib/Makefile
index 3be58fea6b70..3f2065d8d138 100644
--- a/devel/arcanist-lib/Makefile
+++ b/devel/arcanist-lib/Makefile
@@ -1,5 +1,6 @@
PORTNAME?= arcanist
PORTVERSION?= 20220518
+PORTREVISION?= 1
CATEGORIES?= devel
PKGNAMESUFFIX= ${SLAVE_PKGNAMESUFFIX}${PHP_PKGNAMESUFFIX}
diff --git a/devel/arcanist-lib/files/patch-src_parser_ArcanistBundle.php b/devel/arcanist-lib/files/patch-src_parser_ArcanistBundle.php
new file mode 100644
index 000000000000..095e1b24ee81
--- /dev/null
+++ b/devel/arcanist-lib/files/patch-src_parser_ArcanistBundle.php
@@ -0,0 +1,20 @@
+--- src/parser/ArcanistBundle.php.orig 2022-09-08 16:04:09 UTC
++++ src/parser/ArcanistBundle.php
+@@ -762,7 +762,7 @@ final class ArcanistBundle extends Phobject {
+ $old_data = $this->getBlob($old_phid, $name);
+ }
+
+- $old_length = strlen($old_data);
++ $old_length = strlen($old_data ?? '');
+
+ // Here, and below, the binary will be emitted with base85 encoding. This
+ // encoding encodes each 4 bytes of input in 5 bytes of output, so we may
+@@ -795,7 +795,7 @@ final class ArcanistBundle extends Phobject {
+ $new_data = $this->getBlob($new_phid, $name);
+ }
+
+- $new_length = strlen($new_data);
++ $new_length = strlen($new_data ?? '');
+ $this->reserveBytes($new_length * 5 / 4);
+
+ if ($new_data === null) {
diff --git a/devel/arcanist-lib/files/patch-src-toolset-workflow-ArcanistVersionWorkflow.php b/devel/arcanist-lib/files/patch-src_toolset_workflow_ArcanistVersionWorkflow.php
index e76384bac69e..e76384bac69e 100644
--- a/devel/arcanist-lib/files/patch-src-toolset-workflow-ArcanistVersionWorkflow.php
+++ b/devel/arcanist-lib/files/patch-src_toolset_workflow_ArcanistVersionWorkflow.php