aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2022-09-09 21:00:54 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2022-09-09 21:02:04 +0000
commite2438a86b81aea7cd41a66ca23fc49510679d85b (patch)
treef88a421ed67abc4b9fcf70548478bdc6d19564e3
parent25304492d782a019324b8281d87effdd75ce1396 (diff)
downloadports-e2438a86b81aea7cd41a66ca23fc49510679d85b.tar.gz
ports-e2438a86b81aea7cd41a66ca23fc49510679d85b.zip
*/*: Update path set in BUILD_DEPENDS for CMake in more ports
Commit b23ea4e2d2f51b53d8915fe9fd7b4efbdd575e38 changed its location to devel/cmake-core Approved by: portmgr (blanket)
-rw-r--r--audio/bangr-lv2/Makefile2
-rw-r--r--audio/bshapr-lv2/Makefile2
-rw-r--r--databases/cockroach/Makefile2
-rw-r--r--databases/leofs/Makefile2
-rw-r--r--databases/py-caterva/Makefile2
-rw-r--r--databases/xtrabackup/Makefile2
-rw-r--r--devel/criterion/Makefile2
-rw-r--r--devel/py-line-profiler/Makefile2
-rw-r--r--devel/py-ubelt/Makefile2
-rw-r--r--dns/knot-resolver/Makefile2
-rw-r--r--games/0ad/Makefile2
-rw-r--r--graphics/dust3d/Makefile2
-rw-r--r--lang/julia/Makefile2
-rw-r--r--lang/mono/Makefile2
-rw-r--r--lang/mono5.10/Makefile2
-rw-r--r--lang/mono5.20/Makefile2
-rw-r--r--lang/mono6.8/Makefile2
-rw-r--r--lang/rust-bootstrap/Makefile2
-rw-r--r--math/py-fenics-basix/Makefile2
-rw-r--r--math/py-gau2grid/Makefile2
-rw-r--r--math/py-osqp/Makefile2
-rw-r--r--math/py-pdal/Makefile2
-rw-r--r--math/py-qdldl/Makefile2
-rw-r--r--math/sage/Makefile2
-rw-r--r--misc/py-ezc3d/Makefile2
-rw-r--r--misc/py-onnx/Makefile2
-rw-r--r--multimedia/handbrake/Makefile2
-rw-r--r--multimedia/tvheadend/Makefile2
-rw-r--r--science/py-pyqubo/Makefile2
-rw-r--r--science/py-pyscf/Makefile2
-rw-r--r--science/py-qiskit-aer/Makefile2
-rw-r--r--science/py-tweedledum/Makefile2
32 files changed, 32 insertions, 32 deletions
diff --git a/audio/bangr-lv2/Makefile b/audio/bangr-lv2/Makefile
index 1c6794119354..24481a3c0ce4 100644
--- a/audio/bangr-lv2/Makefile
+++ b/audio/bangr-lv2/Makefile
@@ -11,7 +11,7 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= lv2>0:audio/lv2 \
- cmake:devel/cmake
+ cmake:devel/cmake-core
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
diff --git a/audio/bshapr-lv2/Makefile b/audio/bshapr-lv2/Makefile
index e836dd177422..41ac61bf158b 100644
--- a/audio/bshapr-lv2/Makefile
+++ b/audio/bshapr-lv2/Makefile
@@ -12,7 +12,7 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= lv2>0:audio/lv2 \
- cmake:devel/cmake
+ cmake:devel/cmake-core
USES= compiler:c++11-lang gmake gnome pkgconfig xorg
USE_GITHUB= yes
diff --git a/databases/cockroach/Makefile b/databases/cockroach/Makefile
index 75e4c26cf3a3..36a8914da1c3 100644
--- a/databases/cockroach/Makefile
+++ b/databases/cockroach/Makefile
@@ -18,7 +18,7 @@ ONLY_FOR_ARCHS_REASON= 64-bit system is strongly recommended
BUILD_DEPENDS= autoconf:devel/autoconf \
bash:shells/bash \
- cmake:devel/cmake
+ cmake:devel/cmake-core
USES= gmake go libedit
diff --git a/databases/leofs/Makefile b/databases/leofs/Makefile
index d7112f0cd0fc..17ae97454d46 100644
--- a/databases/leofs/Makefile
+++ b/databases/leofs/Makefile
@@ -15,7 +15,7 @@ NOT_FOR_ARCHS= riscv64 sparc64
NOT_FOR_ARCHS_REASON= does not build: error Please implement AtomicPointer for this platform
BUILD_DEPENDS= ${LOCALBASE}/lib/erlang21/bin/erlc:lang/erlang-runtime21 \
- ${LOCALBASE}/bin/cmake:devel/cmake \
+ ${LOCALBASE}/bin/cmake:devel/cmake-core \
${LOCALBASE}/lib/libcheck.a:devel/check
USE_GITHUB= yes
diff --git a/databases/py-caterva/Makefile b/databases/py-caterva/Makefile
index 46fde8daee8d..0a97e4c27338 100644
--- a/databases/py-caterva/Makefile
+++ b/databases/py-caterva/Makefile
@@ -13,7 +13,7 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= caterva>=0.5.0_2:databases/caterva \
- cmake:devel/cmake \
+ cmake:devel/cmake-core \
ninja:devel/ninja \
${PYTHON_PKGNAMEPREFIX}scikit-build>=0:devel/py-scikit-build@${PY_FLAVOR}
LIB_DEPENDS= libblosc2.so:archivers/c-blosc2 \
diff --git a/databases/xtrabackup/Makefile b/databases/xtrabackup/Makefile
index 05e96aef302f..5223551c9a3c 100644
--- a/databases/xtrabackup/Makefile
+++ b/databases/xtrabackup/Makefile
@@ -19,7 +19,7 @@ BROKEN_mips64= fails to compile: 'fpsetmask' was not declared in this scope
# quilt is required by build.sh
BUILD_DEPENDS= bash:shells/bash \
- cmake:devel/cmake
+ cmake:devel/cmake-core
LIB_DEPENDS= libcurl.so:ftp/curl \
libev.so:devel/libev \
libgcrypt.so:security/libgcrypt \
diff --git a/devel/criterion/Makefile b/devel/criterion/Makefile
index 6ba52dc2d57a..9ad3fc1fe28a 100644
--- a/devel/criterion/Makefile
+++ b/devel/criterion/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}protobuf>0:devel/py-protobuf@${PY_FLAVOR} \
nanopb>0:devel/nanopb \
- cmake:devel/cmake \
+ cmake:devel/cmake-core \
protoc:devel/protobuf
LIB_DEPENDS= libboxfort.so:devel/boxfort \
libffi.so:devel/libffi \
diff --git a/devel/py-line-profiler/Makefile b/devel/py-line-profiler/Makefile
index 19dd5d603447..8288c124bb5a 100644
--- a/devel/py-line-profiler/Makefile
+++ b/devel/py-line-profiler/Makefile
@@ -13,7 +13,7 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scikit-build>0:devel/py-scikit-build@${PY_FLAVOR} \
- cmake:devel/cmake
+ cmake:devel/cmake-core
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=5.3:devel/py-coverage@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ipython>=0.13:devel/ipython@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
diff --git a/devel/py-ubelt/Makefile b/devel/py-ubelt/Makefile
index 1b98bb6629f1..67426965b085 100644
--- a/devel/py-ubelt/Makefile
+++ b/devel/py-ubelt/Makefile
@@ -12,7 +12,7 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scikit-build>0:devel/py-scikit-build@${PY_FLAVOR} \
- cmake:devel/cmake
+ cmake:devel/cmake-core
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}codecov>=2.0.15:devel/py-codecov@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}coverage>0:devel/py-coverage@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
diff --git a/dns/knot-resolver/Makefile b/dns/knot-resolver/Makefile
index 6d3d794fae35..7c248dcc1c03 100644
--- a/dns/knot-resolver/Makefile
+++ b/dns/knot-resolver/Makefile
@@ -12,7 +12,7 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= bash:shells/bash \
- cmake:devel/cmake \
+ cmake:devel/cmake-core \
flake8:devel/py-flake8@${PY_FLAVOR} \
lua51-cqueues>=20200726_1:devel/lua-cqueues@lua51 \
luacheck:devel/lua-luacheck
diff --git a/games/0ad/Makefile b/games/0ad/Makefile
index 476252b5ee59..b92074df4535 100644
--- a/games/0ad/Makefile
+++ b/games/0ad/Makefile
@@ -18,7 +18,7 @@ BROKEN_powerpc64= fails to compile: _psutil_bsd.c: error: 'struct xtcpcb' has no
BUILD_DEPENDS= ${RUST_DEFAULT}>=1.35:lang/${RUST_DEFAULT} \
zip:archivers/zip \
- cmake:devel/cmake
+ cmake:devel/cmake-core
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libicui18n.so:devel/icu \
libpng.so:graphics/png \
diff --git a/graphics/dust3d/Makefile b/graphics/dust3d/Makefile
index 90dd5c3b799e..6df3b8a9ed59 100644
--- a/graphics/dust3d/Makefile
+++ b/graphics/dust3d/Makefile
@@ -17,7 +17,7 @@ BROKEN_aarch64= build fails: use of undeclared identifier '__TBB_machine_fetchad
BUILD_DEPENDS= ${LOCALBASE}/include/boost/config.hpp:devel/boost-libs \
${LOCALBASE}/include/CGAL/Polygon_mesh_processing/corefinement.h:math/cgal \
- cmake:devel/cmake
+ cmake:devel/cmake-core
LIB_DEPENDS= libgmp.so:math/gmp libmpfr.so:math/mpfr
USES= compiler:c++14-lang gmake qt:5
diff --git a/lang/julia/Makefile b/lang/julia/Makefile
index 41be31d55d7c..23260385466f 100644
--- a/lang/julia/Makefile
+++ b/lang/julia/Makefile
@@ -16,7 +16,7 @@ ONLY_FOR_ARCHS_REASON= Has not been ported to this platform for freebsd
MY_DEPENDS= 7zz:archivers/7-zip
BUILD_DEPENDS= patchelf:sysutils/patchelf \
- cmake:devel/cmake \
+ cmake:devel/cmake-core \
${MY_DEPENDS}
LIB_DEPENDS= libcurl.so:ftp/curl \
libgit2.so:devel/libgit2 \
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index 72c86d2ee277..858684cf60aa 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -16,7 +16,7 @@ ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386 powerpc powerpc64 powerpc64le
BUILD_DEPENDS= p5-XML-Parser>=0:textproc/p5-XML-Parser \
bash:shells/bash \
- cmake>0:devel/cmake
+ cmake>0:devel/cmake-core
LIB_DEPENDS= libinotify.so:devel/libinotify
RUN_DEPENDS= ${PY_PILLOW} \
ca_root_nss>=0:security/ca_root_nss
diff --git a/lang/mono5.10/Makefile b/lang/mono5.10/Makefile
index 0578d98080a1..9c531d53d6d8 100644
--- a/lang/mono5.10/Makefile
+++ b/lang/mono5.10/Makefile
@@ -17,7 +17,7 @@ ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386 powerpc powerpc64 powerpc64le
BUILD_DEPENDS= p5-XML-Parser>=0:textproc/p5-XML-Parser \
bash:shells/bash \
- cmake>0:devel/cmake
+ cmake>0:devel/cmake-core
LIB_DEPENDS= libinotify.so:devel/libinotify
RUN_DEPENDS= ${PY_PILLOW} \
ca_root_nss>=0:security/ca_root_nss
diff --git a/lang/mono5.20/Makefile b/lang/mono5.20/Makefile
index f920b5a06988..5bbafe1f6f1a 100644
--- a/lang/mono5.20/Makefile
+++ b/lang/mono5.20/Makefile
@@ -17,7 +17,7 @@ ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386 powerpc powerpc64 powerpc64le
BUILD_DEPENDS= p5-XML-Parser>=0:textproc/p5-XML-Parser \
bash:shells/bash \
- cmake>0:devel/cmake
+ cmake>0:devel/cmake-core
LIB_DEPENDS= libinotify.so:devel/libinotify
RUN_DEPENDS= ca_root_nss>=0:security/ca_root_nss
diff --git a/lang/mono6.8/Makefile b/lang/mono6.8/Makefile
index b2a2ebb145ee..5f7dbd67bcd5 100644
--- a/lang/mono6.8/Makefile
+++ b/lang/mono6.8/Makefile
@@ -17,7 +17,7 @@ NOT_FOR_ARCHS= riscv64 riscv64sf sparc64
BUILD_DEPENDS= p5-XML-Parser>=0:textproc/p5-XML-Parser \
bash:shells/bash \
- cmake>0:devel/cmake
+ cmake>0:devel/cmake-core
LIB_DEPENDS= libinotify.so:devel/libinotify
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR} \
ca_root_nss>=0:security/ca_root_nss \
diff --git a/lang/rust-bootstrap/Makefile b/lang/rust-bootstrap/Makefile
index f4b6c2893cbf..7f6049b268fb 100644
--- a/lang/rust-bootstrap/Makefile
+++ b/lang/rust-bootstrap/Makefile
@@ -23,7 +23,7 @@ ONLY_FOR_ARCHS= amd64 powerpc64le
ONLY_FOR_ARCHS_REASON= untested on other architectures
BUILD_DEPENDS= ${FLAVOR:S/_/-/g}-freebsd-sysroot>=a2021.09.14:devel/freebsd-sysroot@${FLAVOR} \
- cmake:devel/cmake \
+ cmake:devel/cmake-core \
gmake:devel/gmake \
rust>=${PORTVERSION}:lang/rust
diff --git a/math/py-fenics-basix/Makefile b/math/py-fenics-basix/Makefile
index c743c0dbd1a0..d6c0adbf715f 100644
--- a/math/py-fenics-basix/Makefile
+++ b/math/py-fenics-basix/Makefile
@@ -12,7 +12,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/../LICENSE
BUILD_DEPENDS= pybind11>=2.6.4:devel/pybind11 \
- cmake>=3.16:devel/cmake \
+ cmake>=3.16:devel/cmake-core \
xtensor>0:math/xtensor \
xtl-quant-stack>0:devel/xtl-quant-stack \
${PYTHON_PKGNAMEPREFIX}pip>0:devel/py-pip@${PY_FLAVOR} \
diff --git a/math/py-gau2grid/Makefile b/math/py-gau2grid/Makefile
index 8f1a20a8b616..2ea05f2fd45b 100644
--- a/math/py-gau2grid/Makefile
+++ b/math/py-gau2grid/Makefile
@@ -12,7 +12,7 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYNUMPY} \
- cmake:devel/cmake
+ cmake:devel/cmake-core
RUN_DEPENDS= ${PYNUMPY}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
diff --git a/math/py-osqp/Makefile b/math/py-osqp/Makefile
index 2c5cfedfdff2..454c7a52f53c 100644
--- a/math/py-osqp/Makefile
+++ b/math/py-osqp/Makefile
@@ -16,7 +16,7 @@ PY_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}qdldl>0:math/py-qdldl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.13.2:science/py-scipy@${PY_FLAVOR}
BUILD_DEPENDS= ${PY_DEPENDS} \
- cmake:devel/cmake
+ cmake:devel/cmake-core
RUN_DEPENDS= ${PY_DEPENDS}
USES= python:3.6+
diff --git a/math/py-pdal/Makefile b/math/py-pdal/Makefile
index 996c40358250..4f891d772434 100644
--- a/math/py-pdal/Makefile
+++ b/math/py-pdal/Makefile
@@ -15,7 +15,7 @@ LICENSE= BSD3CLAUSE
BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scikit-build>0:devel/py-scikit-build@${PY_FLAVOR} \
${PREFIX}/share/cmake/pybind11/pybind11Config.cmake:devel/pybind11 \
- cmake:devel/cmake
+ cmake:devel/cmake-core
LIB_DEPENDS= libpdal_base.so:math/pdal
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} \
${PYNUMPY}
diff --git a/math/py-qdldl/Makefile b/math/py-qdldl/Makefile
index 0a41fa183dad..9ca822ac0992 100644
--- a/math/py-qdldl/Makefile
+++ b/math/py-qdldl/Makefile
@@ -15,7 +15,7 @@ BROKEN_armv7= error: no matching function for call to 'amd_l_order', see https:/
BROKEN_i386= error: no matching function for call to 'amd_l_order', see https://github.com/oxfordcontrol/qdldl-python/issues/15
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pybind11>0:devel/py-pybind11@${PY_FLAVOR} \
- cmake:devel/cmake
+ cmake:devel/cmake-core
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.13.2:science/py-scipy@${PY_FLAVOR}
TEST_DEPENDS= pytest:devel/py-pytest@${PY_FLAVOR}
diff --git a/math/sage/Makefile b/math/sage/Makefile
index be7d35f8a093..c53a1572606e 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -22,7 +22,7 @@ BROKEN= hoping to fix it with Python-3.9
BUILD_DEPENDS= bash:shells/bash \
dash:shells/dash \
- cmake:devel/cmake \
+ cmake:devel/cmake-core \
dreadnaut:math/nauty \
${PYTHON_PKGNAMEPREFIX}alabaster>0:textproc/py-alabaster@${PY_FLAVOR}\
${PYTHON_PKGNAMEPREFIX}attrs>0:devel/py-attrs@${PY_FLAVOR}\
diff --git a/misc/py-ezc3d/Makefile b/misc/py-ezc3d/Makefile
index cb92eb499b06..27a57dcf5b8b 100644
--- a/misc/py-ezc3d/Makefile
+++ b/misc/py-ezc3d/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scikit-build>0:devel/py-scikit-build@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR} \
- cmake:devel/cmake \
+ cmake:devel/cmake-core \
swig:devel/swig
RUN_DEPENDS= ${PYNUMPY}
diff --git a/misc/py-onnx/Makefile b/misc/py-onnx/Makefile
index 67635e382ce9..84c6372376d9 100644
--- a/misc/py-onnx/Makefile
+++ b/misc/py-onnx/Makefile
@@ -12,7 +12,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= bash:shells/bash \
- cmake:devel/cmake \
+ cmake:devel/cmake-core \
protoc-gen-mypy:devel/py-mypy-protobuf@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pybind11>0:devel/py-pybind11@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-runner>=0:devel/py-pytest-runner@${PY_FLAVOR}
diff --git a/multimedia/handbrake/Makefile b/multimedia/handbrake/Makefile
index 893035e78d3e..842214204105 100644
--- a/multimedia/handbrake/Makefile
+++ b/multimedia/handbrake/Makefile
@@ -19,7 +19,7 @@ ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 powerpc64le
BUILD_DEPENDS= bash:shells/bash \
nasm:devel/nasm \
- cmake:devel/cmake \
+ cmake:devel/cmake-core \
meson:devel/meson
LIB_DEPENDS= libdbus-1.so:devel/dbus \
libgudev-1.0.so:devel/libgudev \
diff --git a/multimedia/tvheadend/Makefile b/multimedia/tvheadend/Makefile
index 92857a3e0d36..16fcf9f24565 100644
--- a/multimedia/tvheadend/Makefile
+++ b/multimedia/tvheadend/Makefile
@@ -12,7 +12,7 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE.md
BUILD_DEPENDS= bash:shells/bash \
- cmake:devel/cmake \
+ cmake:devel/cmake-core \
${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
LIB_DEPENDS= libcurl.so:ftp/curl \
liburiparser.so:net/uriparser \
diff --git a/science/py-pyqubo/Makefile b/science/py-pyqubo/Makefile
index b01203473b6e..19572e34f117 100644
--- a/science/py-pyqubo/Makefile
+++ b/science/py-pyqubo/Makefile
@@ -23,7 +23,7 @@ BUILD_DEPENDS= ${PY_DEPENDS} \
${PYTHON_PKGNAMEPREFIX}wheel>=0.36.2:devel/py-wheel@${PY_FLAVOR} \
boost-libs>0:devel/boost-libs \
cimod>0:math/cimod \
- cmake:devel/cmake \
+ cmake:devel/cmake-core \
ninja:devel/ninja \
pybind11>0:devel/pybind11 \
robin-hood-hashing>0:devel/robin-hood-hashing
diff --git a/science/py-pyscf/Makefile b/science/py-pyscf/Makefile
index 7c2c6fa26652..887bcf8b4a41 100644
--- a/science/py-pyscf/Makefile
+++ b/science/py-pyscf/Makefile
@@ -15,7 +15,7 @@ PY_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}h5py>=2.7:science/py-h5py@${PY_FLAVOR}
BUILD_DEPENDS= ${PY_DEPENDS} \
- cmake:devel/cmake \
+ cmake:devel/cmake-core \
gmake:devel/gmake
LIB_DEPENDS= libcint.so:science/libcint \
libxc.so:science/libxc \
diff --git a/science/py-qiskit-aer/Makefile b/science/py-qiskit-aer/Makefile
index ec37a18f0f7e..117ce3429452 100644
--- a/science/py-qiskit-aer/Makefile
+++ b/science/py-qiskit-aer/Makefile
@@ -15,7 +15,7 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scikit-build>0:devel/py-scikit-build@${PY_FLAVOR} \
- cmake:devel/cmake \
+ cmake:devel/cmake-core \
nlohmann-json>0:devel/nlohmann-json \
${PYTHON_PKGNAMEPREFIX}pip>0:devel/py-pip@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pybind11>0:devel/py-pybind11@${PY_FLAVOR} \
diff --git a/science/py-tweedledum/Makefile b/science/py-tweedledum/Makefile
index cec297c366f4..fd9056f6e9d1 100644
--- a/science/py-tweedledum/Makefile
+++ b/science/py-tweedledum/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_FreeBSD_14= clang crashes, see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=265751
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scikit-build>0:devel/py-scikit-build@${PY_FLAVOR} \
- cmake:devel/cmake
+ cmake:devel/cmake-core
USES= compiler:c++17-lang python
USE_PYTHON= distutils autoplist pytest # tests fail to run, see https://github.com/boschmitt/tweedledum/issues/176