aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2022-11-20 16:38:18 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2022-11-22 09:38:26 +0000
commite245ebd0591acbc1fd82ffd4c69dc03d95887eb0 (patch)
tree4e6797776d649a65f8bfc9bc124585033c0f9bd3
parentd7b669ed0815dbc627ff467781aa2e08ddd22496 (diff)
downloadports-e245ebd0591acbc1fd82ffd4c69dc03d95887eb0.tar.gz
ports-e245ebd0591acbc1fd82ffd4c69dc03d95887eb0.zip
devel/libgit2: update to 1.5.0
-rw-r--r--devel/libgit2/Makefile2
-rw-r--r--devel/libgit2/distinfo6
-rw-r--r--devel/libgit2/files/patch-tests_network_url_parse.c116
-rw-r--r--devel/libgit2/pkg-plist2
4 files changed, 6 insertions, 120 deletions
diff --git a/devel/libgit2/Makefile b/devel/libgit2/Makefile
index 9515b3a28daa..89f47924c907 100644
--- a/devel/libgit2/Makefile
+++ b/devel/libgit2/Makefile
@@ -5,7 +5,7 @@
PORTNAME= libgit2
DISTVERSIONPREFIX= v
-DISTVERSION= 1.3.2
+DISTVERSION= 1.5.0
CATEGORIES= devel
MAINTAINER= mfechner@FreeBSD.org
diff --git a/devel/libgit2/distinfo b/devel/libgit2/distinfo
index 9e0e5ff0cdf9..e84ab241d109 100644
--- a/devel/libgit2/distinfo
+++ b/devel/libgit2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1657692035
-SHA256 (libgit2-libgit2-v1.3.2_GH0.tar.gz) = 3a4469b32b73d53f9dbb7bf17b61b0cfb7dae9020e199f928fa96f12d6eb29cb
-SIZE (libgit2-libgit2-v1.3.2_GH0.tar.gz) = 5824473
+TIMESTAMP = 1668845752
+SHA256 (libgit2-libgit2-v1.5.0_GH0.tar.gz) = 8de872a0f201b33d9522b817c92e14edb4efad18dae95cf156cf240b2efff93e
+SIZE (libgit2-libgit2-v1.5.0_GH0.tar.gz) = 5893437
diff --git a/devel/libgit2/files/patch-tests_network_url_parse.c b/devel/libgit2/files/patch-tests_network_url_parse.c
deleted file mode 100644
index d466cb1ce18f..000000000000
--- a/devel/libgit2/files/patch-tests_network_url_parse.c
+++ /dev/null
@@ -1,116 +0,0 @@
---- tests/network/url/parse.c.orig 2021-09-27 20:09:50 UTC
-+++ tests/network/url/parse.c
-@@ -63,18 +63,6 @@ void test_network_url_parse__hostname_implied_root_cus
- cl_assert_equal_i(git_net_url_is_default_port(&conndata), 0);
- }
-
--void test_network_url_parse__hostname_implied_root_empty_port(void)
--{
-- cl_git_pass(git_net_url_parse(&conndata, "http://example.com:"));
-- cl_assert_equal_s(conndata.scheme, "http");
-- cl_assert_equal_s(conndata.host, "example.com");
-- cl_assert_equal_s(conndata.port, "80");
-- cl_assert_equal_s(conndata.path, "/");
-- cl_assert_equal_p(conndata.username, NULL);
-- cl_assert_equal_p(conndata.password, NULL);
-- cl_assert_equal_i(git_net_url_is_default_port(&conndata), 1);
--}
--
- void test_network_url_parse__hostname_encoded_password(void)
- {
- cl_git_pass(git_net_url_parse(&conndata,
-@@ -129,18 +117,6 @@ void test_network_url_parse__hostname_port(void)
- cl_assert_equal_i(git_net_url_is_default_port(&conndata), 0);
- }
-
--void test_network_url_parse__hostname_empty_port(void)
--{
-- cl_git_pass(git_net_url_parse(&conndata, "http://example.com:/resource"));
-- cl_assert_equal_s(conndata.scheme, "http");
-- cl_assert_equal_s(conndata.host, "example.com");
-- cl_assert_equal_s(conndata.port, "80");
-- cl_assert_equal_s(conndata.path, "/resource");
-- cl_assert_equal_p(conndata.username, NULL);
-- cl_assert_equal_p(conndata.password, NULL);
-- cl_assert_equal_i(git_net_url_is_default_port(&conndata), 1);
--}
--
- void test_network_url_parse__hostname_user_port(void)
- {
- /* user@hostname.tld:port/resource */
-@@ -219,18 +195,6 @@ void test_network_url_parse__ipv4_implied_root_custom_
- cl_assert_equal_i(git_net_url_is_default_port(&conndata), 0);
- }
-
--void test_network_url_parse__ipv4_implied_root_empty_port(void)
--{
-- cl_git_pass(git_net_url_parse(&conndata, "http://192.168.1.1:"));
-- cl_assert_equal_s(conndata.scheme, "http");
-- cl_assert_equal_s(conndata.host, "192.168.1.1");
-- cl_assert_equal_s(conndata.port, "80");
-- cl_assert_equal_s(conndata.path, "/");
-- cl_assert_equal_p(conndata.username, NULL);
-- cl_assert_equal_p(conndata.password, NULL);
-- cl_assert_equal_i(git_net_url_is_default_port(&conndata), 1);
--}
--
- void test_network_url_parse__ipv4_encoded_password(void)
- {
- cl_git_pass(git_net_url_parse(&conndata,
-@@ -283,18 +247,6 @@ void test_network_url_parse__ipv4_port(void)
- cl_assert_equal_i(git_net_url_is_default_port(&conndata), 0);
- }
-
--void test_network_url_parse__ipv4_empty_port(void)
--{
-- cl_git_pass(git_net_url_parse(&conndata, "http://192.168.1.1:/resource"));
-- cl_assert_equal_s(conndata.scheme, "http");
-- cl_assert_equal_s(conndata.host, "192.168.1.1");
-- cl_assert_equal_s(conndata.port, "80");
-- cl_assert_equal_s(conndata.path, "/resource");
-- cl_assert_equal_p(conndata.username, NULL);
-- cl_assert_equal_p(conndata.password, NULL);
-- cl_assert_equal_i(git_net_url_is_default_port(&conndata), 1);
--}
--
- void test_network_url_parse__ipv4_user_port(void)
- {
- cl_git_pass(git_net_url_parse(&conndata,
-@@ -371,18 +323,6 @@ void test_network_url_parse__ipv6_implied_root_custom_
- cl_assert_equal_i(git_net_url_is_default_port(&conndata), 0);
- }
-
--void test_network_url_parse__ipv6_implied_root_empty_port(void)
--{
-- cl_git_pass(git_net_url_parse(&conndata, "http://[fe80::dcad:beff:fe00:0001]:"));
-- cl_assert_equal_s(conndata.scheme, "http");
-- cl_assert_equal_s(conndata.host, "fe80::dcad:beff:fe00:0001");
-- cl_assert_equal_s(conndata.port, "80");
-- cl_assert_equal_s(conndata.path, "/");
-- cl_assert_equal_p(conndata.username, NULL);
-- cl_assert_equal_p(conndata.password, NULL);
-- cl_assert_equal_i(git_net_url_is_default_port(&conndata), 1);
--}
--
- void test_network_url_parse__ipv6_encoded_password(void)
- {
- cl_git_pass(git_net_url_parse(&conndata,
-@@ -433,18 +373,6 @@ void test_network_url_parse__ipv6_port(void)
- cl_assert_equal_p(conndata.username, NULL);
- cl_assert_equal_p(conndata.password, NULL);
- cl_assert_equal_i(git_net_url_is_default_port(&conndata), 0);
--}
--
--void test_network_url_parse__ipv6_empty_port(void)
--{
-- cl_git_pass(git_net_url_parse(&conndata, "http://[fe80::dcad:beff:fe00:0001]:/resource"));
-- cl_assert_equal_s(conndata.scheme, "http");
-- cl_assert_equal_s(conndata.host, "fe80::dcad:beff:fe00:0001");
-- cl_assert_equal_s(conndata.port, "80");
-- cl_assert_equal_s(conndata.path, "/resource");
-- cl_assert_equal_p(conndata.username, NULL);
-- cl_assert_equal_p(conndata.password, NULL);
-- cl_assert_equal_i(git_net_url_is_default_port(&conndata), 1);
- }
-
- void test_network_url_parse__ipv6_user_port(void)
diff --git a/devel/libgit2/pkg-plist b/devel/libgit2/pkg-plist
index a1b85dce32c1..5d774ab0854c 100644
--- a/devel/libgit2/pkg-plist
+++ b/devel/libgit2/pkg-plist
@@ -1,3 +1,4 @@
+bin/git2_cli
include/git2.h
include/git2/annotated_commit.h
include/git2/apply.h
@@ -77,6 +78,7 @@ include/git2/sys/openssl.h
include/git2/sys/path.h
include/git2/sys/refdb_backend.h
include/git2/sys/reflog.h
+include/git2/sys/remote.h
include/git2/sys/refs.h
include/git2/sys/repository.h
include/git2/sys/stream.h