aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2022-08-16 06:35:10 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2022-08-24 04:22:18 +0000
commite29f661c9c9db68a2fca2a8e44a6b6a6dd2fed1e (patch)
tree2788e921570956f9049fdfbe9cbc9a86f1d5c821
parentc4576ad47142eab331b8bb345de3c73fce463f04 (diff)
downloadports-e29f661c9c9db68a2fca2a8e44a6b6a6dd2fed1e.tar.gz
ports-e29f661c9c9db68a2fca2a8e44a6b6a6dd2fed1e.zip
security/rubygem-omniauth: most deps use now version 2 of omniauth
-rw-r--r--net/rubygem-omniauth-azure-activedirectory-v2/Makefile3
-rw-r--r--net/rubygem-omniauth-azure-activedirectory-v2/files/patch-omniauth-azure-activedirectory-v2.gemspec14
-rw-r--r--net/rubygem-omniauth-azure-oauth2/Makefile9
-rw-r--r--net/rubygem-omniauth-azure-oauth2/files/patch-lib-omniauth-strategies-azure_oauth2.rb4
-rw-r--r--net/rubygem-omniauth-azure-oauth2/files/patch-omniauth-azure-oauth2.gemspec18
-rw-r--r--net/rubygem-omniauth-facebook/Makefile3
-rw-r--r--net/rubygem-omniauth-facebook/files/patch-omniauth-facebook.gemspec17
-rw-r--r--net/rubygem-omniauth-salesforce/Makefile4
-rw-r--r--net/rubygem-omniauth-salesforce/files/patch-omniauth-salesforce.gemspec19
-rw-r--r--security/rubygem-omniauth-alicloud/Makefile4
-rw-r--r--security/rubygem-omniauth-alicloud/files/patch-gemspec11
-rw-r--r--security/rubygem-omniauth-dingtalk-oauth2/Makefile3
-rw-r--r--security/rubygem-omniauth-dingtalk-oauth2/files/patch-omniauth-dingtalk-oauth2.gemspec16
13 files changed, 108 insertions, 17 deletions
diff --git a/net/rubygem-omniauth-azure-activedirectory-v2/Makefile b/net/rubygem-omniauth-azure-activedirectory-v2/Makefile
index 7944db071672..3a63d5dd7795 100644
--- a/net/rubygem-omniauth-azure-activedirectory-v2/Makefile
+++ b/net/rubygem-omniauth-azure-activedirectory-v2/Makefile
@@ -1,5 +1,6 @@
PORTNAME= omniauth-azure-activedirectory-v2
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= net rubygems
MASTER_SITES= RG
@@ -8,7 +9,7 @@ COMMENT= OAuth 2 authentication with the Azure ActiveDirectory V2 API
LICENSE= MIT
-RUN_DEPENDS= rubygem-omniauth-oauth2>=1.7<2:net/rubygem-omniauth-oauth2
+RUN_DEPENDS= rubygem-omniauth-oauth2>=1.7<3:net/rubygem-omniauth-oauth2
USES= gem
USE_RUBY= yes
diff --git a/net/rubygem-omniauth-azure-activedirectory-v2/files/patch-omniauth-azure-activedirectory-v2.gemspec b/net/rubygem-omniauth-azure-activedirectory-v2/files/patch-omniauth-azure-activedirectory-v2.gemspec
new file mode 100644
index 000000000000..54d08ad8ee42
--- /dev/null
+++ b/net/rubygem-omniauth-azure-activedirectory-v2/files/patch-omniauth-azure-activedirectory-v2.gemspec
@@ -0,0 +1,14 @@
+--- omniauth-azure-activedirectory-v2.gemspec.orig 2022-08-09 15:06:21 UTC
++++ omniauth-azure-activedirectory-v2.gemspec
+@@ -24,9 +24,9 @@ Gem::Specification.new do |s|
+ end
+
+ if s.respond_to? :add_runtime_dependency then
+- s.add_runtime_dependency(%q<omniauth-oauth2>.freeze, ["~> 1.7"])
++ s.add_runtime_dependency(%q<omniauth-oauth2>.freeze, [">= 1.7"])
+ else
+- s.add_dependency(%q<omniauth-oauth2>.freeze, ["~> 1.7"])
++ s.add_dependency(%q<omniauth-oauth2>.freeze, [">= 1.7"])
+ end
+ end
+
diff --git a/net/rubygem-omniauth-azure-oauth2/Makefile b/net/rubygem-omniauth-azure-oauth2/Makefile
index 372dea5b3813..a6cf56c3781a 100644
--- a/net/rubygem-omniauth-azure-oauth2/Makefile
+++ b/net/rubygem-omniauth-azure-oauth2/Makefile
@@ -1,6 +1,6 @@
PORTNAME= omniauth-azure-oauth2
PORTVERSION= 0.0.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net rubygems
MASTER_SITES= RG
@@ -10,11 +10,12 @@ COMMENT= Azure OAuth2 Strategy for OmniAuth
LICENSE= MIT
RUN_DEPENDS= rubygem-jwt>=1.0<3:www/rubygem-jwt \
- rubygem-omniauth1>=1.0<2:security/rubygem-omniauth1 \
+ rubygem-omniauth>=1.0<3:security/rubygem-omniauth \
rubygem-omniauth-oauth2>=1.4<2:net/rubygem-omniauth-oauth2
-NO_ARCH= yes
-USE_RUBY= yes
USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/net/rubygem-omniauth-azure-oauth2/files/patch-lib-omniauth-strategies-azure_oauth2.rb b/net/rubygem-omniauth-azure-oauth2/files/patch-lib-omniauth-strategies-azure_oauth2.rb
index e613394fcfad..472b951e4694 100644
--- a/net/rubygem-omniauth-azure-oauth2/files/patch-lib-omniauth-strategies-azure_oauth2.rb
+++ b/net/rubygem-omniauth-azure-oauth2/files/patch-lib-omniauth-strategies-azure_oauth2.rb
@@ -1,6 +1,6 @@
---- lib/omniauth/strategies/azure_oauth2.rb.orig 2017-12-06 18:00:39 UTC
+--- lib/omniauth/strategies/azure_oauth2.rb.orig 2022-08-12 07:08:52 UTC
+++ lib/omniauth/strategies/azure_oauth2.rb
-@@ -61,7 +61,7 @@ module OmniAuth
+@@ -65,7 +65,7 @@ module OmniAuth
def raw_info
# it's all here in JWT http://msdn.microsoft.com/en-us/library/azure/dn195587.aspx
diff --git a/net/rubygem-omniauth-azure-oauth2/files/patch-omniauth-azure-oauth2.gemspec b/net/rubygem-omniauth-azure-oauth2/files/patch-omniauth-azure-oauth2.gemspec
new file mode 100644
index 000000000000..9878a20f3f2f
--- /dev/null
+++ b/net/rubygem-omniauth-azure-oauth2/files/patch-omniauth-azure-oauth2.gemspec
@@ -0,0 +1,18 @@
+--- omniauth-azure-oauth2.gemspec.orig 2022-08-12 07:15:37 UTC
++++ omniauth-azure-oauth2.gemspec
+@@ -22,13 +22,13 @@ Gem::Specification.new do |s|
+ end
+
+ if s.respond_to? :add_runtime_dependency then
+- s.add_runtime_dependency(%q<omniauth>.freeze, ["~> 1.0"])
++ s.add_runtime_dependency(%q<omniauth>.freeze, [">= 1.0"])
+ s.add_runtime_dependency(%q<jwt>.freeze, [">= 1.0", "< 3.0"])
+ s.add_runtime_dependency(%q<omniauth-oauth2>.freeze, ["~> 1.4"])
+ s.add_development_dependency(%q<rspec>.freeze, [">= 2.14.0"])
+ s.add_development_dependency(%q<rake>.freeze, [">= 0"])
+ else
+- s.add_dependency(%q<omniauth>.freeze, ["~> 1.0"])
++ s.add_dependency(%q<omniauth>.freeze, [">= 1.0"])
+ s.add_dependency(%q<jwt>.freeze, [">= 1.0", "< 3.0"])
+ s.add_dependency(%q<omniauth-oauth2>.freeze, ["~> 1.4"])
+ s.add_dependency(%q<rspec>.freeze, [">= 2.14.0"])
diff --git a/net/rubygem-omniauth-facebook/Makefile b/net/rubygem-omniauth-facebook/Makefile
index eaa5f540987c..842f26bc96f3 100644
--- a/net/rubygem-omniauth-facebook/Makefile
+++ b/net/rubygem-omniauth-facebook/Makefile
@@ -1,5 +1,6 @@
PORTNAME= omniauth-facebook
PORTVERSION= 9.0.0
+PORTREVISION= 1
CATEGORIES= net rubygems
MASTER_SITES= RG
@@ -8,7 +9,7 @@ COMMENT= Facebook OAuth2 Strategy for OmniAuth
LICENSE= MIT
-RUN_DEPENDS= rubygem-omniauth-oauth2>=1.2<2:net/rubygem-omniauth-oauth2
+RUN_DEPENDS= rubygem-omniauth-oauth2>=1.2:net/rubygem-omniauth-oauth2
USES= gem
USE_RUBY= yes
diff --git a/net/rubygem-omniauth-facebook/files/patch-omniauth-facebook.gemspec b/net/rubygem-omniauth-facebook/files/patch-omniauth-facebook.gemspec
new file mode 100644
index 000000000000..6538b77ad58e
--- /dev/null
+++ b/net/rubygem-omniauth-facebook/files/patch-omniauth-facebook.gemspec
@@ -0,0 +1,17 @@
+--- omniauth-facebook.gemspec.orig 2022-08-12 05:57:21 UTC
++++ omniauth-facebook.gemspec
+@@ -22,12 +22,12 @@ Gem::Specification.new do |s|
+ end
+
+ if s.respond_to? :add_runtime_dependency then
+- s.add_runtime_dependency(%q<omniauth-oauth2>.freeze, ["~> 1.2"])
++ s.add_runtime_dependency(%q<omniauth-oauth2>.freeze, [">= 1.2"])
+ s.add_development_dependency(%q<minitest>.freeze, [">= 0"])
+ s.add_development_dependency(%q<mocha>.freeze, [">= 0"])
+ s.add_development_dependency(%q<rake>.freeze, [">= 0"])
+ else
+- s.add_dependency(%q<omniauth-oauth2>.freeze, ["~> 1.2"])
++ s.add_dependency(%q<omniauth-oauth2>.freeze, [">= 1.2"])
+ s.add_dependency(%q<minitest>.freeze, [">= 0"])
+ s.add_dependency(%q<mocha>.freeze, [">= 0"])
+ s.add_dependency(%q<rake>.freeze, [">= 0"])
diff --git a/net/rubygem-omniauth-salesforce/Makefile b/net/rubygem-omniauth-salesforce/Makefile
index a7714e543574..672ea6b3732a 100644
--- a/net/rubygem-omniauth-salesforce/Makefile
+++ b/net/rubygem-omniauth-salesforce/Makefile
@@ -1,6 +1,6 @@
PORTNAME= omniauth-salesforce
PORTVERSION= 1.0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net rubygems
MASTER_SITES= RG
@@ -10,7 +10,7 @@ COMMENT= OmniAuth strategy for salesforce.com
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
-RUN_DEPENDS= rubygem-omniauth1>=1.0<2:security/rubygem-omniauth1 \
+RUN_DEPENDS= rubygem-omniauth>=1.0<3:security/rubygem-omniauth \
rubygem-omniauth-oauth2>=1.0<2:net/rubygem-omniauth-oauth2
USES= gem
diff --git a/net/rubygem-omniauth-salesforce/files/patch-omniauth-salesforce.gemspec b/net/rubygem-omniauth-salesforce/files/patch-omniauth-salesforce.gemspec
new file mode 100644
index 000000000000..e615a0cd8023
--- /dev/null
+++ b/net/rubygem-omniauth-salesforce/files/patch-omniauth-salesforce.gemspec
@@ -0,0 +1,19 @@
+--- omniauth-salesforce.gemspec.orig 2022-08-12 14:54:54 UTC
++++ omniauth-salesforce.gemspec
+@@ -23,14 +23,14 @@ Gem::Specification.new do |s|
+ end
+
+ if s.respond_to? :add_runtime_dependency then
+- s.add_runtime_dependency(%q<omniauth>.freeze, ["~> 1.0"])
++ s.add_runtime_dependency(%q<omniauth>.freeze, [">= 1.0"])
+ s.add_runtime_dependency(%q<omniauth-oauth2>.freeze, ["~> 1.0"])
+ s.add_development_dependency(%q<rspec>.freeze, ["~> 2.7"])
+ s.add_development_dependency(%q<rack-test>.freeze, [">= 0"])
+ s.add_development_dependency(%q<simplecov>.freeze, [">= 0"])
+ s.add_development_dependency(%q<webmock>.freeze, [">= 0"])
+ else
+- s.add_dependency(%q<omniauth>.freeze, ["~> 1.0"])
++ s.add_dependency(%q<omniauth>.freeze, [">= 1.0"])
+ s.add_dependency(%q<omniauth-oauth2>.freeze, ["~> 1.0"])
+ s.add_dependency(%q<rspec>.freeze, ["~> 2.7"])
+ s.add_dependency(%q<rack-test>.freeze, [">= 0"])
diff --git a/security/rubygem-omniauth-alicloud/Makefile b/security/rubygem-omniauth-alicloud/Makefile
index d0bd4e58dc7d..57b1a6c4a380 100644
--- a/security/rubygem-omniauth-alicloud/Makefile
+++ b/security/rubygem-omniauth-alicloud/Makefile
@@ -1,6 +1,6 @@
PORTNAME= omniauth-alicloud
PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security rubygems
MASTER_SITES= RG
@@ -10,7 +10,7 @@ COMMENT= Wrapper the AliCloud Oauth2 API
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= rubygem-omniauth-oauth2>=1.7.1<1.8.1:net/rubygem-omniauth-oauth2
+RUN_DEPENDS= rubygem-omniauth-oauth2>=1.7<2:net/rubygem-omniauth-oauth2
USES= gem
USE_RUBY= yes
diff --git a/security/rubygem-omniauth-alicloud/files/patch-gemspec b/security/rubygem-omniauth-alicloud/files/patch-gemspec
index 0544987827b0..19fce5bda77e 100644
--- a/security/rubygem-omniauth-alicloud/files/patch-gemspec
+++ b/security/rubygem-omniauth-alicloud/files/patch-gemspec
@@ -1,11 +1,14 @@
---- omniauth-alicloud.gemspec.orig 2022-06-24 14:19:41 UTC
+--- omniauth-alicloud.gemspec.orig 2022-07-26 11:42:41 UTC
+++ omniauth-alicloud.gemspec
-@@ -24,7 +24,7 @@ Gem::Specification.new do |s|
+@@ -24,9 +24,9 @@ Gem::Specification.new do |s|
end
if s.respond_to? :add_runtime_dependency then
- s.add_runtime_dependency(%q<omniauth-oauth2>.freeze, ["~> 1.7.1"])
-+ s.add_runtime_dependency(%q<omniauth-oauth2>.freeze, [">= 1.7.1", "< 1.8.1"])
++ s.add_runtime_dependency(%q<omniauth-oauth2>.freeze, [">= 1.7.1"])
else
- s.add_dependency(%q<omniauth-oauth2>.freeze, ["~> 1.7.1"])
+- s.add_dependency(%q<omniauth-oauth2>.freeze, ["~> 1.7.1"])
++ s.add_dependency(%q<omniauth-oauth2>.freeze, [">= 1.7.1"])
end
+ end
+
diff --git a/security/rubygem-omniauth-dingtalk-oauth2/Makefile b/security/rubygem-omniauth-dingtalk-oauth2/Makefile
index f8d7abab7f96..739252d33658 100644
--- a/security/rubygem-omniauth-dingtalk-oauth2/Makefile
+++ b/security/rubygem-omniauth-dingtalk-oauth2/Makefile
@@ -1,5 +1,6 @@
PORTNAME= omniauth-dingtalk-oauth2
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= security rubygems
MASTER_SITES= RG
@@ -9,7 +10,7 @@ COMMENT= Wrapper the DingTalk Oauth2 API
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= rubygem-omniauth-oauth2>=1.7<2:net/rubygem-omniauth-oauth2
+RUN_DEPENDS= rubygem-omniauth-oauth2>=1.7<3:net/rubygem-omniauth-oauth2
USES= gem
USE_RUBY= yes
diff --git a/security/rubygem-omniauth-dingtalk-oauth2/files/patch-omniauth-dingtalk-oauth2.gemspec b/security/rubygem-omniauth-dingtalk-oauth2/files/patch-omniauth-dingtalk-oauth2.gemspec
new file mode 100644
index 000000000000..689535f20271
--- /dev/null
+++ b/security/rubygem-omniauth-dingtalk-oauth2/files/patch-omniauth-dingtalk-oauth2.gemspec
@@ -0,0 +1,16 @@
+--- omniauth-dingtalk-oauth2.gemspec.orig 2022-08-09 16:03:30 UTC
++++ omniauth-dingtalk-oauth2.gemspec
+@@ -24,11 +24,11 @@ Gem::Specification.new do |s|
+ end
+
+ if s.respond_to? :add_runtime_dependency then
+- s.add_runtime_dependency(%q<omniauth-oauth2>.freeze, ["~> 1.7"])
++ s.add_runtime_dependency(%q<omniauth-oauth2>.freeze, [">= 1.7"])
+ s.add_development_dependency(%q<rake>.freeze, ["~> 12.0"])
+ s.add_development_dependency(%q<rspec>.freeze, ["~> 3.0"])
+ else
+- s.add_dependency(%q<omniauth-oauth2>.freeze, ["~> 1.7"])
++ s.add_dependency(%q<omniauth-oauth2>.freeze, [">= 1.7"])
+ s.add_dependency(%q<rake>.freeze, ["~> 12.0"])
+ s.add_dependency(%q<rspec>.freeze, ["~> 3.0"])
+ end