aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-10-07 08:36:28 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-10-07 14:44:04 +0000
commite2adbb0f90a6daef830678d343f537b98b518743 (patch)
tree45bf1f279af7238b72fa47ea098c28a9eaa59c98
parent56ecf72515b7a1de33270cb0dd4b11f40e1fd2d1 (diff)
downloadports-e2adbb0f90a6daef830678d343f537b98b518743.tar.gz
ports-e2adbb0f90a6daef830678d343f537b98b518743.zip
x11-wm/wayfire: update to 0.8.0
Changes: https://github.com/WayfireWM/wayfire/releases/tag/v0.8.0 Reported by: GitHub (watch releases)
-rw-r--r--x11-wm/wayfire-plugins-extra/Makefile2
-rw-r--r--x11-wm/wayfire/Makefile20
-rw-r--r--x11-wm/wayfire/distinfo10
-rw-r--r--x11-wm/wayfire/files/patch-private-libs6
-rw-r--r--x11-wm/wayfire/files/patch-wf-config-0.813
-rw-r--r--x11-wm/wayfire/pkg-plist66
6 files changed, 81 insertions, 36 deletions
diff --git a/x11-wm/wayfire-plugins-extra/Makefile b/x11-wm/wayfire-plugins-extra/Makefile
index 80d2eca2ed82..d238ede9c0f3 100644
--- a/x11-wm/wayfire-plugins-extra/Makefile
+++ b/x11-wm/wayfire-plugins-extra/Makefile
@@ -10,6 +10,8 @@ WWW= https://wayfire.org/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN= fails to build after https://github.com/WayfireWM/wayfire/commit/ea80ae3bcb01
+
BUILD_DEPENDS= wayland-scanner:graphics/wayland \
wayland-protocols>0:graphics/wayland-protocols \
wayfire>0:x11-wm/wayfire
diff --git a/x11-wm/wayfire/Makefile b/x11-wm/wayfire/Makefile
index 4dffb82d045b..639baf3ce9a6 100644
--- a/x11-wm/wayfire/Makefile
+++ b/x11-wm/wayfire/Makefile
@@ -1,7 +1,6 @@
PORTNAME= wayfire
DISTVERSIONPREFIX= v
-DISTVERSION= 0.7.5
-PORTREVISION= 1
+DISTVERSION= 0.8.0
CATEGORIES= x11-wm wayland
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@@ -15,18 +14,21 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
- wf-config>=0.7.0<0.9.0:devel/wf-config \
+ nlohmann-json>0:devel/nlohmann-json \
+ wf-config>=0.8.0<0.9.0:devel/wf-config \
${LOCALBASE}/include/xf86drmMode.h:graphics/libdrm \
wayland-protocols>=1.12:graphics/wayland-protocols \
glm>=0.9.8:math/glm \
wlroots>=0.16.0<0.17.0:x11-toolkits/wlroots
-LIB_DEPENDS= libinotify.so:devel/libinotify \
+LIB_DEPENDS= libevdev.so:devel/libevdev \
+ libinotify.so:devel/libinotify \
libwf-config.so:devel/wf-config \
libpng.so:graphics/png \
libwayland-server.so:graphics/wayland \
libwlroots.so:x11-toolkits/wlroots \
libinput.so:x11/libinput \
libxkbcommon.so:x11/libxkbcommon
+TEST_DEPENDS= doctest>0:devel/doctest
USES= compiler:c++17-lang gl gnome jpeg meson pkgconfig xorg
USE_GITHUB= yes
@@ -35,7 +37,8 @@ USE_GNOME= cairo pango
USE_XORG= pixman
GH_ACCOUNT= WayfireWM
GH_TUPLE= WayfireWM:wf-touch:8974eb0:wftouch/subprojects/wf-touch \
- WayfireWM:wf-utils:889fdaf:wfutils/subprojects/wf-utils
+ WayfireWM:wf-utils:15f8e16:wfutils/subprojects/wf-utils
+MESON_ARGS= -Dtests=disabled
OPTIONS_DEFINE= X11
OPTIONS_DEFAULT=X11
@@ -53,4 +56,11 @@ post-install:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.ini ${STAGEDIR}${EXAMPLESDIR}
+pre-test:
+ @if [ ! -e ${WRKDIR}/.meson_build_tests ]; then \
+ ${RM} ${CONFIGURE_COOKIE} ${BUILD_COOKIE}; \
+ ${MAKE} -C${.CURDIR} build MESON_ARGS="${MESON_ARGS} --reconfigure -Dtests=enabled"; \
+ ${TOUCH} ${WRKDIR}/.meson_build_tests; \
+ fi
+
.include <bsd.port.mk>
diff --git a/x11-wm/wayfire/distinfo b/x11-wm/wayfire/distinfo
index 54486fb52bc6..9fd72754660b 100644
--- a/x11-wm/wayfire/distinfo
+++ b/x11-wm/wayfire/distinfo
@@ -1,9 +1,9 @@
-TIMESTAMP = 1669907568
-SHA256 (WayfireWM-wayfire-v0.7.5_GH0.tar.gz) = ae9a44d3ddcdf97b2dbe2baeeaf880f24f95bfb18e11e1dd5ad7443c26c5e19e
-SIZE (WayfireWM-wayfire-v0.7.5_GH0.tar.gz) = 365235
+TIMESTAMP = 1696673372
+SHA256 (WayfireWM-wayfire-v0.8.0_GH0.tar.gz) = 3b67dd03a9370a0c0a2d9b98d77d9184d62b25ca13844cfdbb0cac788cb9d4b6
+SIZE (WayfireWM-wayfire-v0.8.0_GH0.tar.gz) = 433417
SHA256 (WayfireWM-wf-touch-8974eb0_GH0.tar.gz) = 3d66a67b35452741135420caf43ba349d35fc64643b8e223e6cdf74dbcef33aa
SIZE (WayfireWM-wf-touch-8974eb0_GH0.tar.gz) = 9881
-SHA256 (WayfireWM-wf-utils-889fdaf_GH0.tar.gz) = 8848592f4a04dec60c3e09a996f15d1f86e79f544eda4519f2b3d9dc91997db3
-SIZE (WayfireWM-wf-utils-889fdaf_GH0.tar.gz) = 48477
+SHA256 (WayfireWM-wf-utils-15f8e16_GH0.tar.gz) = 8f32164bb2c620252aa5ca74f03f25d808cce01809a9eddd4b13a4b83ecfa94d
+SIZE (WayfireWM-wf-utils-15f8e16_GH0.tar.gz) = 48505
SHA256 (dd479c06bf84.patch) = c58562defa005b8b3188d8a64003f0ee5444fef7449ed0a5f899d70b1901fb6d
SIZE (dd479c06bf84.patch) = 2086
diff --git a/x11-wm/wayfire/files/patch-private-libs b/x11-wm/wayfire/files/patch-private-libs
index e0ee938f31c0..fe4665abebbf 100644
--- a/x11-wm/wayfire/files/patch-private-libs
+++ b/x11-wm/wayfire/files/patch-private-libs
@@ -1,10 +1,10 @@
wf-touch and wf-utils are untagged and have no other consumers. Keep
it private to wayfire package for now.
---- meson.build.orig 2020-11-08 17:19:12 UTC
+--- meson.build.orig 2023-10-07 08:36:28 UTC
+++ meson.build
-@@ -41,8 +41,8 @@ if not use_system_wfconfig
- wfconfig = subproject('wf-config').get_variable('wfconfig')
+@@ -69,8 +69,8 @@ endif
+ endif
endif
-wfutils = subproject('wf-utils').get_variable('wfutils')
diff --git a/x11-wm/wayfire/files/patch-wf-config-0.8 b/x11-wm/wayfire/files/patch-wf-config-0.8
deleted file mode 100644
index 9ddb792c0f0d..000000000000
--- a/x11-wm/wayfire/files/patch-wf-config-0.8
+++ /dev/null
@@ -1,13 +0,0 @@
-Dependency wf-config found: NO found 0.8.0 but need: '<0.8.0' ; matched: '>=0.7.0'
-
---- meson.build.orig 2022-12-01 15:12:48 UTC
-+++ meson.build
-@@ -31,7 +31,7 @@ wlroots = dependency('wlroots', version: ['>=0.
- threads = dependency('threads')
- xkbcommon = dependency('xkbcommon')
- wlroots = dependency('wlroots', version: ['>=0.16.0', '<0.17.0'], required: get_option('use_system_wlroots'))
--wfconfig = dependency('wf-config', version: ['>=0.7.0', '<0.8.0'], required: get_option('use_system_wfconfig'))
-+wfconfig = dependency('wf-config', version: ['>=0.7.0', '<0.9.0'], required: get_option('use_system_wfconfig'))
-
- use_system_wlroots = not get_option('use_system_wlroots').disabled() and wlroots.found()
- if not use_system_wlroots
diff --git a/x11-wm/wayfire/pkg-plist b/x11-wm/wayfire/pkg-plist
index 5e14791a9f39..4de6ad695742 100644
--- a/x11-wm/wayfire/pkg-plist
+++ b/x11-wm/wayfire/pkg-plist
@@ -1,22 +1,21 @@
bin/wayfire
+include/wayfire/bindings-repository.hpp
include/wayfire/bindings.hpp
-include/wayfire/compositor-surface.hpp
include/wayfire/compositor-view.hpp
include/wayfire/config-backend.hpp
include/wayfire/config.h
include/wayfire/core.hpp
+include/wayfire/dassert.hpp
include/wayfire/debug.hpp
-include/wayfire/decorator.hpp
include/wayfire/geometry.hpp
-include/wayfire/gtk-shell.hpp
include/wayfire/idle.hpp
include/wayfire/img.hpp
include/wayfire/input-device.hpp
include/wayfire/matcher.hpp
-include/wayfire/nonstd/noncopyable.hpp
include/wayfire/nonstd/observer_ptr.h
include/wayfire/nonstd/reverse.hpp
include/wayfire/nonstd/safe-list.hpp
+include/wayfire/nonstd/tracking-allocator.hpp
include/wayfire/nonstd/wlroots-full.hpp
include/wayfire/nonstd/wlroots.hpp
include/wayfire/object.hpp
@@ -24,30 +23,59 @@ include/wayfire/opengl.hpp
include/wayfire/option-wrapper.hpp
include/wayfire/output-layout.hpp
include/wayfire/output.hpp
+include/wayfire/per-output-plugin.hpp
include/wayfire/plugin.hpp
+include/wayfire/plugins/blur/blur.hpp
include/wayfire/plugins/common/cairo-util.hpp
include/wayfire/plugins/common/geometry-animation.hpp
+include/wayfire/plugins/common/input-grab.hpp
+include/wayfire/plugins/common/key-repeat.hpp
include/wayfire/plugins/common/move-drag-interface.hpp
include/wayfire/plugins/common/preview-indication.hpp
include/wayfire/plugins/common/shared-core-data.hpp
include/wayfire/plugins/common/simple-texture.hpp
-include/wayfire/plugins/common/view-change-viewport-signal.hpp
-include/wayfire/plugins/common/workspace-stream-sharing.hpp
+include/wayfire/plugins/common/util.hpp
include/wayfire/plugins/common/workspace-wall.hpp
+include/wayfire/plugins/crossfade.hpp
+include/wayfire/plugins/grid.hpp
+include/wayfire/plugins/ipc/ipc-activator.hpp
+include/wayfire/plugins/ipc/ipc-helpers.hpp
+include/wayfire/plugins/ipc/ipc-method-repository.hpp
+include/wayfire/plugins/ipc/ipc.hpp
include/wayfire/plugins/scale-signal.hpp
-include/wayfire/plugins/scale-transform.hpp
include/wayfire/plugins/vswitch.hpp
+include/wayfire/plugins/wm-actions-signals.hpp
include/wayfire/plugins/wobbly/wobbly-signal.hpp
+include/wayfire/region.hpp
include/wayfire/render-manager.hpp
+include/wayfire/scene-input.hpp
+include/wayfire/scene-operations.hpp
+include/wayfire/scene-render.hpp
+include/wayfire/scene.hpp
+include/wayfire/seat.hpp
include/wayfire/signal-definitions.hpp
-include/wayfire/singleton-plugin.hpp
-include/wayfire/surface.hpp
+include/wayfire/signal-provider.hpp
+include/wayfire/toplevel-view.hpp
+include/wayfire/toplevel.hpp
+include/wayfire/txn/transaction-manager.hpp
+include/wayfire/txn/transaction-object.hpp
+include/wayfire/txn/transaction.hpp
+include/wayfire/unstable/translation-node.hpp
+include/wayfire/unstable/wlr-surface-node.hpp
+include/wayfire/unstable/wlr-view-events.hpp
+include/wayfire/unstable/wlr-view-keyboard-interaction.hpp
+include/wayfire/unstable/xdg-toplevel-base.hpp
+include/wayfire/unstable/xwl-toplevel-base.hpp
include/wayfire/util.hpp
include/wayfire/view-access-interface.hpp
+include/wayfire/view-helpers.hpp
include/wayfire/view-transform.hpp
include/wayfire/view.hpp
-include/wayfire/workspace-manager.hpp
+include/wayfire/window-manager.hpp
+include/wayfire/workarea.hpp
+include/wayfire/workspace-set.hpp
include/wayfire/workspace-stream.hpp
+lib/libwayfire-blur-base.so
lib/wayfire/libalpha.so
lib/wayfire/libanimate.so
lib/wayfire/libautostart.so
@@ -56,13 +84,18 @@ lib/wayfire/libcommand.so
lib/wayfire/libcube.so
lib/wayfire/libdecoration.so
lib/wayfire/libdefault-config-backend.so
+lib/wayfire/libdemo-ipc.so
lib/wayfire/libexpo.so
lib/wayfire/libextra-gestures.so
lib/wayfire/libfast-switcher.so
lib/wayfire/libfisheye.so
+lib/wayfire/libforeign-toplevel.so
lib/wayfire/libgrid.so
+lib/wayfire/libgtk-shell.so
lib/wayfire/libidle.so
lib/wayfire/libinvert.so
+lib/wayfire/libipc-rules.so
+lib/wayfire/libipc.so
lib/wayfire/libmove.so
lib/wayfire/liboswitch.so
lib/wayfire/libplace.so
@@ -71,15 +104,21 @@ lib/wayfire/libresize.so
lib/wayfire/libscale-title-filter.so
lib/wayfire/libscale.so
lib/wayfire/libsimple-tile.so
+lib/wayfire/libstipc.so
lib/wayfire/libswitcher.so
lib/wayfire/libvswipe.so
lib/wayfire/libvswitch.so
+lib/wayfire/libwayfire-shell.so
lib/wayfire/libwindow-rules.so
lib/wayfire/libwm-actions.so
lib/wayfire/libwobbly.so
lib/wayfire/libwrot.so
+lib/wayfire/libwsets.so
+lib/wayfire/libxdg-activation.so
lib/wayfire/libzoom.so
libdata/pkgconfig/wayfire.pc
+man/man1/wayfire.1.gz
+man/wayfire.1.gz
%%EXAMPLESDIR%%/wayfire.ini
%%DATADIR%%/metadata/alpha.xml
%%DATADIR%%/metadata/animate.xml
@@ -93,11 +132,15 @@ libdata/pkgconfig/wayfire.pc
%%DATADIR%%/metadata/extra-gestures.xml
%%DATADIR%%/metadata/fast-switcher.xml
%%DATADIR%%/metadata/fisheye.xml
+%%DATADIR%%/metadata/foreign-toplevel.xml
%%DATADIR%%/metadata/grid.xml
+%%DATADIR%%/metadata/gtk-shell.xml
%%DATADIR%%/metadata/idle.xml
%%DATADIR%%/metadata/input-device.xml
%%DATADIR%%/metadata/input.xml
%%DATADIR%%/metadata/invert.xml
+%%DATADIR%%/metadata/ipc-rules.xml
+%%DATADIR%%/metadata/ipc.xml
%%DATADIR%%/metadata/move.xml
%%DATADIR%%/metadata/oswitch.xml
%%DATADIR%%/metadata/output.xml
@@ -110,11 +153,14 @@ libdata/pkgconfig/wayfire.pc
%%DATADIR%%/metadata/switcher.xml
%%DATADIR%%/metadata/vswipe.xml
%%DATADIR%%/metadata/vswitch.xml
+%%DATADIR%%/metadata/wayfire-shell.xml
%%DATADIR%%/metadata/window-rules.xml
%%DATADIR%%/metadata/wm-actions.xml
%%DATADIR%%/metadata/wobbly.xml
%%DATADIR%%/metadata/workarounds.xml
%%DATADIR%%/metadata/wrot.xml
+%%DATADIR%%/metadata/wsets.xml
+%%DATADIR%%/metadata/xdg-activation.xml
%%DATADIR%%/metadata/zoom.xml
%%DATADIR%%/protocols/unstable/wayfire-shell-unstable-v2.xml
share/wayland-sessions/wayfire.desktop