aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2023-09-16 12:15:35 +0000
committerBernard Spil <brnrd@FreeBSD.org>2023-09-16 12:15:35 +0000
commite332bedb5ec7594a6cc4d243ec120113591e3e86 (patch)
treeecb727e1bfa9a9ad7b93a902fe2b9cb361d6363f
parent9fb2c8ee70488e1fe46a5844f35485cda955db22 (diff)
security/openssl*: Chase addition of 3.2
* Update CONFLICTS * Update comment in Mk/Uses/ssl.mk
-rw-r--r--Mk/Uses/ssl.mk3
-rw-r--r--security/boringssl/Makefile2
-rw-r--r--security/libressl-devel/Makefile2
-rw-r--r--security/libressl/Makefile3
-rw-r--r--security/openssl-quictls/Makefile2
-rw-r--r--security/openssl30/Makefile2
-rw-r--r--security/openssl31/Makefile2
7 files changed, 9 insertions, 7 deletions
diff --git a/Mk/Uses/ssl.mk b/Mk/Uses/ssl.mk
index 8d92229da70d..6b7c09857f34 100644
--- a/Mk/Uses/ssl.mk
+++ b/Mk/Uses/ssl.mk
@@ -8,7 +8,8 @@
#
# DEFAULT_VERSIONS+= ssl=<openssl variant>
#
-# Variants being base, openssl, openssl30, openssl31, libressl, and libressl-devel.
+# Variants being base, openssl, openssl30, openssl31, openssl32,
+# openssl-quictls, libressl, and libressl-devel.
#
# The Makefile sets these variables:
# OPENSSLBASE - "/usr" or ${LOCALBASE}
diff --git a/security/boringssl/Makefile b/security/boringssl/Makefile
index acc91c155929..1169b46e12fd 100644
--- a/security/boringssl/Makefile
+++ b/security/boringssl/Makefile
@@ -22,7 +22,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake:insource cpe go:no_targets localbase perl5
CONFLICTS_INSTALL= libressl libressl-devel \
- openssl openssl3[01] openssl-quictls
+ openssl openssl3[012] openssl-quictls
CPE_VENDOR= google
diff --git a/security/libressl-devel/Makefile b/security/libressl-devel/Makefile
index e06be0da8dbb..8c4574f9c5be 100644
--- a/security/libressl-devel/Makefile
+++ b/security/libressl-devel/Makefile
@@ -27,7 +27,7 @@ NC_DESC= Install TLS-enabled netcat
CONFLICTS_INSTALL= libressl \
libretls
-default_CONFLICTS_INSTALL= openssl openssl3[01] openssl-quictls
+default_CONFLICTS_INSTALL= openssl openssl3[012] openssl-quictls
.if ${FLAVOR:U} == default
OPTIONS_EXCLUDE= LIBTLS
diff --git a/security/libressl/Makefile b/security/libressl/Makefile
index 3d39bee45714..2807e6ff01ab 100644
--- a/security/libressl/Makefile
+++ b/security/libressl/Makefile
@@ -27,7 +27,8 @@ NC_DESC= Install TLS-enabled netcat
CONFLICTS_INSTALL= libressl-devel
libtls_CONFLICTS_INSTALL= libretls
default_CONFLICTS_INSTALL= openssl \
- openssl3[01]
+ openssl3[012] \
+ openssl-quictls
.if ${FLAVOR:U} == default
OPTIONS_EXCLUDE= LIBTLS
diff --git a/security/openssl-quictls/Makefile b/security/openssl-quictls/Makefile
index 562138535939..9e2e1f996919 100644
--- a/security/openssl-quictls/Makefile
+++ b/security/openssl-quictls/Makefile
@@ -10,7 +10,7 @@ WWW= https://www.github.com/quictls/openssl
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-CONFLICTS_INSTALL= boringssl libressl libressl-devel openssl openssl3[01]
+CONFLICTS_INSTALL= boringssl libressl libressl-devel openssl openssl3[012]
BROKEN_i386= ld: error: undefined symbol: __atomic_is_lock_free
diff --git a/security/openssl30/Makefile b/security/openssl30/Makefile
index 263d6e6ed0b7..8ce44028502e 100644
--- a/security/openssl30/Makefile
+++ b/security/openssl30/Makefile
@@ -12,7 +12,7 @@ WWW= https://www.openssl.org/
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-CONFLICTS_INSTALL= boringssl libressl libressl-devel openssl openssl31 openssl-quictls
+CONFLICTS_INSTALL= boringssl libressl libressl-devel openssl openssl3[12] openssl-quictls
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= config
diff --git a/security/openssl31/Makefile b/security/openssl31/Makefile
index e0baa28cfd53..e410d0a45df4 100644
--- a/security/openssl31/Makefile
+++ b/security/openssl31/Makefile
@@ -12,7 +12,7 @@ WWW= https://www.openssl.org/
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-CONFLICTS_INSTALL= boringssl libressl libressl-devel openssl openssl30 openssl-quictls
+CONFLICTS_INSTALL= boringssl libressl libressl-devel openssl openssl3[02] openssl-quictls
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= config