aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2024-04-02 19:03:30 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2024-04-28 16:15:55 +0000
commite382a74b41f678c81d5ab1dcfc9031778500b9a5 (patch)
tree3098a326c1a488cc735836c37ecfa6e15ac01b4f
parent6ec3a09fb0b0ebbc0cb3cc1eb098901068fb98e4 (diff)
downloadports-e382a74b41f678c81d5ab1dcfc9031778500b9a5.tar.gz
ports-e382a74b41f678c81d5ab1dcfc9031778500b9a5.zip
devel/libvirt: update to 10.2.0
-rw-r--r--devel/libvirt/Makefile4
-rw-r--r--devel/libvirt/distinfo8
-rw-r--r--devel/libvirt/files/patch-src_util_virprocess.c11
3 files changed, 5 insertions, 18 deletions
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index 8812d24cddd8..eb1b61d3ffdb 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -1,5 +1,5 @@
PORTNAME= libvirt
-PORTVERSION= 10.1.0
+PORTVERSION= 10.2.0
CATEGORIES= devel
MASTER_SITES= http://libvirt.org/sources/ \
ftp://libvirt.org/libvirt/
@@ -142,7 +142,7 @@ USE_PERL5= build
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
TEST_TARGET= check
-SHLIB_VER= 0.10001.0
+SHLIB_VER= 0.10002.0
PLIST_SUB+= SHLIB_VER=${SHLIB_VER}
PORTDOCS= *
#SHEBANG_FILES= src/keycodemapdb/tools/keymap-gen
diff --git a/devel/libvirt/distinfo b/devel/libvirt/distinfo
index f35562d050f4..76ba28e5d6ad 100644
--- a/devel/libvirt/distinfo
+++ b/devel/libvirt/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1709320848
-SHA256 (libvirt-10.1.0.tar.xz) = 36d9077e2b0ef6b0c6df3b42e42a67411b6ce3b1564b427b55e65019dde60eed
-SIZE (libvirt-10.1.0.tar.xz) = 9444244
-SHA256 (dcfe548cb0.patch) = 9211f318e0508a7b390c656c036240b168591d3aebf5d485a6ac10b18301797a
-SIZE (dcfe548cb0.patch) = 4967
+TIMESTAMP = 1712083691
+SHA256 (libvirt-10.2.0.tar.xz) = 215772bc5dc4a672e67ffa9de3774f05ed4b7ed282dbe296ec5c9fec01dd7ae3
+SIZE (libvirt-10.2.0.tar.xz) = 9466588
diff --git a/devel/libvirt/files/patch-src_util_virprocess.c b/devel/libvirt/files/patch-src_util_virprocess.c
deleted file mode 100644
index a3668f357617..000000000000
--- a/devel/libvirt/files/patch-src_util_virprocess.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/util/virprocess.c.orig 2021-12-14 12:38:57 UTC
-+++ src/util/virprocess.c
-@@ -480,7 +480,7 @@ int virProcessKillPainfully(pid_t pid, bool force)
- return virProcessKillPainfullyDelay(pid, force, 0, false);
- }
-
--#if WITH_DECL_CPU_SET_T
-+#if WITH_DECL_CPU_SET_T && defined(__linux__)
-
- int virProcessSetAffinity(pid_t pid, virBitmap *map, bool quiet)
- {