aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-12-24 23:56:04 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-12-25 01:22:57 +0000
commite39b70298c5452ca5eeeea45f444fde55abc0b85 (patch)
tree0a7d0f264871f5a955a433cbde8627d7a222f0e3
parenteed1be43623c0096619c0faa5fd5c30f31ff23a5 (diff)
science/py-xbout: New port: Collect data from BOUT++ runs in python using xarray
-rw-r--r--science/Makefile1
-rw-r--r--science/py-xbout/Makefile33
-rw-r--r--science/py-xbout/distinfo3
-rw-r--r--science/py-xbout/pkg-descr3
4 files changed, 40 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index a922e9909dae..f4e3659e3342 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -428,6 +428,7 @@
SUBDIR += py-trainstation
SUBDIR += py-tweedledum
SUBDIR += py-veusz
+ SUBDIR += py-xbout
SUBDIR += pybrain
SUBDIR += pynn
SUBDIR += q
diff --git a/science/py-xbout/Makefile b/science/py-xbout/Makefile
new file mode 100644
index 000000000000..155e08adbb72
--- /dev/null
+++ b/science/py-xbout/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= xbout
+DISTVERSION= 0.3.3
+CATEGORIES= science education
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Collect data from BOUT++ runs in python using xarray
+WWW= https://github.com/boutproject/xBOUT
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}animatplot>=0.4.2:math/py-animatplot@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}boutdata>0:science/py-boutdata@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dask>=2.10.0:devel/py-dask@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gelidum>=0.5.3:devel/py-gelidum@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=3.1.1:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}natsort>=5.5.0:devel/py-natsort@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}netCDF4>=1.4.0:science/py-netCDF4@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>=6.1.0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xarray>0:devel/py-xarray@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm_git_archive>0:devel/py-setuptools_scm_git_archive@${PY_FLAVOR} \
+ ${PY_DEPENDS}
+RUN_DEPENDS= ${PY_DEPENDS}
+
+USES= python:3.8+
+USE_PYTHON= autoplist distutils pytest
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-xbout/distinfo b/science/py-xbout/distinfo
new file mode 100644
index 000000000000..803e22ec2918
--- /dev/null
+++ b/science/py-xbout/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1671859649
+SHA256 (xbout-0.3.3.tar.gz) = e83473d157c251e9a726ff6371b50318f7043b7ce059581f0081f668aa27a506
+SIZE (xbout-0.3.3.tar.gz) = 4790987
diff --git a/science/py-xbout/pkg-descr b/science/py-xbout/pkg-descr
new file mode 100644
index 000000000000..b97a73e7eb3a
--- /dev/null
+++ b/science/py-xbout/pkg-descr
@@ -0,0 +1,3 @@
+xBOUT provides an interface for collecting the output data from a BOUT++
+simulation into an xarray dataset in an efficient and scalable way, as well
+as accessor methods for common BOUT++ analysis and plotting tasks.