aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-23 09:11:44 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-23 18:33:53 +0000
commite45b3ccfef5f6747c156036bfebbd0573f444da2 (patch)
treed676bb45a055e7612d5731bcaa3d2358fc70174c
parentbe927e1c87723f345c05e7624f72ade636da47ba (diff)
math/mfem: Improve MPI options
-rw-r--r--math/mfem/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/math/mfem/Makefile b/math/mfem/Makefile
index e7fb1df095c3..8e298e41a2fd 100644
--- a/math/mfem/Makefile
+++ b/math/mfem/Makefile
@@ -20,22 +20,19 @@ CMAKE_TESTING_ON= MFEM_ENABLE_TESTING # tests are broken, see https://github.com
OPTIONS_SINGLE= MPI
OPTIONS_SINGLE_MPI= NOMPI MPICH OPENMPI
OPTIONS_DEFAULT= MPICH # should be the same choice as in science/hypre
+OPTIONS_SUB= yes
NOMPI_DESC= Build without parallel processing support
-NOMPI_CMAKE_ON= -DMFEM_USE_MPI=OFF
+OPENMPI_CMAKE_ON= -DTPL_ENABLE_MPI=OFF
-MPICH_CMAKE_ON= -DMFEM_USE_MPI=ON \
- -DMPI_HOME=${LOCALBASE}
-MPICH_BUILD_DEPENDS= mpich>0:net/mpich
+MPICH_USES= mpi:mpich
+MPICH_CMAKE_ON= -DTPL_ENABLE_MPI=ON
MPICH_LIB_DEPENDS= libHYPRE.so:science/hypre \
libmetis.so:math/metis
-MPICH_RUN_DEPENDS= mpich>0:net/mpich
-OPENMPI_CMAKE_ON= -DMFEM_USE_MPI=ON \
- -DMPI_HOME=${LOCALBASE}/mpi/openmpi
-OPENMPI_BUILD_DEPENDS= openmpi>0:net/openmpi
+OPENMPI_USES= mpi:openmpi
+OPENMPI_CMAKE_ON= -DTPL_ENABLE_MPI=ON
OPENMPI_LIB_DEPENDS= libHYPRE.so:science/hypre \
libmetis.so:math/metis
-OPENMPI_RUN_DEPENDS= openmpi>0:net/openmpi
.include <bsd.port.mk>