aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Pizzamiglio <pizzamig@FreeBSD.org>2020-03-13 09:12:41 +0000
committerLuca Pizzamiglio <pizzamig@FreeBSD.org>2020-03-13 09:12:41 +0000
commite47344f5d6f6f62a9da0f0135d5863fa6ff4e481 (patch)
tree1ff5ed21765bd31f3e986ceb8565bcb1c93093f4
parent2760f3c82c8ccca7fa1756a9b248e773f0a68141 (diff)
downloadports-e47344f5d6f6f62a9da0f0135d5863fa6ff4e481.tar.gz
ports-e47344f5d6f6f62a9da0f0135d5863fa6ff4e481.zip
devel/gdb: fix build with BUILE option enabled
PR: 244760 Reported by: Ting-Wei Lan <lantw44@gmail.com>
Notes
Notes: svn path=/head/; revision=528338
-rw-r--r--devel/gdb/Makefile1
-rw-r--r--devel/gdb/files/extrapatch-guile227
2 files changed, 3 insertions, 5 deletions
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index 3f43e53aee84..7cd5d966e3de 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -70,7 +70,6 @@ OPTIONS_SUB= yes
BUNDLED_READLINE_CONFIGURE_OFF= --with-system-readline
DEBUG_CFLAGS= -g
GUILE_CONFIGURE_WITH= guile
-GUILE_USES= pkgconfig
GUILE_LIB_DEPENDS= libguile-2.2.so:lang/guile2
GUILE_EXTRA_PATCHES= ${FILESDIR}/extrapatch-guile22
NLS_USES= gettext-runtime
diff --git a/devel/gdb/files/extrapatch-guile22 b/devel/gdb/files/extrapatch-guile22
index f488e20cf5e0..047c87de9044 100644
--- a/devel/gdb/files/extrapatch-guile22
+++ b/devel/gdb/files/extrapatch-guile22
@@ -175,7 +175,7 @@
/* Support for connecting Guile's stdio ports to GDB's stdio ports. */
-@@ -218,6 +262,73 @@ ioscm_input_waiting (SCM port)
+@@ -218,6 +262,72 @@ ioscm_input_waiting (SCM port)
}
}
@@ -228,18 +228,17 @@
+ scm_syserror("ioscm_write");
+ }
+
-+ TRY
++ try
+ {
+ if (scm_is_eq (port, error_port_scm))
+ fputsn_filtered (ptr, count, gdb_stderr);
+ else
+ fputsn_filtered (ptr, count, gdb_stdout);
+ }
-+ CATCH (except, RETURN_MASK_ALL)
++ catch (gdbscm_gdb_exception &except)
+ {
+ GDBSCM_HANDLE_GDB_EXCEPTION (except);
+ }
-+ END_CATCH
+
+ return count;
+}