aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2022-09-28 15:48:39 +0000
committerCy Schubert <cy@FreeBSD.org>2022-09-28 15:54:31 +0000
commite5274f9c60037a3649382753b2370e6fea2e2b94 (patch)
tree558bb8dd47ee6d4449ea968d5bc42478c3775161
parentdacca3015a05b3eefa5cd746acaf1836d19d2ebe (diff)
downloadports-e5274f9c60037a3649382753b2370e6fea2e2b94.tar.gz
ports-e5274f9c60037a3649382753b2370e6fea2e2b94.zip
security/nmap: Update to 7.93
PR: 266623 Reported by: takefu@airport.fm
-rw-r--r--security/nmap/Makefile3
-rw-r--r--security/nmap/distinfo6
-rw-r--r--security/nmap/files/patch-libpcap_Makefile.in8
-rw-r--r--security/nmap/files/patch-ncat_ncat__connect.c23
-rw-r--r--security/nmap/files/patch-ncat_ncat__ssl.h11
-rw-r--r--security/nmap/pkg-plist3
6 files changed, 23 insertions, 31 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index bd72bedf10a9..3250219d2442 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -1,6 +1,5 @@
PORTNAME= nmap
-DISTVERSION= 7.91
-PORTREVISION= 2
+DISTVERSION= 7.93
CATEGORIES= security
MASTER_SITES= https://nmap.org/dist/ \
LOCAL/ohauer
diff --git a/security/nmap/distinfo b/security/nmap/distinfo
index b024db74fe94..604360bac13e 100644
--- a/security/nmap/distinfo
+++ b/security/nmap/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1602357099
-SHA256 (nmap-7.91.tar.bz2) = 18cc4b5070511c51eb243cdd2b0b30ff9b2c4dc4544c6312f75ce3a67a593300
-SIZE (nmap-7.91.tar.bz2) = 10503500
+TIMESTAMP = 1664379242
+SHA256 (nmap-7.93.tar.bz2) = 55bcfe4793e25acc96ba4274d8c4228db550b8e8efd72004b38ec55a2dd16651
+SIZE (nmap-7.93.tar.bz2) = 10823114
diff --git a/security/nmap/files/patch-libpcap_Makefile.in b/security/nmap/files/patch-libpcap_Makefile.in
index a71ba748570a..91bae33073bf 100644
--- a/security/nmap/files/patch-libpcap_Makefile.in
+++ b/security/nmap/files/patch-libpcap_Makefile.in
@@ -1,11 +1,13 @@
---- libpcap/Makefile.in.orig 2020-10-05 09:03:33 UTC
-+++ libpcap/Makefile.in
-@@ -69,7 +69,7 @@ INSTALL_RPCAPD=@INSTALL_RPCAPD@
+--- libpcap/Makefile.in.orig 2022-08-31 11:39:55.000000000 -0700
++++ libpcap/Makefile.in 2022-09-28 08:38:02.131119000 -0700
+@@ -70,8 +70,8 @@
EXTRA_NETWORK_LIBS=@EXTRA_NETWORK_LIBS@
# Standard CFLAGS for building members of a shared library
-FULL_CFLAGS = $(CCOPT) @V_LIB_CCOPT_FAT@ $(SHLIB_CCOPT) $(INCLS) $(DEFS) $(CFLAGS)
+-CXXFLAGS = $(CCOPT) @V_LIB_CCOPT_FAT@ $(SHLIB_CCOPT) $(INCLS) $(DEFS) $(CFLAGS)
+FULL_CFLAGS = -I. $(CCOPT) @V_LIB_CCOPT_FAT@ $(SHLIB_CCOPT) $(INCLS) $(DEFS) $(CFLAGS)
++CXXFLAGS = -I. $(CCOPT) @V_LIB_CCOPT_FAT@ $(SHLIB_CCOPT) $(INCLS) $(DEFS) $(CFLAGS)
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
diff --git a/security/nmap/files/patch-ncat_ncat__connect.c b/security/nmap/files/patch-ncat_ncat__connect.c
deleted file mode 100644
index 8d6260912e07..000000000000
--- a/security/nmap/files/patch-ncat_ncat__connect.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- ncat/ncat_connect.c
-+++ ncat/ncat_connect.c
-@@ -1064,12 +1064,17 @@ int ncat_connect(void)
- bye("Failed to set hostname on iod.");
- if (o.ssl)
- {
-+ /* connect_handler creates stdin_nsi and calls post_connect */
- nsock_reconnect_ssl(mypool, cs.sock_nsi, connect_handler, o.conntimeout, NULL, NULL);
- }
-+ else
-+ {
-+ /* Create IOD for nsp->stdin */
-+ if ((cs.stdin_nsi = nsock_iod_new2(mypool, 0, NULL)) == NULL)
-+ bye("Failed to create stdin nsiod.");
-
-- /* Create IOD for nsp->stdin */
-- if ((cs.stdin_nsi = nsock_iod_new2(mypool, 0, NULL)) == NULL)
-- bye("Failed to create stdin nsiod.");
-+ post_connect(mypool, cs.sock_nsi);
-+ }
- }
-
- /* connect */
diff --git a/security/nmap/files/patch-ncat_ncat__ssl.h b/security/nmap/files/patch-ncat_ncat__ssl.h
new file mode 100644
index 000000000000..173e55061612
--- /dev/null
+++ b/security/nmap/files/patch-ncat_ncat__ssl.h
@@ -0,0 +1,11 @@
+--- ncat/ncat_ssl.h.orig 2022-08-25 07:51:59.000000000 -0700
++++ ncat/ncat_ssl.h 2022-09-28 08:44:14.564723000 -0700
+@@ -67,6 +67,8 @@
+ #include <openssl/ssl.h>
+ #include <openssl/err.h>
+
++#define OPENSSL_API_COMPAT OPENSSL_VERSION_NUMBER
++
+ /* OPENSSL_API_LEVEL per OpenSSL 3.0: decimal MMmmpp */
+ #ifndef OPENSSL_API_LEVEL
+ # if OPENSSL_API_COMPAT < 0x900000L
diff --git a/security/nmap/pkg-plist b/security/nmap/pkg-plist
index ad84a3a3e117..df89afcb742c 100644
--- a/security/nmap/pkg-plist
+++ b/security/nmap/pkg-plist
@@ -600,6 +600,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/nat-pmp-info.nse
%%DATADIR%%/scripts/nat-pmp-mapport.nse
%%DATADIR%%/scripts/nbd-info.nse
+%%DATADIR%%/scripts/nbns-interfaces.nse
%%DATADIR%%/scripts/nbstat.nse
%%DATADIR%%/scripts/ncp-enum-users.nse
%%DATADIR%%/scripts/ncp-serverinfo.nse
@@ -625,6 +626,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/omp2-brute.nse
%%DATADIR%%/scripts/omp2-enum-targets.nse
%%DATADIR%%/scripts/omron-info.nse
+%%DATADIR%%/scripts/openflow-info.nse
%%DATADIR%%/scripts/openlookup-info.nse
%%DATADIR%%/scripts/openvas-otp-brute.nse
%%DATADIR%%/scripts/openwebnet-discovery.nse
@@ -643,6 +645,7 @@ man/zh/man1/nmap.1.gz
%%DATADIR%%/scripts/pop3-brute.nse
%%DATADIR%%/scripts/pop3-capabilities.nse
%%DATADIR%%/scripts/pop3-ntlm-info.nse
+%%DATADIR%%/scripts/port-states.nse
%%DATADIR%%/scripts/pptp-version.nse
%%DATADIR%%/scripts/puppet-naivesigning.nse
%%DATADIR%%/scripts/qconn-exec.nse