aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonald Klop <ronald@FreeBSD.org>2023-05-26 11:49:25 +0000
committerRonald Klop <ronald@FreeBSD.org>2023-05-27 06:45:34 +0000
commite5716c2af8f92559f17516c74f975708ff469fb7 (patch)
tree037bcd5986b25a64d9109c5fd455a25904123404
parentca5fd0c991d382e3bcce32dec80dc4c5e6547931 (diff)
databases/immudb: new port
Open source immutable database * High performance and easy to integrate * Supports both Key/Value & SQL * Cryptographical client-verification, tamper-resistant, and auditable * Versioned and temporal queries subject to cryptographic verification - portlint ok - portclippy ok - portfmt clean - poudriere stage-qa ok Requested by: Vladimir MiĊĦev @vmisev (via Twitter) Reviewed by: rene Differential Revision: https://reviews.freebsd.org/D40280
-rw-r--r--databases/Makefile1
-rw-r--r--databases/immudb/Makefile29
-rw-r--r--databases/immudb/distinfo5
-rw-r--r--databases/immudb/pkg-descr6
-rw-r--r--databases/immudb/pkg-plist4
5 files changed, 45 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 3582d6feb5c3..232259469f98 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -102,6 +102,7 @@
SUBDIR += hashtypes
SUBDIR += hiredis
SUBDIR += hsqldb
+ SUBDIR += immudb
SUBDIR += influxdb
SUBDIR += influxdb2-cli
SUBDIR += innotop
diff --git a/databases/immudb/Makefile b/databases/immudb/Makefile
new file mode 100644
index 000000000000..3f06e87a5fe6
--- /dev/null
+++ b/databases/immudb/Makefile
@@ -0,0 +1,29 @@
+PORTNAME= immudb
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.4.1
+CATEGORIES= databases net
+PKGNAMESUFFIX= ${DISTVERSION:R:S/.//}
+
+MAINTAINER= ronald@FreeBSD.org
+COMMENT= Database with built-in cryptographic proof and verification
+WWW= https://immudb.io/
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= bash:shells/bash
+
+USES= gmake go:modules,no_targets
+GO_MODULE= github.com/codenotary/immudb
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|g' ${WRKSRC}/Makefile
+
+do-install:
+.for f in immuadmin immuclient immudb immutest
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}/${PREFIX}/bin/${f}
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/databases/immudb/distinfo b/databases/immudb/distinfo
new file mode 100644
index 000000000000..b7e1d0a907e3
--- /dev/null
+++ b/databases/immudb/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1685050165
+SHA256 (go/databases_immudb/immudb-v1.4.1/v1.4.1.mod) = cba588a430551addda983e4864a96d48d0b9205f9da1b92c3641af9c86b39b4e
+SIZE (go/databases_immudb/immudb-v1.4.1/v1.4.1.mod) = 2388
+SHA256 (go/databases_immudb/immudb-v1.4.1/v1.4.1.zip) = d8aca5ed02f6080c845c9d60e679fa4432d300084cd3e6108a9be82b10167378
+SIZE (go/databases_immudb/immudb-v1.4.1/v1.4.1.zip) = 3019202
diff --git a/databases/immudb/pkg-descr b/databases/immudb/pkg-descr
new file mode 100644
index 000000000000..5ac4ca4ecf84
--- /dev/null
+++ b/databases/immudb/pkg-descr
@@ -0,0 +1,6 @@
+Open source immutable database
+
+* High performance and easy to integrate
+* Supports both Key/Value & SQL
+* Cryptographical client-verification, tamper-resistant, and auditable
+* Versioned and temporal queries subject to cryptographic verification
diff --git a/databases/immudb/pkg-plist b/databases/immudb/pkg-plist
new file mode 100644
index 000000000000..2d0b292a016c
--- /dev/null
+++ b/databases/immudb/pkg-plist
@@ -0,0 +1,4 @@
+bin/immuadmin
+bin/immuclient
+bin/immudb
+bin/immutest