aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-07 20:17:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-08 09:40:49 +0000
commite57e88a3f9ca764ff177aeb4255b18732d40ea99 (patch)
tree85bb277addf04c116fc7b89daa0ab7b8a35592ca
parent0e7b85563d5efb4d6ac8836e79b59d9ff2b9bcee (diff)
downloadports-e57e88a3f9ca764ff177aeb4255b18732d40ea99.tar.gz
ports-e57e88a3f9ca764ff177aeb4255b18732d40ea99.zip
comms/suwidgets: New port: Sigutils-related widgets
-rw-r--r--comms/Makefile1
-rw-r--r--comms/suwidgets/Makefile28
-rw-r--r--comms/suwidgets/distinfo3
-rw-r--r--comms/suwidgets/pkg-descr1
-rw-r--r--comms/suwidgets/pkg-plist28
5 files changed, 61 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index e937cb380187..1cd8bfc93b03 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -185,6 +185,7 @@
SUBDIR += sredird
SUBDIR += sunxi-tools
SUBDIR += suscan
+ SUBDIR += suwidgets
SUBDIR += svxlink
SUBDIR += syncterm
SUBDIR += tcpser
diff --git a/comms/suwidgets/Makefile b/comms/suwidgets/Makefile
new file mode 100644
index 000000000000..8fc8fb61b41e
--- /dev/null
+++ b/comms/suwidgets/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= suwidgets
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.0-147
+DISTVERSIONSUFFIX= -g826b3ee
+CATEGORIES= comms
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Sigutils-related widgets
+WWW= https://github.com/BatchDrake/SuWidgets
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libfftw3.so:math/fftw3 \
+ libsigutils.so:comms/sigutils
+
+USES= gl pkgconfig qmake qt:5
+USE_QT= core designer gui opengl widgets xml buildtools:build
+USE_GL= gl
+USE_LDCONFIG= yes
+
+QMAKE_SOURCE_PATH= ${WRKSRC}/SuWidgets.pro
+
+USE_GITHUB= yes
+GH_ACCOUNT= BatchDrake
+GH_PROJECT= SuWidgets
+
+.include <bsd.port.mk>
diff --git a/comms/suwidgets/distinfo b/comms/suwidgets/distinfo
new file mode 100644
index 000000000000..bbdf483dabde
--- /dev/null
+++ b/comms/suwidgets/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1673119565
+SHA256 (BatchDrake-SuWidgets-v0.1.0-147-g826b3ee_GH0.tar.gz) = db3c338be36de37135636ac321bc31a258ea3c3e0a497450adec454a5118b569
+SIZE (BatchDrake-SuWidgets-v0.1.0-147-g826b3ee_GH0.tar.gz) = 143422
diff --git a/comms/suwidgets/pkg-descr b/comms/suwidgets/pkg-descr
new file mode 100644
index 000000000000..a74d754056f1
--- /dev/null
+++ b/comms/suwidgets/pkg-descr
@@ -0,0 +1 @@
+Sigutils-related widgets that are used in SigDigger.
diff --git a/comms/suwidgets/pkg-plist b/comms/suwidgets/pkg-plist
new file mode 100644
index 000000000000..441727e5d2b8
--- /dev/null
+++ b/comms/suwidgets/pkg-plist
@@ -0,0 +1,28 @@
+include/SuWidgets/ColorChooserButton.h
+include/SuWidgets/Constellation.h
+include/SuWidgets/Decider.h
+include/SuWidgets/FrequencySpinBox.h
+include/SuWidgets/GLWaterfall.h
+include/SuWidgets/Histogram.h
+include/SuWidgets/LCD.h
+include/SuWidgets/MultiToolBox.h
+include/SuWidgets/QVerticalLabel.h
+include/SuWidgets/SuWidgetsHelpers.h
+include/SuWidgets/SymView.h
+include/SuWidgets/TVDisplay.h
+include/SuWidgets/ThrottleableWidget.h
+include/SuWidgets/TimeSpinBox.h
+include/SuWidgets/Transition.h
+include/SuWidgets/Version.h
+include/SuWidgets/WFHelpers.h
+include/SuWidgets/Waterfall.h
+include/SuWidgets/WaveView.h
+include/SuWidgets/WaveViewTree.h
+include/SuWidgets/Waveform.h
+include/SuWidgets/ctkPimpl.h
+include/SuWidgets/ctkRangeSlider.h
+lib/libsuwidgets.so
+lib/libsuwidgets.so.0
+lib/libsuwidgets.so.0.3
+lib/libsuwidgets.so.0.3.0
+%%QT_PLUGINDIR%%/designer/libsuwidgetsplugin.so