aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSilvio Ap Silva <contato@kanazuchi.com>2023-12-22 01:15:12 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-22 01:24:36 +0000
commite658b9c287a660e40c84f4a378cf01a0c8f987bb (patch)
treef8f7f9483d17cae531d9da7661c5d7e1f8bcee80
parent66f32c9dd235dbabda1fbe032194f159aa00d7a7 (diff)
www/php-google-api-php-client: New port
The Google API Client Library enables you to work with Google APIs such as Google+, Drive, or YouTube on your server. These client libraries are officially supported by Google. However, the libraries are considered complete and are in maintenance mode. This means that we will address critical bugs and security issues but will not add any new features. WWW: https://github.com/google/google-api-php-client PR: 227881
-rw-r--r--www/Makefile1
-rw-r--r--www/php-google-api-php-client/Makefile28
-rw-r--r--www/php-google-api-php-client/distinfo3
-rw-r--r--www/php-google-api-php-client/pkg-descr6
-rw-r--r--www/php-google-api-php-client/pkg-plist24
5 files changed, 62 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 072da607d4fe..0369edabfc88 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1401,6 +1401,7 @@
SUBDIR += persepolis
SUBDIR += pglogd
SUBDIR += phalcon
+ SUBDIR += php-google-api-php-client
SUBDIR += php80-opcache
SUBDIR += php80-session
SUBDIR += php80-tidy
diff --git a/www/php-google-api-php-client/Makefile b/www/php-google-api-php-client/Makefile
new file mode 100644
index 000000000000..6f62a983c50f
--- /dev/null
+++ b/www/php-google-api-php-client/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= google-api-php-client
+PORTVERSION= 2.12.4
+DISTVERSIONPREFIX= v
+CATEGORIES= www
+PKGNAMEPREFIX= ${PHP_PKGNAMEPREFIX}
+
+MAINTAINER= contato@kanazuchi.com
+COMMENT= Google api client for php
+WWW= https://github.com/googleapis/google-api-php-client
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PHP_PKGNAMEPREFIX}composer>=0:devel/php-composer@${PHP_FLAVOR}
+
+USES= php:flavors
+USE_GITHUB= yes
+GH_ACCOUNT= googleapis
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} src ${STAGEDIR}${WWWDIR})
+ ${INSTALL_DATA} ${WRKSRC}/composer.json ${STAGEDIR}${WWWDIR}
+
+.include <bsd.port.mk>
diff --git a/www/php-google-api-php-client/distinfo b/www/php-google-api-php-client/distinfo
new file mode 100644
index 000000000000..0d3d1237046e
--- /dev/null
+++ b/www/php-google-api-php-client/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1653504247
+SHA256 (googleapis-google-api-php-client-v2.12.4_GH0.tar.gz) = f136b5cff8ac59f7ae3ba33d0eaecfecfafa7492be38c2000eb131db962ce4e5
+SIZE (googleapis-google-api-php-client-v2.12.4_GH0.tar.gz) = 41119
diff --git a/www/php-google-api-php-client/pkg-descr b/www/php-google-api-php-client/pkg-descr
new file mode 100644
index 000000000000..fbf70ea738ac
--- /dev/null
+++ b/www/php-google-api-php-client/pkg-descr
@@ -0,0 +1,6 @@
+The Google API Client Library enables you to work with Google APIs such as
+Google+, Drive, or YouTube on your server. These client libraries are
+officially supported by Google. However, the libraries are considered complete
+and are in maintenance mode.
+This means that we will address critical bugs and security issues but will not
+add any new features.
diff --git a/www/php-google-api-php-client/pkg-plist b/www/php-google-api-php-client/pkg-plist
new file mode 100644
index 000000000000..854115f6da77
--- /dev/null
+++ b/www/php-google-api-php-client/pkg-plist
@@ -0,0 +1,24 @@
+%%WWWDIR%%/composer.json
+%%WWWDIR%%/src/AccessToken/Revoke.php
+%%WWWDIR%%/src/AccessToken/Verify.php
+%%WWWDIR%%/src/AuthHandler/AuthHandlerFactory.php
+%%WWWDIR%%/src/AuthHandler/Guzzle5AuthHandler.php
+%%WWWDIR%%/src/AuthHandler/Guzzle6AuthHandler.php
+%%WWWDIR%%/src/AuthHandler/Guzzle7AuthHandler.php
+%%WWWDIR%%/src/Client.php
+%%WWWDIR%%/src/Collection.php
+%%WWWDIR%%/src/Exception.php
+%%WWWDIR%%/src/Http/Batch.php
+%%WWWDIR%%/src/Http/MediaFileUpload.php
+%%WWWDIR%%/src/Http/REST.php
+%%WWWDIR%%/src/Model.php
+%%WWWDIR%%/src/Service.php
+%%WWWDIR%%/src/Service/Exception.php
+%%WWWDIR%%/src/Service/README.md
+%%WWWDIR%%/src/Service/Resource.php
+%%WWWDIR%%/src/Task/Composer.php
+%%WWWDIR%%/src/Task/Exception.php
+%%WWWDIR%%/src/Task/Retryable.php
+%%WWWDIR%%/src/Task/Runner.php
+%%WWWDIR%%/src/Utils/UriTemplate.php
+%%WWWDIR%%/src/aliases.php