aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-07 16:03:09 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-07 16:03:09 +0000
commite6dd54055487dca75275d26c5d5039245d1882e3 (patch)
tree9f63f5a4f44fcb6a9a18d99fa291bd1173a91ade
parent7d44e70bf6a7996f92b8b8deb92280f8b580612f (diff)
downloadports-e6dd54055487dca75275d26c5d5039245d1882e3.tar.gz
ports-e6dd54055487dca75275d26c5d5039245d1882e3.zip
devel/googletest: Use C++14
- Update WWW - Use complete arguments/options - Take maintainership from Release Notes: GoogleTest now requires at least C++14. Reference: https://github.com/google/googletest/releases/tag/v1.13.0
-rw-r--r--devel/googletest/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/devel/googletest/Makefile b/devel/googletest/Makefile
index ef5be3fcab49..495d73779aff 100644
--- a/devel/googletest/Makefile
+++ b/devel/googletest/Makefile
@@ -1,21 +1,25 @@
PORTNAME= googletest
+PORTVERSION= 1.13.0
DISTVERSIONPREFIX= v
-DISTVERSION= 1.13.0
CATEGORIES= devel
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Framework for writing C++ tests on a variety of platforms
-WWW= https://github.com/google/googletest
+WWW= https://google.github.io/googletest/ \
+ https://github.com/google/googletest
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USE_GITHUB= yes
-GH_ACCOUNT= google
+USES= cmake:testing compiler:c++14-lang python:test
-USES= cmake:testing compiler:c++11-lib python:test
+CMAKE_OFF= gmock_build_tests gtest_build_samples gtest_build_tests gtest_disable_pthreads gtest_hide_internal_symbols
+CMAKE_ON= BUILD_GMOCK BUILD_SHARED_LIBS INSTALL_GTEST
+CMAKE_TESTING_ON= gmock_build_tests gtest_build_tests
+USE_CXXSTD= c++14
USE_LDCONFIG= yes
-CMAKE_ON= BUILD_SHARED_LIBS
-CMAKE_TESTING_ON= gtest_build_tests gmock_build_tests
+
+USE_GITHUB= yes
+GH_ACCOUNT= google
.include <bsd.port.mk>