aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-29 19:12:42 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-29 19:13:26 +0000
commite70dc32f52b96d9c4541e2d9c0ed4fa38e61b031 (patch)
tree5e9e2ef334bb9d156e3e010af13badfc019cea66
parent810af1b1a0c45daf0cddcaf8578a051ca9d3723a (diff)
downloadports-e70dc32f52b96d9c4541e2d9c0ed4fa38e61b031.tar.gz
ports-e70dc32f52b96d9c4541e2d9c0ed4fa38e61b031.zip
misc/py-pypatent: New port: Search for and retrieve US Patent and Trademark Office Patent Data
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-pypatent/Makefile24
-rw-r--r--misc/py-pypatent/distinfo3
-rw-r--r--misc/py-pypatent/pkg-descr4
4 files changed, 32 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 0bda9756077f..c333f8ac2bc7 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -411,6 +411,7 @@
SUBDIR += py-pyEDFlib
SUBDIR += py-pyfiglet
SUBDIR += py-pykml
+ SUBDIR += py-pypatent
SUBDIR += py-pyprind
SUBDIR += py-python-geohash
SUBDIR += py-python-utils
diff --git a/misc/py-pypatent/Makefile b/misc/py-pypatent/Makefile
new file mode 100644
index 000000000000..35a7ae3780a2
--- /dev/null
+++ b/misc/py-pypatent/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= pypatent
+DISTVERSION= 1.2.0
+CATEGORIES= misc
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Search for and retrieve US Patent and Trademark Office Patent Data
+
+LICENSE= GPLv3
+
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>0:www/py-beautifulsoup@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>0:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}selenium>0:www/py-selenium@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_DEPENDS}
+RUN_DEPENDS= ${PY_DEPENDS}
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-pypatent/distinfo b/misc/py-pypatent/distinfo
new file mode 100644
index 000000000000..8daf16f0f5af
--- /dev/null
+++ b/misc/py-pypatent/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1661797964
+SHA256 (pypatent-1.2.0.tar.gz) = 6ebb2e4e1d8a801a78560607577487c6be97884a1ac1f22cc09350484867fe8d
+SIZE (pypatent-1.2.0.tar.gz) = 7756
diff --git a/misc/py-pypatent/pkg-descr b/misc/py-pypatent/pkg-descr
new file mode 100644
index 000000000000..c2327e36a365
--- /dev/null
+++ b/misc/py-pypatent/pkg-descr
@@ -0,0 +1,4 @@
+pypatent is a tiny Python package to easily search for and scrape US Patent and
+Trademark Office Patent Data.
+
+WWW: https://github.com/daneads/pypatent