aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-05-03 08:16:26 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-05-03 08:16:26 +0000
commite7453ba8973b16ad5caa41e052bd2027758f0599 (patch)
tree5ed537f844925d9e8e21dc46f7aa93fef068ef1f
parent27b683e97975846ddf2d0e1d973e3c35cfbdd6aa (diff)
downloadports-e7453ba8973b16ad5caa41e052bd2027758f0599.tar.gz
ports-e7453ba8973b16ad5caa41e052bd2027758f0599.zip
- Update to 3.3
- Fixed problem described on secunia advisory SA19706, please see http://secunia.com/advisories/19706/ - Few modifications - Note: phpwebftp-3.3b is the same than phpwebftp-3.3 available at sf.net PR: 96702 Submitted by: maintainer (Jose Alonso Cardenas Marquez)
Notes
Notes: svn path=/head/; revision=161260
-rw-r--r--ftp/phpwebftp/Makefile20
-rw-r--r--ftp/phpwebftp/distinfo6
-rw-r--r--ftp/phpwebftp/pkg-plist7
3 files changed, 16 insertions, 17 deletions
diff --git a/ftp/phpwebftp/Makefile b/ftp/phpwebftp/Makefile
index b66bf362fc9f..bb6b376cc14c 100644
--- a/ftp/phpwebftp/Makefile
+++ b/ftp/phpwebftp/Makefile
@@ -6,13 +6,11 @@
#
PORTNAME= phpwebftp
-PORTVERSION= 3.2
-PORTREVISION= 1
+PORTVERSION= 3.3
CATEGORIES= ftp
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= phpwebftp
-DISTNAME= phpWebFTP32
-EXTRACT_SUFX= .zip
+DISTNAME= ${PORTNAME}33
MAINTAINER= acardenas@bsd.org.pe
COMMENT= A set of PHP-scripts to manage FTP over the web
@@ -20,19 +18,19 @@ COMMENT= A set of PHP-scripts to manage FTP over the web
USE_ZIP= yes
NO_BUILD= yes
USE_PHP= ftp
-PHPWEBFTPDIR?= www/data/phpWebFTP
+PHPWEBFTPDIR?= www/data-dist/${PORTNAME}
PLIST_SUB+= PHPWEBFTPDIR=${PHPWEBFTPDIR}
-WRKSRC= ${WRKDIR}/phpWebFTP
+WRKSRC= ${WRKDIR}/${PORTNAME}
do-configure:
- @${MV} ${WRKSRC}/config.inc.php ${WRKSRC}/config.inc.php.bak
- @${CAT} ${WRKSRC}/config.inc.php.bak | ${TR} -d '\015' > ${WRKSRC}/config.inc.php && \
- ${RM} ${WRKSRC}/config.inc.php.bak
@${FIND} -d ${WRKSRC} -name CVS -type d -print0 | ${XARGS} -0 ${RM} -R
do-install:
- @${MKDIR} ${PREFIX}/${PHPWEBFTPDIR}
- @${CP} -R ${WRKSRC}/* ${PREFIX}/${PHPWEBFTPDIR}
+ ${MKDIR} ${PREFIX}/${PHPWEBFTPDIR}
+ @cd ${WRKSRC} && \
+ ${FIND} * -type d -exec ${MKDIR} "${PREFIX}/${PHPWEBFTPDIR}/{}" \; && \
+ ${FIND} -E * -type f -iregex ".*\.(php|html|css|gif|js)" \
+ -exec ${INSTALL_DATA} "{}" "${PREFIX}/${PHPWEBFTPDIR}/{}" \;
@${CHGRP} -R ${WWWGRP} ${PREFIX}/${PHPWEBFTPDIR}
.include <bsd.port.mk>
diff --git a/ftp/phpwebftp/distinfo b/ftp/phpwebftp/distinfo
index 742aa2999984..3fc47f2216f7 100644
--- a/ftp/phpwebftp/distinfo
+++ b/ftp/phpwebftp/distinfo
@@ -1,3 +1,3 @@
-MD5 (phpWebFTP32.zip) = 94ceb24ec758c836422e2b01c5920b03
-SHA256 (phpWebFTP32.zip) = 0eac62ba7a903e4518306c3e30d4e118eaadccfdfb968fb0b6b51410928b699d
-SIZE (phpWebFTP32.zip) = 109053
+MD5 (phpwebftp33.zip) = d3cea8da4ddf19b9703b4f6feb1bc28b
+SHA256 (phpwebftp33.zip) = 1bc13fb68b59085d3d0f6c680d3cab4fe1d8bbe30f483b1bee136e6127d75d5a
+SIZE (phpwebftp33.zip) = 103220
diff --git a/ftp/phpwebftp/pkg-plist b/ftp/phpwebftp/pkg-plist
index a1044aff5d46..7657c6b91482 100644
--- a/ftp/phpwebftp/pkg-plist
+++ b/ftp/phpwebftp/pkg-plist
@@ -1,5 +1,4 @@
%%PHPWEBFTPDIR%%/config.inc.php
-%%PHPWEBFTPDIR%%/gpl.txt
%%PHPWEBFTPDIR%%/img/zip.gif
%%PHPWEBFTPDIR%%/img/createdir.gif
%%PHPWEBFTPDIR%%/img/doc.gif
@@ -28,7 +27,6 @@
%%PHPWEBFTPDIR%%/img/pdf.gif
%%PHPWEBFTPDIR%%/img/php.gif
%%PHPWEBFTPDIR%%/img/pic.gif
-%%PHPWEBFTPDIR%%/img/Thumbs.db
%%PHPWEBFTPDIR%%/img/titlebar.gif
%%PHPWEBFTPDIR%%/img/txt.gif
%%PHPWEBFTPDIR%%/img/upload.gif
@@ -45,6 +43,7 @@
%%PHPWEBFTPDIR%%/include/language/german.lang.php
%%PHPWEBFTPDIR%%/include/language/index.html
%%PHPWEBFTPDIR%%/include/language/italian.lang.php
+%%PHPWEBFTPDIR%%/include/language/japanese.lang.php
%%PHPWEBFTPDIR%%/include/language/latvian.lang.php
%%PHPWEBFTPDIR%%/include/language/latvian-utf8.lang.php
%%PHPWEBFTPDIR%%/include/language/norwegian.lang.php
@@ -56,13 +55,15 @@
%%PHPWEBFTPDIR%%/include/language/swedish.lang.php
%%PHPWEBFTPDIR%%/include/language/turkish.lang.php
%%PHPWEBFTPDIR%%/include/language/ukrainian.lang.php
+%%PHPWEBFTPDIR%%/include/ftp.class.php
%%PHPWEBFTPDIR%%/include/functions.inc.php
+%%PHPWEBFTPDIR%%/include/ss_zip.class.php
%%PHPWEBFTPDIR%%/include/index.html
%%PHPWEBFTPDIR%%/include/script.js
%%PHPWEBFTPDIR%%/index.php
-%%PHPWEBFTPDIR%%/setpermission.php
%%PHPWEBFTPDIR%%/style/cm.css
%%PHPWEBFTPDIR%%/style/index.html
+%%PHPWEBFTPDIR%%/tmp/index.html
@dirrm %%PHPWEBFTPDIR%%/img
@dirrm %%PHPWEBFTPDIR%%/include/language
@dirrm %%PHPWEBFTPDIR%%/include