aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2024-02-11 17:32:37 +0000
committerNicola Vitale <nivit@FreeBSD.org>2024-02-11 17:32:37 +0000
commite7c085c93fa30d429567291a18384abf03b68bbc (patch)
tree538c20abc159a9618a25c250377eb0010616b3a8
parentb6998fd13cf6354a837506d53c87e58fd9307417 (diff)
downloadports-e7c085c93fa30d429567291a18384abf03b68bbc.tar.gz
ports-e7c085c93fa30d429567291a18384abf03b68bbc.zip
deskutils/py-i3-gnome-pomodoro: Add new port
This program integrates gnome-pomodoro into i3/sway and supports i3bar, polybar, sfwbar and waybar. https://github.com/kantord/i3-gnome-pomodoro
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/py-i3-gnome-pomodoro/Makefile32
-rw-r--r--deskutils/py-i3-gnome-pomodoro/distinfo3
-rw-r--r--deskutils/py-i3-gnome-pomodoro/pkg-descr2
4 files changed, 38 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 31be914985b6..e9c589209cb9 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -226,6 +226,7 @@
SUBDIR += puush
SUBDIR += py-autokey
SUBDIR += py-bugwarrior
+ SUBDIR += py-i3-gnome-pomodoro
SUBDIR += py-khal
SUBDIR += py-khard
SUBDIR += py-paperless
diff --git a/deskutils/py-i3-gnome-pomodoro/Makefile b/deskutils/py-i3-gnome-pomodoro/Makefile
new file mode 100644
index 000000000000..6b026a6b0db2
--- /dev/null
+++ b/deskutils/py-i3-gnome-pomodoro/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= i3-gnome-pomodoro
+DISTVERSION= 0.1.0
+CATEGORIES= deskutils python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PYDISTNAME}-${DISTVERSION}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Integrate gnome-pomodoro into i3bar, polybar or waybar
+WWW= https://github.com/kantord/i3-gnome-pomodoro
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.7.0:devel/py-poetry-core@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blinkstick>=g20230504:sysutils/py-blinkstick@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>=8.1.7:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}i3ipc>=2.2.1:x11/py-i3ipc@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pydbus>=0.6.0:devel/py-pydbus@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyusb>=1.2.1:devel/py-pyusb@${PY_FLAVOR} \
+ gnome-pomodoro:deskutils/gnome-pomodoro \
+ pygobject3-common>=3.42.0:devel/pygobject3-common
+
+USES= python shebangfix
+
+USE_PYTHON= autoplist pep517
+
+SHEBANG_FILES= ${WRKSRC}/${PYDISTNAME}/pomodoro_client.py
+
+PYDISTNAME= ${PORTNAME:S/-/_/g}
+
+.include <bsd.port.mk>
diff --git a/deskutils/py-i3-gnome-pomodoro/distinfo b/deskutils/py-i3-gnome-pomodoro/distinfo
new file mode 100644
index 000000000000..02cd55dc725c
--- /dev/null
+++ b/deskutils/py-i3-gnome-pomodoro/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1704301272
+SHA256 (i3_gnome_pomodoro-0.1.0.tar.gz) = dfe372e1936576f55de3d78a7a05f22159cfa45ae712a45ebf0560ed6b92f531
+SIZE (i3_gnome_pomodoro-0.1.0.tar.gz) = 17932
diff --git a/deskutils/py-i3-gnome-pomodoro/pkg-descr b/deskutils/py-i3-gnome-pomodoro/pkg-descr
new file mode 100644
index 000000000000..ce635369563d
--- /dev/null
+++ b/deskutils/py-i3-gnome-pomodoro/pkg-descr
@@ -0,0 +1,2 @@
+This program integrates gnome-pomodoro into i3 and supports i3bar, polybar,
+sfwbar and waybar.