aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2022-04-15 06:25:56 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2022-04-15 06:25:56 +0000
commite81eb93dd6fe13db218526e8410297dad2a61dfb (patch)
treee9f33135ae0e2988610e479fbabc6877a0df5011
parent04268f78bf232f126104ed770e6702a8a615b7b8 (diff)
downloadports-e81eb93dd6fe13db218526e8410297dad2a61dfb.tar.gz
ports-e81eb93dd6fe13db218526e8410297dad2a61dfb.zip
graphics/gd: new option LIQ
PR: 263185
-rw-r--r--graphics/gd/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/graphics/gd/Makefile b/graphics/gd/Makefile
index 26c5a22ee79e..2c13dd53581c 100644
--- a/graphics/gd/Makefile
+++ b/graphics/gd/Makefile
@@ -25,8 +25,8 @@ SUB_FILES= gdlib-config
USE_LDCONFIG= yes
TEST_TARGET= check
-OPTIONS_DEFINE= PNG JPEG WEBP HEIF AVIF TIFF FREETYPE FONTCONFIG RAQM XPM ICONV
-OPTIONS_DEFAULT=PNG JPEG WEBP TIFF FREETYPE FONTCONFIG ICONV
+OPTIONS_DEFINE= PNG JPEG WEBP TIFF XPM HEIF AVIF LIQ FREETYPE FONTCONFIG RAQM ICONV
+OPTIONS_DEFAULT=PNG JPEG WEBP TIFF LIQ FREETYPE FONTCONFIG ICONV
NO_OPTIONS_SORT=yes
OPTIONS_SUB= yes
PNG_LIB_DEPENDS= libpng.so:graphics/png
@@ -38,6 +38,9 @@ JPEG_CPPFLAGS= -I${LOCALBASE}/include
WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
WEBP_CONFIGURE_OFF= --without-webp
WEBP_CPPFLAGS= -I${LOCALBASE}/include
+TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
+TIFF_CONFIGURE_OFF= --without-tiff
+TIFF_CPPFLAGS= -I${LOCALBASE}/include
HEIF_DESC= HEIF image format support
HEIF_LIB_DEPENDS= libheif.so:graphics/libheif
HEIF_CONFIGURE_OFF= --without-heif
@@ -46,9 +49,10 @@ AVIF_LIB_DEPENDS= libavif.so:graphics/libavif
AVIF_CONFIGURE_OFF= --without-avif
AVIF_CPPFLAGS= -I${LOCALBASE}/include
AVIF_USES= autoreconf
-TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
-TIFF_CONFIGURE_OFF= --without-tiff
-TIFF_CPPFLAGS= -I${LOCALBASE}/include
+LIQ_DESC= libimagequant color conversion support
+LIQ_LIB_DEPENDS= libimagequant.so:graphics/libimagequant
+LIQ_CONFIGURE_OFF= --with-liq=no
+LIQ_CPPFLAGS= -I${LOCALBASE}/include
FREETYPE_LIB_DEPENDS= libfreetype.so:print/freetype2
FREETYPE_CONFIGURE_OFF= --without-freetype
FREETYPE_CPPFLAGS= -I${LOCALBASE}/include