aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2023-01-06 17:33:28 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2023-01-06 19:16:14 +0000
commite828e846e9fb1079bc75cdd33789ceff248bfe74 (patch)
tree78999b58ce1ff979bdce15ea6d4ceba15284a714
parentcd455a53702681a0b1832828bb99fe9c0ab1f11e (diff)
downloadports-e828e846e9fb1079bc75cdd33789ceff248bfe74.tar.gz
ports-e828e846e9fb1079bc75cdd33789ceff248bfe74.zip
devel/arcanist-lib: handle 'arc patch' runtime exception
Approved by: grembo (maintainer) Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D37969
-rw-r--r--devel/arcanist-lib/Makefile2
-rw-r--r--devel/arcanist-lib/files/patch-src_repository_api_ArcanistGitAPI.php11
2 files changed, 12 insertions, 1 deletions
diff --git a/devel/arcanist-lib/Makefile b/devel/arcanist-lib/Makefile
index a22e2ad35e3d..8fbe5718f993 100644
--- a/devel/arcanist-lib/Makefile
+++ b/devel/arcanist-lib/Makefile
@@ -1,6 +1,6 @@
PORTNAME?= arcanist
PORTVERSION?= 20220518
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= devel
PKGNAMESUFFIX= ${SLAVE_PKGNAMESUFFIX}${PHP_PKGNAMESUFFIX}
diff --git a/devel/arcanist-lib/files/patch-src_repository_api_ArcanistGitAPI.php b/devel/arcanist-lib/files/patch-src_repository_api_ArcanistGitAPI.php
new file mode 100644
index 000000000000..fa73cbef6e63
--- /dev/null
+++ b/devel/arcanist-lib/files/patch-src_repository_api_ArcanistGitAPI.php
@@ -0,0 +1,11 @@
+--- src/repository/api/ArcanistGitAPI.php.orig 2023-01-06 17:27:38 UTC
++++ src/repository/api/ArcanistGitAPI.php
+@@ -1143,7 +1143,7 @@ final class ArcanistGitAPI extends ArcanistRepositoryA
+
+ public function hasLocalCommit($commit) {
+ try {
+- if (!$this->getCanonicalRevisionName($commit)) {
++ if (!$this->getCanonicalRevisionName($commit ?? '')) {
+ return false;
+ }
+ } catch (CommandException $exception) {