aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGian-Simon Purkert <gspurki@gmail.com>2021-12-23 20:41:02 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2021-12-23 21:20:59 +0000
commite84b431b31bb3d65bb30934f2f6f42b3d80cc0f7 (patch)
tree6a28abe374adbac5b87dbe00c9761af14f86f472
parentfa3376773c949c77fdb0fafb61adb139b4c566aa (diff)
downloadports-e84b431b31bb3d65bb30934f2f6f42b3d80cc0f7.tar.gz
ports-e84b431b31bb3d65bb30934f2f6f42b3d80cc0f7.zip
emulators/dps8m: New port: 'SIMH' based simulator for the Honeywell h6180 / dps8m Multics processor
PR: 254553 Approved by: mentors (implicit)
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/dps8m/Makefile41
-rw-r--r--emulators/dps8m/distinfo3
-rw-r--r--emulators/dps8m/files/patch-src_Makefile.mk11
-rw-r--r--emulators/dps8m/pkg-descr9
5 files changed, 65 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index ec606176fa43..474bddb0bdd2 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -22,6 +22,7 @@
SUBDIR += dolphin-emu
SUBDIR += dosbox
SUBDIR += dosbox-staging
+ SUBDIR += dps8m
SUBDIR += dynamips-community
SUBDIR += edumips64
SUBDIR += elliott-803
diff --git a/emulators/dps8m/Makefile b/emulators/dps8m/Makefile
new file mode 100644
index 000000000000..555e7ca9d278
--- /dev/null
+++ b/emulators/dps8m/Makefile
@@ -0,0 +1,41 @@
+PORTNAME= dps8m
+DISTVERSION= 2.0.1rc2.20211124
+CATEGORIES= emulators
+
+MAINTAINER= gspurki@gmail.com
+COMMENT= SIMH based simulator for the Honeywell h6180/dps8m Multics processor
+
+LICENSE= ICU
+LICENSE_NAME= ICU license
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+ONLY_FOR_ARCHS= aarch64 amd64
+ONLY_FOR_ARCHS_REASON= __uint128_t is only implemented on 64-bit platforms
+
+LIB_DEPENDS= libuv.so:devel/libuv
+
+USES= gmake
+
+USE_GITLAB= yes
+GL_COMMIT= 572f79bb4f0f84a8b16c3892c894c2b9ed64b458
+
+MAKEFILE= GNUmakefile
+
+MAKE_ARGS+= V=1 ATOMICS=BSD
+
+PLIST_FILES= bin/dps8 \
+ bin/prt2pdf \
+ bin/punutil
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/dps8/dps8 ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/prt2pdf/prt2pdf ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/punutil/punutil ${STAGEDIR}${PREFIX}/bin
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/dps8
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/prt2pdf
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/punutil
+
+.include <bsd.port.mk>
diff --git a/emulators/dps8m/distinfo b/emulators/dps8m/distinfo
new file mode 100644
index 000000000000..ca7d2920c191
--- /dev/null
+++ b/emulators/dps8m/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1638915391
+SHA256 (dps8m-dps8m-572f79bb4f0f84a8b16c3892c894c2b9ed64b458_GL0.tar.gz) = 9416cf5b5198f795af913b9f0cae24cb6237693f8a53b84500b60a55d5d32550
+SIZE (dps8m-dps8m-572f79bb4f0f84a8b16c3892c894c2b9ed64b458_GL0.tar.gz) = 1928413
diff --git a/emulators/dps8m/files/patch-src_Makefile.mk b/emulators/dps8m/files/patch-src_Makefile.mk
new file mode 100644
index 000000000000..1a6461794d3e
--- /dev/null
+++ b/emulators/dps8m/files/patch-src_Makefile.mk
@@ -0,0 +1,11 @@
+--- src/Makefile.mk.orig 2021-12-07 20:32:53 UTC
++++ src/Makefile.mk
+@@ -163,7 +163,7 @@ endif
+ # Default FLAGS
+
+ ifndef SUNPRO
+- CFLAGS += -Wall -g3 -O3 -fno-strict-aliasing
++ CFLAGS += -Wall -fno-strict-aliasing
+ endif
+ CFLAGS += $(X_FLAGS)
+ LDFLAGS += $(X_FLAGS)
diff --git a/emulators/dps8m/pkg-descr b/emulators/dps8m/pkg-descr
new file mode 100644
index 000000000000..b2b256b2afab
--- /dev/null
+++ b/emulators/dps8m/pkg-descr
@@ -0,0 +1,9 @@
+SIMH based simulator for the Honeywell h6180/dps8m Multics processor.
+Capable of booting Multics MR12.5 and Multics MR12.6f.
+
+The fastest way to your running Multics-system is the
+Quickstart Image, downloadable from:
+
+https://multics-wiki.swenson.org/index.php/Main_Page
+
+WWW: http://ringzero.wikidot.com