aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2024-01-04 17:51:08 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2024-01-04 17:51:08 +0000
commite880e2dc5cad38f40570945d32159e1cab3d4faa (patch)
tree3daec2438776556216bf6f1cdf7b7c36d8e8bc4c
parent3ef3192a9b9d372938583fd67fb64470d2a35347 (diff)
downloadports-e880e2dc5cad38f40570945d32159e1cab3d4faa.tar.gz
ports-e880e2dc5cad38f40570945d32159e1cab3d4faa.zip
lang/fpc: Add dbus and newt units
- Remove obsolete pkg-message entries - Bump PORTREVISION
-rw-r--r--lang/fpc/Makefile6
-rw-r--r--lang/fpc/files/pkg-message.in14
-rw-r--r--lang/fpc/pkg-plist13
3 files changed, 20 insertions, 13 deletions
diff --git a/lang/fpc/Makefile b/lang/fpc/Makefile
index 518cf1206854..5c08282cb2eb 100644
--- a/lang/fpc/Makefile
+++ b/lang/fpc/Makefile
@@ -1,6 +1,6 @@
PORTNAME= fpc
PORTVERSION= 3.2.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= lang
MASTER_SITES= SF/freepascal/Source/${PORTVERSION}:source \
https://downloads.freepascal.org/${PORTNAME}/dist/${PORTVERSION}/source/:source \
@@ -111,6 +111,8 @@ post-patch:
@${REINPLACE_CMD} -i "" -e 's|linux|freebsd,linux|g' \
${WRKSRC}/packages/a52/fpmake.pp
@${REINPLACE_CMD} -i "" -e 's|linux|freebsd,linux|g' \
+ ${WRKSRC}/packages/dbus/fpmake.pp
+ @${REINPLACE_CMD} -i "" -e 's|linux|freebsd,linux|g' \
${WRKSRC}/packages/dts/fpmake.pp
@${REINPLACE_CMD} -i "" -e 's|freebsd,||g' \
${WRKSRC}/packages/fpgtk/fpmake.pp
@@ -130,7 +132,7 @@ post-patch:
${WRKSRC}/packages/mad/fpmake.pp
@${REINPLACE_CMD} -i "" -e 's|linux|freebsd,linux|g' \
${WRKSRC}/packages/modplug/fpmake.pp
- @${REINPLACE_CMD} -i "" -e 's|linux|freebsd,linux|g' \
+ @${REINPLACE_CMD} -i "" -e 's|Linux|freebsd,linux|g' \
${WRKSRC}/packages/newt/fpmake.pp
@${REINPLACE_CMD} -i "" -e 's|linux|freebsd,linux|g' \
${WRKSRC}/packages/oggvorbis/fpmake.pp
diff --git a/lang/fpc/files/pkg-message.in b/lang/fpc/files/pkg-message.in
index d90535d45583..6733c0ec4758 100644
--- a/lang/fpc/files/pkg-message.in
+++ b/lang/fpc/files/pkg-message.in
@@ -8,26 +8,18 @@
This is necessary for correct linking of libraries.
-2) You can install additional units from:
-
- * lang/fpc-units
-
-3) If you want to see all documentation about FreePascal, you can install
+2) If you want to see all documentation about FreePascal, you can install
* lang/fpc-docs
-4) Optionally, you can install textmode IDE with Delphi support
-
- * editors/fpc-ide
-
-5) This port add support to fp compiler to get value from FPC_LDPATH
+3) This port add support to fp compiler to get value from FPC_LDPATH
environment variable. By default fp compiler use %%LOCALBASE%%/bin/ld.bfd for
linking binaries. If you want change this, just must be define FPC_LDPATH
with path to ld tool that will be used by fp compiler. Take on mind that fpc
only works with binutils on this moment but could work with another ld tool
later on next versions of freepascal
-6) Enjoy it ;)
+4) Enjoy it ;)
EOM
}
]
diff --git a/lang/fpc/pkg-plist b/lang/fpc/pkg-plist
index 085478620ff4..796a1cf70bff 100644
--- a/lang/fpc/pkg-plist
+++ b/lang/fpc/pkg-plist
@@ -72,6 +72,7 @@ lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/bzip2.fpm
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/cairo.fpm
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/chm.fpm
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/dblib.fpm
+lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/dbus.fpm
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/dts.fpm
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/fastcgi.fpm
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/fcl-async.fpm
@@ -134,6 +135,7 @@ lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/mad.fpm
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/modplug.fpm
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/mysql.fpm
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/ncurses.fpm
+lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/newt.fpm
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/numlib.fpm
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/odata.fpm
lib/fpc/%%PORTVERSION%%/fpmkinst/%%BUILDNAME%%/odbc.fpm
@@ -264,6 +266,11 @@ lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/paslzxcomp.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/paslzxcomp.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/dblib/dblib.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/dblib/dblib.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/dbus/dbus.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/dbus/dbus.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/dbus/dbuscomp.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/dbus/dbuscomp.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/dbus/dbuscomp.rsj
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/dts/dts.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/dts/dts.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/fastcgi/fastcgi.o
@@ -1839,6 +1846,8 @@ lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/ncurses/ocrt.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/ncurses/ocrt.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/ncurses/panel.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/ncurses/panel.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/newt/newt.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/newt/newt.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/numlib/det.o
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/numlib/det.ppu
lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/numlib/dsl.o
@@ -2619,6 +2628,7 @@ man/man5/ptop.cfg.5.gz
%%DOCSDIR%%-%%PORTVERSION%%/symbolic/symbolic.txt
%%EXAMPLESDIR%%-%%PORTVERSION%%/aspell/examples/example.pas
%%EXAMPLESDIR%%-%%PORTVERSION%%/bzip2/examples/pasbzip.pas
+%%EXAMPLESDIR%%-%%PORTVERSION%%/dbus/examples/busexample.pp
%%EXAMPLESDIR%%-%%PORTVERSION%%/fcl-base/examples/asiotest.pp
%%EXAMPLESDIR%%-%%PORTVERSION%%/fcl-base/examples/b64.pp
%%EXAMPLESDIR%%-%%PORTVERSION%%/fcl-base/examples/b64dec.pp
@@ -2883,6 +2893,9 @@ man/man5/ptop.cfg.5.gz
%%EXAMPLESDIR%%-%%PORTVERSION%%/ncurses/examples/tnlshello.pp
%%EXAMPLESDIR%%-%%PORTVERSION%%/ncurses/examples/tpad.pp
%%EXAMPLESDIR%%-%%PORTVERSION%%/ncurses/examples/twindow.pp
+%%EXAMPLESDIR%%-%%PORTVERSION%%/newt/examples/newt1.pas
+%%EXAMPLESDIR%%-%%PORTVERSION%%/newt/examples/newt2.pas
+%%EXAMPLESDIR%%-%%PORTVERSION%%/newt/examples/newt3.pas
%%EXAMPLESDIR%%-%%PORTVERSION%%/numlib/examples/detgpbte.pas
%%EXAMPLESDIR%%-%%PORTVERSION%%/numlib/examples/detgpdte.pas
%%EXAMPLESDIR%%-%%PORTVERSION%%/numlib/examples/detgsyte.pas