aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjörn Lemke <lemke@lemke-it.com>2024-06-30 09:43:00 +0000
committerKurt Jaeger <pi@FreeBSD.org>2024-06-30 09:43:56 +0000
commite89748e0ca32e838e041b47d011d21e8bed7e95c (patch)
treeb22d0320abdc4df17b18cbe936623542bddf8175
parent8a36037e77347b35dc6e8dc46cb6bdf3d142eaa9 (diff)
databases/pythoncego: New port
The Cego Python driver enables Python programs to access cego databases, using an API which is compliant with the Python DB API 2.0 (PEP-249). It is written in C and uses the Cego C wrapper client library for client server communication. This implementation is derived from the MariaDB Connector written by Georg Richter.
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pythoncego/Makefile19
-rw-r--r--databases/pythoncego/distinfo3
-rw-r--r--databases/pythoncego/pkg-descr8
4 files changed, 31 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 770f1911c306..14cbeddc4d2a 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -841,6 +841,7 @@
SUBDIR += py-whisper
SUBDIR += py-xapian
SUBDIR += py-zodbpickle
+ SUBDIR += pythoncego
SUBDIR += qdbm
SUBDIR += qdbm-plus
SUBDIR += qdrant
diff --git a/databases/pythoncego/Makefile b/databases/pythoncego/Makefile
new file mode 100644
index 000000000000..1e97b7efafd8
--- /dev/null
+++ b/databases/pythoncego/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= pythoncego
+PORTVERSION= 1.0.1
+
+CATEGORIES= databases
+MASTER_SITES= http://www.lemke-it.com/
+
+MAINTAINER= pi@FreeBSD.org
+COMMENT= Cego database support for Python
+WWW= https://www.lemke-it.com/
+
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libcego.so:databases/cego
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils pytest
+
+.include <bsd.port.mk>
diff --git a/databases/pythoncego/distinfo b/databases/pythoncego/distinfo
new file mode 100644
index 000000000000..5ee792736030
--- /dev/null
+++ b/databases/pythoncego/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1719740107
+SHA256 (pythoncego-1.0.1.tar.gz) = 24f8b354216895a707692c47fa173f6af2deb0ed456d37351067675f8b3be87a
+SIZE (pythoncego-1.0.1.tar.gz) = 34401
diff --git a/databases/pythoncego/pkg-descr b/databases/pythoncego/pkg-descr
new file mode 100644
index 000000000000..3e4410ab91f1
--- /dev/null
+++ b/databases/pythoncego/pkg-descr
@@ -0,0 +1,8 @@
+The Cego Python driver enables Python programs to access cego databases,
+using an API which is compliant with the Python DB API 2.0 (PEP-249).
+It is written in C and uses the Cego C wrapper client library for
+client server communication.
+
+This implementation is derived from the MariaDB Connector written
+by Georg Richter.
+