aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-17 23:44:32 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-17 23:58:18 +0000
commite8e275f53cb30213ba77c5f599e3d803f8a8092b (patch)
treef7f1831081bc7873cda924bfcfdfa55adcfe85c0
parent8b2239433daf63c60b036fb37697c69c6fd0b6fe (diff)
devel/py-pint: Update to 0.19.1
- Update USES=python of dependent ports Changes: https://github.com/hgrecco/pint/blob/master/CHANGES
-rw-r--r--devel/py-pint-pandas/Makefile2
-rw-r--r--devel/py-pint/Makefile13
-rw-r--r--devel/py-pint/distinfo6
-rw-r--r--math/py-mathics/Makefile2
-rw-r--r--science/py-pyked/Makefile2
-rw-r--r--science/py-qcelemental/Makefile2
-rw-r--r--science/py-qcengine/Makefile2
7 files changed, 11 insertions, 18 deletions
diff --git a/devel/py-pint-pandas/Makefile b/devel/py-pint-pandas/Makefile
index 5cde81108c8e..a2a7abc8404a 100644
--- a/devel/py-pint-pandas/Makefile
+++ b/devel/py-pint-pandas/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pandas>=1.2,1:math/py-pandas@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pint>=0.17:devel/py-pint@${PY_FLAVOR}
-USES= python:3.7+
+USES= python:3.8+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/devel/py-pint/Makefile b/devel/py-pint/Makefile
index 48ec310e9fc8..2e89f3531de1 100644
--- a/devel/py-pint/Makefile
+++ b/devel/py-pint/Makefile
@@ -1,7 +1,7 @@
# Created by: Alexander Nusov <alexander.nusov@nfvexpress.com>
PORTNAME= pint
-PORTVERSION= 0.18
+PORTVERSION= 0.19.1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,19 +14,12 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR}
-USES= python:3.7+ shebangfix
+USES= python:3.8+ shebangfix
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
SHEBANG_FILES= pint/pint-convert
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 30800
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=0:devel/py-importlib-metadata@${PY_FLAVOR}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/py-pint/distinfo b/devel/py-pint/distinfo
index c5c9cdcdac63..0cf1b0bc3094 100644
--- a/devel/py-pint/distinfo
+++ b/devel/py-pint/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1635713661
-SHA256 (Pint-0.18.tar.gz) = 8c4bce884c269051feb7abc69dbfd18403c0c764abc83da132e8a7222f8ba801
-SIZE (Pint-0.18.tar.gz) = 272830
+TIMESTAMP = 1650129296
+SHA256 (Pint-0.19.1.tar.gz) = 3e5913e4ad125f672f72e19e06a8cb1f6d36a4922b6e5a49e04ff882511f82c8
+SIZE (Pint-0.19.1.tar.gz) = 290698
diff --git a/math/py-mathics/Makefile b/math/py-mathics/Makefile
index 6847dc5ba338..3277457c4e71 100644
--- a/math/py-mathics/Makefile
+++ b/math/py-mathics/Makefile
@@ -63,7 +63,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
#USE_GITHUB= yes
#GH_ACCOUNT= ${PORTNAME:tl}
-USES= python:3.7+ shebangfix
+USES= python:3.8+ shebangfix
USE_PYTHON= distutils noflavors
SHEBANG_GLOB= *.py
diff --git a/science/py-pyked/Makefile b/science/py-pyked/Makefile
index 257f252453b6..0534b8dde910 100644
--- a/science/py-pyked/Makefile
+++ b/science/py-pyked/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}uncertainties>=3.0.1:math/py-uncertainties@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>=3.12:devel/py-yaml@${PY_FLAVOR} \
-USES= python:3.7+
+USES= python:3.8+
USE_PYTHON= distutils concurrent autoplist
USE_GITHUB= yes
diff --git a/science/py-qcelemental/Makefile b/science/py-qcelemental/Makefile
index c1fd2aee2870..977611df69d4 100644
--- a/science/py-qcelemental/Makefile
+++ b/science/py-qcelemental/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}pydantic>=1.8.2:devel/py-pydantic@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
-USES= python:3.7+
+USES= python:3.8+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/science/py-qcengine/Makefile b/science/py-qcengine/Makefile
index 9873435ab974..e7c8ae7a068a 100644
--- a/science/py-qcengine/Makefile
+++ b/science/py-qcengine/Makefile
@@ -22,7 +22,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}geometric>0:science/py-geometric@${PY_FLAVOR}
# last dependencies above are for specific quantum chemistry packages to test with TODO torchani,mopac,openmm,psi4,torsiondrive,mdi
-USES= python:3.6+
+USES= python:3.8+
USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes