aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2021-04-14 11:11:06 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2021-04-14 11:11:06 +0000
commite91ecf9b7664d357cf9270b0edc43524957e9777 (patch)
treed258787b8afbfffc7904845237d4bf179eaa480f
parent9ee84848094757a07a41aefc97967e6ae1a43039 (diff)
downloadports-e91ecf9b7664d357cf9270b0edc43524957e9777.tar.gz
ports-e91ecf9b7664d357cf9270b0edc43524957e9777.zip
net/ipxe: update g20201129 (13a6d17) to g20210413 (8ca43cc)
- https://github.com/ipxe/ipxe/commit/79c0173 Create util/genfsimg for building filesystem-based images Generalise util/geniso, util/gensdsk, and util/genefidsk to create a single script util/genfsimg that can be used to build either FAT filesystem images or ISO images. - https://github.com/ipxe/ipxe/commit/f034ae5 Allow elf2efi.c to build on FreeBSD PR: 254600 Reported by: dch@
-rw-r--r--net/ipxe/Makefile6
-rw-r--r--net/ipxe/distinfo6
-rw-r--r--net/ipxe/files/patch-util_elf2efi.c11
3 files changed, 6 insertions, 17 deletions
diff --git a/net/ipxe/Makefile b/net/ipxe/Makefile
index 8c388b392891..e4025538bca5 100644
--- a/net/ipxe/Makefile
+++ b/net/ipxe/Makefile
@@ -1,7 +1,7 @@
# Created by: Guerkan Karaman <gk.freebsd@googlemail.com>
PORTNAME= ipxe
-DISTVERSION= g20201129
+DISTVERSION= g20210413
PORTEPOCH= 1
CATEGORIES= net
@@ -17,9 +17,8 @@ USES= gmake perl5 shebangfix
USE_BINUTILS= yes
USE_GCC= yes:build
USE_GITHUB= yes
-GH_TAGNAME= 13a6d17
+GH_TAGNAME= 8ca43cc
USE_PERL5= build
-SHEBANG_FILES= util/geniso util/gensdsk
MAKE_ARGS= AR=${AR} \
ARCH=${ARCH:S/amd64/i386/} \
AS=${AS} \
@@ -34,6 +33,7 @@ MAKE_ARGS= AR=${AR} \
RANLIB=${RANLIB} \
SIZE=${SIZE} \
V=1
+
# Append user-settable build args from make.conf
MAKE_ARGS+= ${IPXE_MAKE_ARGS}
ALL_TARGET= bin/ipxe.dsk bin/ipxe.lkrn bin/ipxe.pxe bin/ipxe.usb \
diff --git a/net/ipxe/distinfo b/net/ipxe/distinfo
index 5c02040df867..4793d4bc3e80 100644
--- a/net/ipxe/distinfo
+++ b/net/ipxe/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1606744168
-SHA256 (ipxe-ipxe-g20201129-13a6d17_GH0.tar.gz) = ed3f8f838463d9341988a38aa2f208fe55bf778a7933a62ed01241e35d1e9138
-SIZE (ipxe-ipxe-g20201129-13a6d17_GH0.tar.gz) = 3914076
+TIMESTAMP = 1618392901
+SHA256 (ipxe-ipxe-g20210413-8ca43cc_GH0.tar.gz) = c55d3d45d486a62460152323e329eadb2a24f9f4ef52567efdb3fcccb965f936
+SIZE (ipxe-ipxe-g20210413-8ca43cc_GH0.tar.gz) = 3955775
diff --git a/net/ipxe/files/patch-util_elf2efi.c b/net/ipxe/files/patch-util_elf2efi.c
deleted file mode 100644
index e3d1a367dca9..000000000000
--- a/net/ipxe/files/patch-util_elf2efi.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- util/elf2efi.c.orig 2018-02-27 10:48:55 UTC
-+++ util/elf2efi.c
-@@ -73,7 +73,7 @@
- #define ELF_MREL( mach, type ) ( (mach) | ( (type) << 16 ) )
-
- /* Allow for building with older versions of elf.h */
--#ifndef EM_AARCH64
-+#if !defined(EM_AARCH64) || defined(__FreeBSD__)
- #define EM_AARCH64 183
- #define R_AARCH64_NONE 0
- #define R_AARCH64_ABS64 257