aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-07-29 19:02:49 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-07-29 19:02:49 +0000
commite9b9dbfdc41cf443fbbed58f4cc687db9a381d0b (patch)
treee77316147592448a17b3b97ce70346676733c9cd
parent3e3aa55e1e4b46cbcaffa3daa1e4c53776b88802 (diff)
devel/py-pytest-alembic: Add py-pytest-alembic 0.11.1
pytest-alembic is a pytest plugin to test alembic migrations (with default tests) and which enables you to write tests specific to your migrations.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pytest-alembic/Makefile33
-rw-r--r--devel/py-pytest-alembic/distinfo3
-rw-r--r--devel/py-pytest-alembic/pkg-descr2
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a52351129b4a..e00bb73f7186 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5512,6 +5512,7 @@
SUBDIR += py-pyte
SUBDIR += py-pytest
SUBDIR += py-pytest-aiohttp
+ SUBDIR += py-pytest-alembic
SUBDIR += py-pytest-asyncio
SUBDIR += py-pytest-azurepipelines
SUBDIR += py-pytest-benchmark
diff --git a/devel/py-pytest-alembic/Makefile b/devel/py-pytest-alembic/Makefile
new file mode 100644
index 000000000000..dd67144812eb
--- /dev/null
+++ b/devel/py-pytest-alembic/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= pytest-alembic
+PORTVERSION= 0.11.1
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pytest_alembic-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Pytest plugin for verifying alembic migrations
+WWW= https://pytest-alembic.readthedocs.io/en/latest/ \
+ https://github.com/schireson/pytest-alembic
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.0.8:devel/py-poetry-core@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}alembic>=0:databases/py-alembic@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=6.0,1:devel/py-pytest@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+#NO_ARCH= yes
+
+OPTIONS_RADIO_SQL= ALCHEMY14 ALCHEMY20
+OPTIONS_DEFAULT=ALCHEMY14
+ALCHEMY14_DESC= Support SQL databases via databases/py-sqlalchemy14
+ALCHEMY20_DESC= Support SQL databases via databases/py-sqlalchemy20
+
+ALCHEMY14_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy14>=0:databases/py-sqlalchemy14@${PY_FLAVOR}
+ALCHEMY20_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy20>=0:databases/py-sqlalchemy20@${PY_FLAVOR}
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytest-alembic/distinfo b/devel/py-pytest-alembic/distinfo
new file mode 100644
index 000000000000..da81045cd7f7
--- /dev/null
+++ b/devel/py-pytest-alembic/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1722272048
+SHA256 (pytest_alembic-0.11.1.tar.gz) = a920d8770b5be77326c5c1b2bd8d4d4a0dd8fc2c2d57abbcd1fec28a21131b85
+SIZE (pytest_alembic-0.11.1.tar.gz) = 29977
diff --git a/devel/py-pytest-alembic/pkg-descr b/devel/py-pytest-alembic/pkg-descr
new file mode 100644
index 000000000000..c16eb5eed6bf
--- /dev/null
+++ b/devel/py-pytest-alembic/pkg-descr
@@ -0,0 +1,2 @@
+pytest-alembic is a pytest plugin to test alembic migrations (with default
+tests) and which enables you to write tests specific to your migrations.