aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-07-15 17:57:58 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-07-15 17:58:53 +0000
commiteabf8b6d55f022279a56f53120c93410c7d73458 (patch)
treec7255986e2d28a27d45ad1fd493b8a8f6c76fc65
parentc2bb2605ef5848028cc327c268f6040523f997d1 (diff)
downloadports-eabf8b6d55f022279a56f53120c93410c7d73458.tar.gz
ports-eabf8b6d55f022279a56f53120c93410c7d73458.zip
games/py-discord.py: New port: API wrapper for Discord written in Python
-rw-r--r--games/Makefile1
-rw-r--r--games/py-discord.py/Makefile19
-rw-r--r--games/py-discord.py/distinfo3
-rw-r--r--games/py-discord.py/pkg-descr4
4 files changed, 27 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 9318c70d8f72..238da4150402 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -769,6 +769,7 @@
SUBDIR += pushover
SUBDIR += pvpgn
SUBDIR += py-cbeams
+ SUBDIR += py-discord.py
SUBDIR += py-fife
SUBDIR += py-mnemosyne
SUBDIR += py-pychess
diff --git a/games/py-discord.py/Makefile b/games/py-discord.py/Makefile
new file mode 100644
index 000000000000..e30bcbb47efd
--- /dev/null
+++ b/games/py-discord.py/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= discord.py
+PORTVERSION= 1.7.3
+CATEGORIES= games python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nc@FreeBSD.org
+COMMENT= API wrapper for Discord written in Python
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>0:www/py-aiohttp@${PY_FLAVOR}
+
+USES= python:3.8+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/games/py-discord.py/distinfo b/games/py-discord.py/distinfo
new file mode 100644
index 000000000000..b47bea5a1b8d
--- /dev/null
+++ b/games/py-discord.py/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1626371751
+SHA256 (discord.py-1.7.3.tar.gz) = 462cd0fe307aef8b29cbfa8dd613e548ae4b2cb581d46da9ac0d46fb6ea19408
+SIZE (discord.py-1.7.3.tar.gz) = 730988
diff --git a/games/py-discord.py/pkg-descr b/games/py-discord.py/pkg-descr
new file mode 100644
index 000000000000..0516d2547de7
--- /dev/null
+++ b/games/py-discord.py/pkg-descr
@@ -0,0 +1,4 @@
+discord.py is a modern, easy to use, feature-rich, and async ready API
+wrapper for Discord written in Python.
+
+WWW: https://github.com/Rapptz/discord.py