aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-05-30 08:47:56 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-05-30 08:49:05 +0000
commiteae7bb6a90ebb38a372f12b5bd614db4c7b26ff3 (patch)
tree52393774e9ae7780bb9a8f9b3b5c2ca74225fac9
parent9673aa6789360e64a309dd6cafbf2d002001dc2f (diff)
downloadports-eae7bb6a90ebb38a372f12b5bd614db4c7b26ff3.tar.gz
ports-eae7bb6a90ebb38a372f12b5bd614db4c7b26ff3.zip
graphics/py-pyvista: New port: Pythonic interface to VTK
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-pyvista/Makefile25
-rw-r--r--graphics/py-pyvista/distinfo3
-rw-r--r--graphics/py-pyvista/pkg-descr13
4 files changed, 42 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 9794aa47bf19..fff0ee488c0a 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -904,6 +904,7 @@
SUBDIR += py-pytesseract
SUBDIR += py-python-poppler-qt5
SUBDIR += py-pyvips
+ SUBDIR += py-pyvista
SUBDIR += py-pyx
SUBDIR += py-qrencode
SUBDIR += py-railroad-diagrams
diff --git a/graphics/py-pyvista/Makefile b/graphics/py-pyvista/Makefile
new file mode 100644
index 000000000000..b4adc945fc5f
--- /dev/null
+++ b/graphics/py-pyvista/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= pyvista
+DISTVERSION= 0.34.1
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Pythonic interface to VTK
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}appdirs>0:devel/py-appdirs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}imageio>0:graphics/py-imageio@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scooby>=0.5.1:devel/py-scooby@${PY_FLAVOR} \
+ vtk9>0:math/vtk9
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-pyvista/distinfo b/graphics/py-pyvista/distinfo
new file mode 100644
index 000000000000..13c16a0948c6
--- /dev/null
+++ b/graphics/py-pyvista/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1653894421
+SHA256 (pyvista-0.34.1.tar.gz) = 3fe322d76c5e74797242026d338f948c4cebeee99efcc817fbf97e39a09ccfb0
+SIZE (pyvista-0.34.1.tar.gz) = 1398743
diff --git a/graphics/py-pyvista/pkg-descr b/graphics/py-pyvista/pkg-descr
new file mode 100644
index 000000000000..9e283bb6fcb3
--- /dev/null
+++ b/graphics/py-pyvista/pkg-descr
@@ -0,0 +1,13 @@
+PyVista is a helper module for the Visualization Toolkit (VTK) that
+wraps the VTK library through NumPy and direct array access through
+a variety of methods and classes. This package provides a Pythonic,
+well-documented interface exposing VTK's powerful visualization
+backend to facilitate rapid prototyping, analysis, and visual
+integration of spatially referenced datasets.
+
+This module can be used for scientific plotting for presentations and
+research papers as well as a supporting module for other mesh 3D
+rendering dependent Python modules; see Connections for a list of
+projects that leverage PyVista.
+
+WWW: https://github.com/pyvista/pyvista