aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2025-02-06 19:30:03 +0000
committerDima Panov <fluffy@FreeBSD.org>2025-02-06 19:34:58 +0000
commiteb68e13520c84f2834ad918be73bb5fdb4e126c2 (patch)
treefff806789692d74fb703a59d45f34992b23c8458
parent931f936e3073653756101549f96757995cb44fd0 (diff)
security/botan3: update to 3.7.1 release (+)
While here, install manpage as botan3.1 to avoid conflicts with botan2 package Release notes: https://botan.randombit.net/news.html#version-3-7-0-2025-02-04 \ https://botan.randombit.net/news.html#version-3-7-1-2025-02-05
-rw-r--r--security/botan3/Makefile12
-rw-r--r--security/botan3/distinfo6
-rw-r--r--security/botan3/files/patch-src_scripts_install.py11
-rw-r--r--security/botan3/pkg-plist8
4 files changed, 26 insertions, 11 deletions
diff --git a/security/botan3/Makefile b/security/botan3/Makefile
index 4f029ff2a362..a376d1c4fa7c 100644
--- a/security/botan3/Makefile
+++ b/security/botan3/Makefile
@@ -1,6 +1,5 @@
PORTNAME= botan
-DISTVERSION= 3.6.1
-PORTREVISION= 1
+DISTVERSION= 3.7.1
CATEGORIES= security
MASTER_SITES= http://botan.randombit.net/releases/
PKGNAMESUFFIX= ${_BOTANMAJOR}
@@ -38,7 +37,7 @@ LDFLAGS+= -pthread
DOCSDIR= ${LOCALBASE}/share/doc/${PORTNAME}-${PORTVERSION}
-_SOABIVER= 6
+_SOABIVER= 7
_BOTANMAJOR= ${DISTVERSION:S/./ /g:[1]}
_SHLIBVER= ${DISTVERSION:S/./ /g:[2]}
_SHLIBVERPATCH= ${DISTVERSION:S/./ /g:[3]}
@@ -52,7 +51,8 @@ OPTIONS_DEFINE= DOCS MANPAGES PYTHON SQLITE3
OPTIONS_DEFAULT= MANPAGES
OPTIONS_SUB= yes
-MANPAGES_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx@${PY_FLAVOR}
+MANPAGES_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}furo>=2022.6.21:textproc/py-furo@${PY_FLAVOR}
MANPAGES_CONFIGURE_WITH= sphinx
PYTHON_USES= python
@@ -67,13 +67,11 @@ SQLITE3_CONFIGURE_WITH= sqlite3
.if ${ARCH} == aarch64
CONFIGURE_ARGS+= --cc-abi="-march=armv8-a+crypto"
-.elif ${ARCH} == powerpc64
+.elif ${ARCH:Mpowerpc64*}
CONFIGURE_ARGS+= --cpu="ppc64"
.if !defined(MACHINE_CPU) || (defined(MACHINE_CPU) && !${MACHINE_ABI:Mvsx2})
CONFIGURE_ARGS+= --disable-powercrypto
.endif
-.elif ${ARCH} == powerpc64le
-CONFIGURE_ARGS+= --cpu="ppc64le"
.endif
.if ${ARCH} == i386 || ${ARCH} == amd64
diff --git a/security/botan3/distinfo b/security/botan3/distinfo
index 4147a3a69d7a..e90946f4ca79 100644
--- a/security/botan3/distinfo
+++ b/security/botan3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1730906988
-SHA256 (Botan-3.6.1.tar.xz) = 7cb8575d88d232c77174769d7f9e24bb44444160585986eebd66e749cb9a9089
-SIZE (Botan-3.6.1.tar.xz) = 7581864
+TIMESTAMP = 1738854685
+SHA256 (Botan-3.7.1.tar.xz) = fc0620463461caaea8e60f06711d7e437a3ad1eebd6de4ac29c14bbd901ccd1b
+SIZE (Botan-3.7.1.tar.xz) = 8659408
diff --git a/security/botan3/files/patch-src_scripts_install.py b/security/botan3/files/patch-src_scripts_install.py
new file mode 100644
index 000000000000..fe90cc30d50f
--- /dev/null
+++ b/security/botan3/files/patch-src_scripts_install.py
@@ -0,0 +1,11 @@
+--- src/scripts/install.py.orig 2025-02-06 16:19:41 UTC
++++ src/scripts/install.py
+@@ -246,7 +246,7 @@ def main(args):
+ makedirs(man1_dir)
+
+ copy_file(os.path.join(cfg['build_dir'], 'botan.1'),
+- os.path.join(man1_dir, 'botan.1'))
++ os.path.join(man1_dir, 'botan%d.1' % (ver_major)))
+
+ logging.info('Botan %s installation to %s complete', cfg['version'], cfg['prefix'])
+ return 0
diff --git a/security/botan3/pkg-plist b/security/botan3/pkg-plist
index 07a16aa97fe9..72104cc2071e 100644
--- a/security/botan3/pkg-plist
+++ b/security/botan3/pkg-plist
@@ -1,6 +1,7 @@
bin/botan%%BOTANMAJOR%%
include/botan-%%BOTANMAJOR%%/botan/aead.h
include/botan-%%BOTANMAJOR%%/botan/allocator.h
+include/botan-%%BOTANMAJOR%%/botan/api.h
include/botan-%%BOTANMAJOR%%/botan/argon2.h
include/botan-%%BOTANMAJOR%%/botan/argon2fmt.h
include/botan-%%BOTANMAJOR%%/botan/asio_async_ops.h
@@ -30,6 +31,8 @@ include/botan-%%BOTANMAJOR%%/botan/certstor.h
include/botan-%%BOTANMAJOR%%/botan/certstor_system.h
include/botan-%%BOTANMAJOR%%/botan/chacha_rng.h
include/botan-%%BOTANMAJOR%%/botan/cipher_mode.h
+include/botan-%%BOTANMAJOR%%/botan/cmce.h
+include/botan-%%BOTANMAJOR%%/botan/cmce_parameter_set.h
include/botan-%%BOTANMAJOR%%/botan/compiler.h
include/botan-%%BOTANMAJOR%%/botan/compression.h
include/botan-%%BOTANMAJOR%%/botan/concepts.h
@@ -47,6 +50,7 @@ include/botan-%%BOTANMAJOR%%/botan/dl_group.h
include/botan-%%BOTANMAJOR%%/botan/dlies.h
include/botan-%%BOTANMAJOR%%/botan/dsa.h
include/botan-%%BOTANMAJOR%%/botan/ec_point.h
+include/botan-%%BOTANMAJOR%%/botan/ec_point_format.h
include/botan-%%BOTANMAJOR%%/botan/ec_group.h
include/botan-%%BOTANMAJOR%%/botan/ec_apoint.h
include/botan-%%BOTANMAJOR%%/botan/ec_scalar.h
@@ -91,6 +95,7 @@ include/botan-%%BOTANMAJOR%%/botan/p11.h
include/botan-%%BOTANMAJOR%%/botan/p11_ecc_key.h
include/botan-%%BOTANMAJOR%%/botan/p11_ecdh.h
include/botan-%%BOTANMAJOR%%/botan/p11_ecdsa.h
+include/botan-%%BOTANMAJOR%%/botan/p11_mechanism.h
include/botan-%%BOTANMAJOR%%/botan/p11_object.h
include/botan-%%BOTANMAJOR%%/botan/p11_randomgenerator.h
include/botan-%%BOTANMAJOR%%/botan/p11_rsa.h
@@ -115,6 +120,7 @@ include/botan-%%BOTANMAJOR%%/botan/pkix_enums.h
include/botan-%%BOTANMAJOR%%/botan/pkix_types.h
%%HAS_PROCESSOR_RNG%%include/botan-%%BOTANMAJOR%%/botan/processor_rng.h
include/botan-%%BOTANMAJOR%%/botan/psk_db.h
+include/botan-%%BOTANMAJOR%%/botan/pss_params.h
include/botan-%%BOTANMAJOR%%/botan/pubkey.h
include/botan-%%BOTANMAJOR%%/botan/pwdhash.h
include/botan-%%BOTANMAJOR%%/botan/reducer.h
@@ -192,4 +198,4 @@ lib/libbotan-%%BOTANMAJOR%%.so.%%SOABIVER%%
lib/libbotan-%%BOTANMAJOR%%.so.%%SOABIVER%%.%%SHLIBVER%%.%%SHLIBVERPATCH%%
%%PYTHON%%%%PYTHON_SITELIBDIR%%/botan%%BOTANMAJOR%%.py
libdata/pkgconfig/botan-%%BOTANMAJOR%%.pc
-%%MANPAGES%%share/man/man1/botan.1.gz
+%%MANPAGES%%share/man/man1/botan%%BOTANMAJOR%%.1.gz